summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2009-04-28 01:45:38 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2009-04-28 01:45:38 +0000
commitb690489f94ab8797846d3cf389b44d022b32e233 (patch)
treeb85639eb2211f4b1290131e7ab1f415b2acfc4a4 /app-emulation/kvm-kmod
parentMY_P no longer needs to be defined since it's done in the eclass - just have ... (diff)
downloadgentoo-2-b690489f94ab8797846d3cf389b44d022b32e233.tar.gz
gentoo-2-b690489f94ab8797846d3cf389b44d022b32e233.tar.bz2
gentoo-2-b690489f94ab8797846d3cf389b44d022b32e233.zip
New kvm-kmod split from kvm
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/kvm-kmod')
-rw-r--r--app-emulation/kvm-kmod/ChangeLog10
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-85.ebuild68
-rw-r--r--app-emulation/kvm-kmod/metadata.xml19
3 files changed, 97 insertions, 0 deletions
diff --git a/app-emulation/kvm-kmod/ChangeLog b/app-emulation/kvm-kmod/ChangeLog
new file mode 100644
index 000000000000..ce8cc5aebb70
--- /dev/null
+++ b/app-emulation/kvm-kmod/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emulation/kvm-kmod
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.1 2009/04/28 01:45:38 dang Exp $
+
+*kvm-kmod-85 (28 Apr 2009)
+
+ 28 Apr 2009; Daniel Gryniewicz <dang@gentoo.org> +metadata.xml,
+ +kvm-kmod-85.ebuild:
+ New kvm modules package; upstream split them up
+
diff --git a/app-emulation/kvm-kmod/kvm-kmod-85.ebuild b/app-emulation/kvm-kmod/kvm-kmod-85.ebuild
new file mode 100644
index 000000000000..2956e48f82cc
--- /dev/null
+++ b/app-emulation/kvm-kmod/kvm-kmod-85.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-85.ebuild,v 1.1 2009/04/28 01:45:38 dang Exp $
+
+EAPI="2"
+
+inherit eutils linux-mod
+
+MY_PN="${PN}-devel"
+MY_P="${MY_PN}-${PV}"
+
+# Patchset git repo is at http://github.com/dang/kvm-patches/tree/master
+PATCHSET="kvm-patches-20090218"
+SRC_URI="mirror://sourceforge/kvm/${MY_P}.tar.gz"
+
+DESCRIPTION="Kernel-based Virtual Machine kernel modules"
+HOMEPAGE="http://www.linux-kvm.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ !<app-emulation/kvm-85"
+
+S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ linux-info_pkg_setup
+ if ! linux_chkconfig_present KVM; then
+ eerror "KVM now needs CONFIG_KVM built into your kernel, even"
+ eerror "if you're using the external modules from this package."
+ eerror "Please enable KVM support in your kernel, found at:"
+ eerror
+ eerror " Virtualization"
+ eerror " Kernel-based Virtual Machine (KVM) support"
+ eerror
+ die "KVM support not detected!"
+ fi
+ BUILD_TARGETS="all"
+ MODULE_NAMES="kvm(kvm:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-intel(kvm:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-amd(kvm:${S}:${S}/x86)"
+ linux-mod_pkg_setup
+}
+
+src_configure() {
+ local conf_opts
+
+ conf_opts="--kerneldir=$KV_DIR"
+
+ if has_multilib_profile && [[ "${DEFAULT_ABI}" == "x86" ]] ; then
+ conf_opts="$conf_opts --arch=x86"
+ fi
+
+ ./configure ${conf_opts} || die "configure failed"
+}
+
+src_compile() {
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+}
+
diff --git a/app-emulation/kvm-kmod/metadata.xml b/app-emulation/kvm-kmod/metadata.xml
new file mode 100644
index 000000000000..bc45e90dc0a0
--- /dev/null
+++ b/app-emulation/kvm-kmod/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>none</herd>
+ <maintainer>
+ <email>dang@gentoo.org</email>
+ <name>Daniel Gryniewicz</name>
+ </maintainer>
+ <maintainer>
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ </maintainer>
+ <longdescription lang="en">
+ KVM (for Kernel-based Virtual Machine) is a full virtualization solution
+ for Linux on x86 hardware containing virtualization extensions (Intel VT
+ or AMD-V). This package contains kernel modules for kvm.
+ </longdescription>
+</pkgmetadata>
+