summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso <nimiux@gentoo.org>2012-11-11 19:32:07 +0000
committerJosé María Alonso <nimiux@gentoo.org>2012-11-11 19:32:07 +0000
commit05b840805eb023685d324d32d14bb564aa31dd20 (patch)
treee4cd5b144f832cf30dcf6444edfbafcf7135ef49 /app-emulation/free42
parentAdded || die, bug #441544 (diff)
downloadgentoo-2-05b840805eb023685d324d32d14bb564aa31dd20.tar.gz
gentoo-2-05b840805eb023685d324d32d14bb564aa31dd20.tar.bz2
gentoo-2-05b840805eb023685d324d32d14bb564aa31dd20.zip
Version bump 1.4.75
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key D628E536)
Diffstat (limited to 'app-emulation/free42')
-rw-r--r--app-emulation/free42/ChangeLog8
-rw-r--r--app-emulation/free42/files/free42-1.4.75-fix-alsa.patch11
-rw-r--r--app-emulation/free42/free42-1.4.75.ebuild47
-rw-r--r--app-emulation/free42/metadata.xml25
4 files changed, 80 insertions, 11 deletions
diff --git a/app-emulation/free42/ChangeLog b/app-emulation/free42/ChangeLog
index 98c706613d45..542a2a0ea840 100644
--- a/app-emulation/free42/ChangeLog
+++ b/app-emulation/free42/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/free42
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/free42/ChangeLog,v 1.6 2012/07/05 16:06:12 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/free42/ChangeLog,v 1.7 2012/11/11 19:32:07 nimiux Exp $
+
+*free42-1.4.75 (11 Nov 2012)
+
+ 11 Nov 2012; Chema Alonso <nimiux@gentoo.org> +free42-1.4.75.ebuild,
+ +files/free42-1.4.75-fix-alsa.patch, metadata.xml:
+ Version bump
05 Jul 2012; Chema Alonso <nimiux@gentoo.org> free42-1.4.74.ebuild:
Remove --hash-style=both wrt bug #424503 comment #7.
diff --git a/app-emulation/free42/files/free42-1.4.75-fix-alsa.patch b/app-emulation/free42/files/free42-1.4.75-fix-alsa.patch
new file mode 100644
index 000000000000..bbcb24907e0a
--- /dev/null
+++ b/app-emulation/free42/files/free42-1.4.75-fix-alsa.patch
@@ -0,0 +1,11 @@
+diff -Nur a/gtk/audio_alsa.cc b/gtk/audio_alsa.cc
+--- a/gtk/audio_alsa.cc 2012-10-27 21:14:48.000000000 +0200
++++ b/gtk/audio_alsa.cc 2012-11-11 20:26:28.779917284 +0100
+@@ -23,6 +23,7 @@
+ #include <sys/time.h>
+ #include <pthread.h>
+ #include <dlfcn.h>
++#include <math.h>
+
+ // We want to be able to run even if libasound is not present, so we have to
+ // link it manually using dlopen() and dlsym(). These are the functions we are
diff --git a/app-emulation/free42/free42-1.4.75.ebuild b/app-emulation/free42/free42-1.4.75.ebuild
new file mode 100644
index 000000000000..00fef4cd8692
--- /dev/null
+++ b/app-emulation/free42/free42-1.4.75.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/free42/free42-1.4.75.ebuild,v 1.1 2012/11/11 19:32:05 nimiux Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An HP-42S Calculator Simulator"
+HOMEPAGE="http://thomasokken.com/free42/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa"
+
+DEPEND="dev-libs/atk
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango
+ media-libs/alsa-lib"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i -e '/^CXXFLAGS :=/{s/-g //;s/$/ \$\{CXXFLAGS\}/}' \
+ "${S}/gtk/Makefile" || die
+ sed -i -e '/^LDFLAGS =/{s/=/:=/;s/$/ \$\{LDFLAGS\}/}' \
+ "${S}/gtk/Makefile" || die
+ sed -i -e '/^LDFLAGS +=/d' "${S}/gtk/Makefile" || die
+ epatch "${FILESDIR}"/${P}-fix-alsa.patch
+}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="AUDIO_ALSA=yes"
+ emake -j1 CXX="$(tc-getCXX)" ${myconf} -C "${S}/gtk"
+}
+
+src_install() {
+ dodoc CREDITS HISTORY README TODO
+ dobin gtk/free42bin
+}
diff --git a/app-emulation/free42/metadata.xml b/app-emulation/free42/metadata.xml
index ea55ea661bbe..ae876330a77d 100644
--- a/app-emulation/free42/metadata.xml
+++ b/app-emulation/free42/metadata.xml
@@ -1,14 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>nimiux@gentoo.org</email>
- <name>Chema Alonso</name>
-</maintainer>
-<longdescription lang="en">
- An HP-42S Calculator Simulator
-</longdescription>
-<longdescription lang="es">
- Un simulador de la calculadora HP-42S
-</longdescription>
+ <maintainer>
+ <email>nimiux@gentoo.org</email>
+ <name>Chema Alonso</name>
+ </maintainer>
+ <longdescription lang="en">
+ An HP-42S Calculator Simulator
+ </longdescription>
+ <longdescription lang="es">
+ Un simulador de la calculadora HP-42S
+ </longdescription>
+ <use>
+ <flag name="alsa">
+ Adds support for Advanced Linux Sound Architecture
+ </flag>
+ </use>
</pkgmetadata>