summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-07-29 02:22:28 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-07-29 02:22:28 +0000
commit86e5a52887758cdb19ceec78523b72387858c543 (patch)
tree1e548901b6fbf3cde0bcf9eb709b4463402ab041 /app-emulation/basiliskII
parentversion bump (bug 20086) (diff)
downloadgentoo-2-86e5a52887758cdb19ceec78523b72387858c543.tar.gz
gentoo-2-86e5a52887758cdb19ceec78523b72387858c543.tar.bz2
gentoo-2-86e5a52887758cdb19ceec78523b72387858c543.zip
version bump (bug 20086)
Diffstat (limited to 'app-emulation/basiliskII')
-rw-r--r--app-emulation/basiliskII/ChangeLog7
-rw-r--r--app-emulation/basiliskII/Manifest4
-rw-r--r--app-emulation/basiliskII/basiliskII-1.0.0.ebuild81
-rw-r--r--app-emulation/basiliskII/files/digest-basiliskII-1.0.01
4 files changed, 90 insertions, 3 deletions
diff --git a/app-emulation/basiliskII/ChangeLog b/app-emulation/basiliskII/ChangeLog
index 4edd01d8ff4d..e4298b3da3cf 100644
--- a/app-emulation/basiliskII/ChangeLog
+++ b/app-emulation/basiliskII/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/basiliskII
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/ChangeLog,v 1.7 2003/05/15 13:03:02 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/ChangeLog,v 1.8 2003/07/29 02:22:25 msterret Exp $
+
+*basiliskII-1.0.0 (28 Jul 2003)
+
+ 28 Jul 2003; Michael Sterrett <msterret@gentoo.org> basiliskII-1.0.0.ebuild:
+ version bump (bug 20086)
15 May 2003; Patrick Kursawe <phosphan@gentoo.org> basiliskII-0.9.0.ebuild:
Corrected homepage (bug 21056)
diff --git a/app-emulation/basiliskII/Manifest b/app-emulation/basiliskII/Manifest
index 3419f47faead..7ea0b8a5098b 100644
--- a/app-emulation/basiliskII/Manifest
+++ b/app-emulation/basiliskII/Manifest
@@ -1,5 +1,5 @@
-MD5 ec2f2288ea0ff1713007fb6d1f8919e9 ChangeLog 1480
+MD5 e862694921214227bd6ca679df024160 ChangeLog 1620
MD5 60f9e87b6c628a754c067771510d0f36 basiliskII-0.9.0.ebuild 2573
-MD5 b8c5d6bee4e67f82d3e9a305830f8e2c basiliskII-1.0.0.ebuild 2548
+MD5 7dd0d975238ac003177dde3c5f74cdd2 basiliskII-1.0.0.ebuild 2589
MD5 d45a6f9ac5136a79e49778d98cf973b8 files/digest-basiliskII-0.9.0 75
MD5 1cbb0fab815fa2bc2c502966bdf62294 files/digest-basiliskII-1.0.0 79
diff --git a/app-emulation/basiliskII/basiliskII-1.0.0.ebuild b/app-emulation/basiliskII/basiliskII-1.0.0.ebuild
new file mode 100644
index 000000000000..cc7fb289dd60
--- /dev/null
+++ b/app-emulation/basiliskII/basiliskII-1.0.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/basiliskII-1.0.0.ebuild,v 1.1 2003/07/29 02:22:25 msterret Exp $
+
+IUSE="X gtk xv esd dga"
+
+inherit flag-o-matic
+
+### This package requires a Mac II/Classic ROM, A Mac OS Image
+### Mac OS 7.5.3r2 is available freely from the Apple Homepage
+### System ROMS can be retreived from a 'real' Mac, See info/man pages
+
+DESCRIPTION="BasiliskII Macintosh Emulator"
+HOMEPAGE="http://gwenole.beauchesne.online.fr/basilisk2/"
+LICENSE="GPL-2 | LGPL-2.1"
+KEYWORDS="x86 -ppc"
+SLOT="0"
+
+### We'll set $S Manually, it's version dependant, and nested strangely.
+S=${WORKDIR}/BasiliskII-jit-1.0/src/Unix
+
+### fbdev support in the stable release... the cvs branch is broken, period!
+### gtk and esd support are compile time options, we'll check the usual
+### use variables here and set ./configure options accordingly
+
+DEPEND="gtk? ( x11-libs/gtk+ )
+ esd? ( media-sound/esound )
+ >=sys-apps/sed-4"
+
+SRC_URI="http://hometown.aol.de/wimdk/files/BasiliskII-jit-1.0-mdk-src.tar.bz2"
+
+src_compile() {
+ #fpu_x86 doesnt compile properly if -O3 or greater :(
+ replace-flags -O[3-9] -O2
+
+ local myflags
+
+### Default ./configure options are all =yes by default. we'll check for
+### and use -values and switch them accordingly
+
+ use X || myflags="${myflags} --with-x=no"
+ use esd || myflags="${myflags} --with-esd=no"
+ use gtk || myflags="${myflags} --with-gtk=no"
+ use dga || myflags="${myflags} --with-dga=no"
+ use xv || myflags="${myflags} --enable-xf86-vidmode=no"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myflags} || die "./configure failed"
+
+ #hack to link against libstdc++ for gcc3.x compatibility
+ sed -i \
+ -e 's:-o $(OBJ_DIR)/gencpu:-lstdc++ -o $(OBJ_DIR)/gencpu:' \
+ Makefile || die "sed Makefile failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "make install failed"
+
+ cd ../..
+ dodoc ChangeLog INSTALL README TECH TODO TODO.JIT
+
+### Networking is _disabled_ in this revision, hopefully -r2 will
+### resolve the permissions issue / linux src compilation problem
+### that prevents it's inclusion
+
+### Uncomment the following, and read the manual _carefully_ if you really
+### need networking, this will create a sheep_net.o kernel module that
+### provides (effectivly) an ethernet bridge between basliskII and the kernel
+
+# make modules
+}
diff --git a/app-emulation/basiliskII/files/digest-basiliskII-1.0.0 b/app-emulation/basiliskII/files/digest-basiliskII-1.0.0
new file mode 100644
index 000000000000..3679057027e2
--- /dev/null
+++ b/app-emulation/basiliskII/files/digest-basiliskII-1.0.0
@@ -0,0 +1 @@
+MD5 de61127f222213d066ac8317cb87e625 BasiliskII-jit-1.0-mdk-src.tar.bz2 597741