summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-12-08 13:21:04 +0000
committerUlrich Müller <ulm@gentoo.org>2011-12-08 13:21:04 +0000
commitf47d7ee8ea95a8dea750735814f86b02c73ba345 (patch)
treeff1e0795cb98c0b22784fabcb7bb841e00802708 /app-emacs
parentRemoved not needed patch anymore. Cause was bug #361385 (diff)
downloadgentoo-2-f47d7ee8ea95a8dea750735814f86b02c73ba345.tar.gz
gentoo-2-f47d7ee8ea95a8dea750735814f86b02c73ba345.tar.bz2
gentoo-2-f47d7ee8ea95a8dea750735814f86b02c73ba345.zip
Version bump, bug 386465.
(Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/proofgeneral/ChangeLog10
-rw-r--r--app-emacs/proofgeneral/files/proofgeneral-4.1-emacs-24.patch73
-rw-r--r--app-emacs/proofgeneral/proofgeneral-4.1.ebuild58
3 files changed, 139 insertions, 2 deletions
diff --git a/app-emacs/proofgeneral/ChangeLog b/app-emacs/proofgeneral/ChangeLog
index afb314374afd..970bb918983c 100644
--- a/app-emacs/proofgeneral/ChangeLog
+++ b/app-emacs/proofgeneral/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/proofgeneral
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/proofgeneral/ChangeLog,v 1.32 2010/12/07 01:50:23 ulm Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/proofgeneral/ChangeLog,v 1.33 2011/12/08 13:21:03 ulm Exp $
+
+*proofgeneral-4.1 (08 Dec 2011)
+
+ 08 Dec 2011; Ulrich Mueller <ulm@gentoo.org> +proofgeneral-4.1.ebuild,
+ +files/proofgeneral-4.1-emacs-24.patch:
+ Version bump, bug 386465.
07 Dec 2010; Ulrich Mueller <ulm@gentoo.org> proofgeneral-4.0.ebuild:
Require Emacs version 23 at least. Don't compile and install bundled
diff --git a/app-emacs/proofgeneral/files/proofgeneral-4.1-emacs-24.patch b/app-emacs/proofgeneral/files/proofgeneral-4.1-emacs-24.patch
new file mode 100644
index 000000000000..2a9571afa469
--- /dev/null
+++ b/app-emacs/proofgeneral/files/proofgeneral-4.1-emacs-24.patch
@@ -0,0 +1,73 @@
+https://bugs.gentoo.org/386465
+
+--- a/generic/proof-menu.el
++++ b/generic/proof-menu.el
+@@ -49,7 +49,7 @@ without adjusting window layout.&quot;
+ ;; trace buffer, etc. (Makes less sense from the menu, though,
+ ;; where it seems more natural just to rotate from last position)
+ (cond
+- ((and (interactive-p)
++ ((and (called-interactively-p 'any)
+ (eq last-command 'proof-display-some-buffers))
+ (incf proof-display-some-buffers-count))
+ (t
+--- a/generic/proof-script.el
++++ b/generic/proof-script.el
+@@ -431,13 +431,13 @@ Point must be after the locked region or this will signal an error.&quot;
+ If called interactively or SWITCH is non-nil, switch to script buffer.
+ If called interactively, a mark is set at the current location with `push-mark'&quot;
+ (interactive)
+- (if (and proof-script-buffer (interactive-p))
++ (if (and proof-script-buffer (called-interactively-p 'any))
+ (push-mark))
+ (proof-with-script-buffer
+ (if ;; there is an active scripting buffer and it's not displayed
+ (and proof-script-buffer
+ (not (get-buffer-window proof-script-buffer))
+- (or switch (interactive-p)))
++ (or switch (called-interactively-p 'any)))
+ ;; display it
+ (switch-to-buffer proof-script-buffer))
+ (goto-char (proof-unprocessed-begin))))
+@@ -1260,7 +1260,7 @@ activation is considered to have failed and an error is given.&quot;
+ ;; immediately because scripting has been turned on now.
+ (if proof-activate-scripting-hook
+ (let
+- ((activated-interactively (interactive-p)))
++ ((activated-interactively (called-interactively-p 'any)))
+ (setq proof-shell-last-output-kind nil)
+ (run-hooks 'proof-activate-scripting-hook)
+ ;; If activate scripting functions caused an error,
+--- a/generic/proof-splash.el
++++ b/generic/proof-splash.el
+@@ -287,7 +287,7 @@ binding to remove this buffer.&quot;
+ (progn
+ ;; disable ordinary emacs splash
+ (setq inhibit-startup-message t)
+- (proof-splash-display-screen (not (interactive-p))))
++ (proof-splash-display-screen (not (called-interactively-p 'any))))
+ ;; Otherwise, a message
+ (message &quot;Welcome to %s Proof General!&quot; proof-assistant))
+ (setq proof-splash-seen t)))
+--- a/isar/isabelle-system.el
++++ b/isar/isabelle-system.el
+@@ -292,7 +292,7 @@ for you, you should disable this behaviour.&quot;
+ &quot;Refresh isabelle-logics-menu-entries, returning new entries.&quot;
+ (interactive)
+ (if (and isabelle-refresh-logics
+- (or isabelle-time-to-refresh-logics (interactive-p)))
++ (or isabelle-time-to-refresh-logics (called-interactively-p 'any)))
+ (progn
+ (setq isabelle-logics-available (isa-tool-list-logics))
+ (isabelle-logics-menu-calculate)
+--- a/lib/scomint.el
++++ b/lib/scomint.el
+@@ -251,7 +251,7 @@ NO-NEWLINE is non-nil.&quot;
+ (save-excursion
+ (condition-case nil
+ (goto-char
+- (if (interactive-p) scomint-last-input-end scomint-last-output-start))
++ (if (called-interactively-p 'any) scomint-last-input-end scomint-last-output-start))
+ (error nil))
+ (while (re-search-forward &quot;\r+$&quot; pmark t)
+ (replace-match &quot;&quot; t t)))))
diff --git a/app-emacs/proofgeneral/proofgeneral-4.1.ebuild b/app-emacs/proofgeneral/proofgeneral-4.1.ebuild
new file mode 100644
index 000000000000..0d4f8d9f04dd
--- /dev/null
+++ b/app-emacs/proofgeneral/proofgeneral-4.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/proofgeneral/proofgeneral-4.1.ebuild,v 1.1 2011/12/08 13:21:03 ulm Exp $
+
+EAPI=4
+NEED_EMACS=23
+
+inherit elisp
+
+MY_PN="ProofGeneral"
+DESCRIPTION="A generic interface for proof assistants"
+HOMEPAGE="http://proofgeneral.inf.ed.ac.uk/"
+SRC_URI="http://proofgeneral.inf.ed.ac.uk/releases/${MY_PN}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=app-emacs/mmm-mode-0.4.8-r2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+ELISP_PATCHES="${P}-emacs-24.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+ sed -i -e '/^OTHER_ELISP/s:contrib/mmm::' Makefile || die
+}
+
+src_compile() {
+ # remove precompiled lisp files
+ emake clean
+ emake -j1 compile EMACS=emacs
+}
+
+src_install() {
+ emake -j1 install EMACS=emacs PREFIX="${D}"/usr
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" ${MY_PN} || die
+
+ doinfo doc/*.info*
+ doman doc/proofgeneral.1
+ dohtml doc/ProofGeneral/*.html doc/PG-adapting/*.html
+ dodoc AUTHORS BUGS CHANGES COMPATIBILITY FAQ INSTALL README REGISTER
+
+ # clean up
+ rm -rf "${D}/usr/share/emacs/site-lisp/site-start.d"
+ rm -rf "${D}/usr/share/application-registry"
+ rm -rf "${D}/usr/share/mime-info"
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Please register your use of Proof General on the web at:"
+ elog " http://proofgeneral.inf.ed.ac.uk/register "
+ elog "(see the REGISTER file for more information)"
+}