summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-09-09 11:44:30 +0000
committerUlrich Müller <ulm@gentoo.org>2010-09-09 11:44:30 +0000
commitd2e1c79ad9e7dfd8f68a48d8ff52b70d85b00301 (patch)
treec7123695bb2fd5d82c28fd2aa4299d78537cf38d /app-emacs
parentFixed 402-oggzfbsd.patch (bug #336504). (diff)
downloadgentoo-2-d2e1c79ad9e7dfd8f68a48d8ff52b70d85b00301.tar.gz
gentoo-2-d2e1c79ad9e7dfd8f68a48d8ff52b70d85b00301.tar.bz2
gentoo-2-d2e1c79ad9e7dfd8f68a48d8ff52b70d85b00301.zip
Fix test failure caused by wrong load-path, bug 319385.
(Portage version: 2.2_rc71/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/edb/ChangeLog8
-rw-r--r--app-emacs/edb/edb-1.31.ebuild9
-rw-r--r--app-emacs/edb/files/edb-1.31-skram-path.patch11
3 files changed, 22 insertions, 6 deletions
diff --git a/app-emacs/edb/ChangeLog b/app-emacs/edb/ChangeLog
index a0aa2ae3c9d2..6aeac86a1b51 100644
--- a/app-emacs/edb/ChangeLog
+++ b/app-emacs/edb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/edb
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/edb/ChangeLog,v 1.11 2009/01/29 01:25:15 fauli Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/edb/ChangeLog,v 1.12 2010/09/09 11:44:30 ulm Exp $
+
+ 09 Sep 2010; Ulrich Mueller <ulm@gentoo.org> edb-1.31.ebuild,
+ +files/edb-1.31-skram-path.patch:
+ Fix test failure caused by wrong load-path, bug 319385.
29 Jan 2009; Christian Faulhammer <fauli@gentoo.org>
-files/edb-info-direntry.patch, -edb-1.29.ebuild:
diff --git a/app-emacs/edb/edb-1.31.ebuild b/app-emacs/edb/edb-1.31.ebuild
index dd24eff8c238..4852848e4674 100644
--- a/app-emacs/edb/edb-1.31.ebuild
+++ b/app-emacs/edb/edb-1.31.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/edb/edb-1.31.ebuild,v 1.1 2008/05/29 16:24:19 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/edb/edb-1.31.ebuild,v 1.2 2010/09/09 11:44:30 ulm Exp $
inherit elisp eutils
@@ -13,11 +13,12 @@ SLOT="0"
KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
IUSE=""
+ELISP_PATCHES="${P}-skram-path.patch"
SITEFILE="52${PN}-gentoo.el"
src_compile() {
- econf || die "econf failed"
- emake -j1 || die "emake failed"
+ econf
+ emake -j1 || die
}
src_install() {
diff --git a/app-emacs/edb/files/edb-1.31-skram-path.patch b/app-emacs/edb/files/edb-1.31-skram-path.patch
new file mode 100644
index 000000000000..75921ca00160
--- /dev/null
+++ b/app-emacs/edb/files/edb-1.31-skram-path.patch
@@ -0,0 +1,11 @@
+--- edb-1.31-orig/skram/GNUmakefile.in
++++ edb-1.31/skram/GNUmakefile.in
+@@ -48,7 +48,7 @@
+ #
+ # Until that change is distributed, here is a workaround:
+ wily-emacs = $(ebatch) \
+- --eval '(add-to-list (quote load-path) (expand-file-name "$(topdir)"))' \
++ --eval '(add-to-list (quote load-path) (expand-file-name "$(topdir)/lisp"))' \
+ --eval '(require (quote database))'
+
+ sk2: skram.data