summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-07-17 15:09:27 +0000
committerUlrich Müller <ulm@gentoo.org>2009-07-17 15:09:27 +0000
commitc679a156cbf9427fd31134c9ce8241c9729e5b9b (patch)
tree4f08915c05532f893635ee96fafa87a81294ff54 /app-emacs
parentFix description, thanks mraudsepp (diff)
downloadgentoo-2-c679a156cbf9427fd31134c9ce8241c9729e5b9b.tar.gz
gentoo-2-c679a156cbf9427fd31134c9ce8241c9729e5b9b.tar.bz2
gentoo-2-c679a156cbf9427fd31134c9ce8241c9729e5b9b.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/emacs-daemon/ChangeLog11
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-0.15.ebuild41
2 files changed, 49 insertions, 3 deletions
diff --git a/app-emacs/emacs-daemon/ChangeLog b/app-emacs/emacs-daemon/ChangeLog
index e79943aa6027..88c15a3151e3 100644
--- a/app-emacs/emacs-daemon/ChangeLog
+++ b/app-emacs/emacs-daemon/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for app-emacs/emacs-daemon
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/ChangeLog,v 1.16 2009/07/17 08:35:04 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/ChangeLog,v 1.17 2009/07/17 15:09:27 ulm Exp $
- 17 Jul 2009; Ulrich Mueller <ulm@gentoo.org> emacs-daemon-0.14.ebuild:
- Remove backwards compatibility code.
+*emacs-daemon-0.15 (17 Jul 2009)
+
+ 17 Jul 2009; Ulrich Mueller <ulm@gentoo.org> emacs-daemon-0.14.ebuild,
+ +emacs-daemon-0.15.ebuild:
+ Remove compatibility code that was needed for Emacs 23.0.90 and earlier.
+ Version bump; remove OpenRC dependency, as the init script should now be
+ compatible with baselayout-1.
03 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
-emacs-daemon-0.13.ebuild:
diff --git a/app-emacs/emacs-daemon/emacs-daemon-0.15.ebuild b/app-emacs/emacs-daemon/emacs-daemon-0.15.ebuild
new file mode 100644
index 000000000000..ee898a242449
--- /dev/null
+++ b/app-emacs/emacs-daemon/emacs-daemon-0.15.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/emacs-daemon-0.15.ebuild,v 1.1 2009/07/17 15:09:27 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Gentoo support for Emacs running as a server in the background"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/emacs-23"
+RDEPEND="${DEPEND}"
+
+SITEFILE="10${PN}-gentoo.el"
+
+pkg_setup() {
+ local has_daemon=$(${EMACS} ${EMACSFLAGS} \
+ --eval "(princ (fboundp 'daemonp))")
+ if [ "${has_daemon}" != t ]; then
+ ewarn "Your current Emacs version does not support running as a daemon"
+ ewarn "which is required for ${CATEGORY}/${PN}."
+ ewarn "Use \"eselect emacs\" to select an Emacs version >= 23."
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ newinitd emacs.rc emacs || die
+ newconfd emacs.conf emacs || die
+ exeinto /usr/libexec/emacs
+ doexe emacs-wrapper.sh || die
+ elisp-site-file-install "${SITEFILE}" || die
+ keepdir /var/run/emacs || die
+ dodoc README ChangeLog || die
+}