summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-03-16 11:59:52 +0000
committerUlrich Müller <ulm@gentoo.org>2010-03-16 11:59:52 +0000
commit85f28accc0be9c1c9f83f450da5d8b2d1edf653c (patch)
treec877ac1a062d80e97d6dc27fe0b0d8b8fbc22012 /app-emacs
parentBump to upstream released version. (diff)
downloadgentoo-2-85f28accc0be9c1c9f83f450da5d8b2d1edf653c.tar.gz
gentoo-2-85f28accc0be9c1c9f83f450da5d8b2d1edf653c.tar.bz2
gentoo-2-85f28accc0be9c1c9f83f450da5d8b2d1edf653c.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/vm/ChangeLog7
-rw-r--r--app-emacs/vm/vm-8.1.0.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/app-emacs/vm/ChangeLog b/app-emacs/vm/ChangeLog
index 4a520eacb53d..281d3db187b4 100644
--- a/app-emacs/vm/ChangeLog
+++ b/app-emacs/vm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/vm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/ChangeLog,v 1.89 2010/02/02 09:09:38 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/ChangeLog,v 1.90 2010/03/16 11:59:52 ulm Exp $
+
+*vm-8.1.0 (16 Mar 2010)
+
+ 16 Mar 2010; Ulrich Mueller <ulm@gentoo.org> +vm-8.1.0.ebuild:
+ Version bump.
*vm-8.1.0_beta2 (02 Feb 2010)
diff --git a/app-emacs/vm/vm-8.1.0.ebuild b/app-emacs/vm/vm-8.1.0.ebuild
new file mode 100644
index 000000000000..3a867fb0e664
--- /dev/null
+++ b/app-emacs/vm/vm-8.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/vm-8.1.0.ebuild,v 1.1 2010/03/16 11:59:52 ulm Exp $
+
+inherit elisp eutils
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="The VM mail reader for Emacs"
+HOMEPAGE="http://www.nongnu.org/viewmail/"
+SRC_URI="http://launchpad.net/vm/${PV%.*}.x/${MY_PV}/+download/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="bbdb ssl"
+
+DEPEND="bbdb? ( app-emacs/bbdb )"
+RDEPEND="!app-emacs/u-vm-color
+ ${DEPEND}
+ ssl? ( net-misc/stunnel )"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use bbdb; then
+ elog "Excluding vm-pcrisis.el since the \"bbdb\" USE flag is not set."
+ epatch "${FILESDIR}/vm-8.0-no-pcrisis.patch"
+ fi
+}
+
+src_compile() {
+ econf \
+ --with-emacs="emacs" \
+ --with-pixmapdir="${SITEETC}/${PN}" \
+ $(use bbdb && echo "--with-other-dirs=${SITELISP}/bbdb")
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc CHANGES NEWS README TODO example.vm || die "dodoc failed"
+}