summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-06 06:53:53 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-06 06:53:53 +0000
commit85438fa392a755872a0fda213bfa57988b763ed3 (patch)
tree8bdd71d4368949899702ac942593d0631c26d9f6 /app-emacs
parentinitial import (diff)
downloadgentoo-2-85438fa392a755872a0fda213bfa57988b763ed3.tar.gz
gentoo-2-85438fa392a755872a0fda213bfa57988b763ed3.tar.bz2
gentoo-2-85438fa392a755872a0fda213bfa57988b763ed3.zip
initial import
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/lua-mode/ChangeLog8
-rw-r--r--app-emacs/lua-mode/Manifest5
-rw-r--r--app-emacs/lua-mode/files/70lua-mode-gentoo.el9
-rw-r--r--app-emacs/lua-mode/files/digest-lua-mode-1.261
-rw-r--r--app-emacs/lua-mode/lua-mode-1.26.ebuild25
5 files changed, 46 insertions, 2 deletions
diff --git a/app-emacs/lua-mode/ChangeLog b/app-emacs/lua-mode/ChangeLog
new file mode 100644
index 000000000000..1b3e5315f5ea
--- /dev/null
+++ b/app-emacs/lua-mode/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-emacs/lua-mode
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/lua-mode/ChangeLog,v 1.1 2003/10/06 06:53:49 mkennedy Exp $
+
+*lua-mode-1.26 (05 Oct 2003)
+
+ 05 Oct 2003; Matthew Kennedy <mkennedy@gentoo.org> :
+ Initial import. Ebuild submitted by Jeremy Maitin-Shepard <jbms@attbi.com>.
diff --git a/app-emacs/lua-mode/Manifest b/app-emacs/lua-mode/Manifest
index a259764d78d4..450b5ccf7d59 100644
--- a/app-emacs/lua-mode/Manifest
+++ b/app-emacs/lua-mode/Manifest
@@ -1,3 +1,4 @@
-MD5 125ee013081b112d56a1d15507d72ef2 ChangeLog 3674
-MD5 544c51b9ac6b95db847b9cd89e888f69 lua-mode-1.26.ebuild 688
+MD5 592ea015bfabb2aaa0e346f1d48e3f43 ChangeLog 384
+MD5 2fabc6129ebc741b1fbcba8e90eceabe lua-mode-1.26.ebuild 774
MD5 08f5bc31d5db2fbb018155ce81a18812 files/digest-lua-mode-1.26 64
+MD5 5f162ad79174f8ec9eb51309facbf431 files/70lua-mode-gentoo.el 282
diff --git a/app-emacs/lua-mode/files/70lua-mode-gentoo.el b/app-emacs/lua-mode/files/70lua-mode-gentoo.el
new file mode 100644
index 000000000000..8f308219662c
--- /dev/null
+++ b/app-emacs/lua-mode/files/70lua-mode-gentoo.el
@@ -0,0 +1,9 @@
+
+;;; lua-mode site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'lua-mode "lua-mode" "Mode for editing Lua scripts" t)
+(setq auto-mode-alist
+ (append '(("\\.lua$" . lua-mode))
+ auto-mode-alist))
+(setq lua-default-application "/usr/bin/lua")
diff --git a/app-emacs/lua-mode/files/digest-lua-mode-1.26 b/app-emacs/lua-mode/files/digest-lua-mode-1.26
new file mode 100644
index 000000000000..9d7416d6a8a3
--- /dev/null
+++ b/app-emacs/lua-mode/files/digest-lua-mode-1.26
@@ -0,0 +1 @@
+MD5 1ec31e2fbe8d42863501bfa9a0cb6c0b lua-mode-1.26.tar.gz 10159
diff --git a/app-emacs/lua-mode/lua-mode-1.26.ebuild b/app-emacs/lua-mode/lua-mode-1.26.ebuild
new file mode 100644
index 000000000000..1d52e8a34354
--- /dev/null
+++ b/app-emacs/lua-mode/lua-mode-1.26.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/lua-mode/lua-mode-1.26.ebuild,v 1.1 2003/10/06 06:53:49 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="An Emacs major mode for editing Lua scripts"
+HOMEPAGE="http://lua-users.org/wiki/LuaEditorSupport"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/emacs"
+
+SITEFILE="70${PN}-gentoo.el"
+
+src_unpack() {
+ elisp_src_unpack
+ # Fix it so that it can be byte compiled. Apparently, it
+ # wasn't tested with the byte compiler.
+ local sed_expr='s/eval-when-compile/progn/g'
+ cp "${S}/lua-mode.el" "${T}"
+ sed -e "${sed_expr}" "${T}/lua-mode.el" > "${S}/lua-mode.el"
+}