summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-09-22 07:09:03 +0000
committerUlrich Müller <ulm@gentoo.org>2009-09-22 07:09:03 +0000
commit729b113c90249ffc0cb028e8a149b92246df7c10 (patch)
treed3002c7de50e74905533e990c05d48c9b3e6b02d /app-emacs
parentx11-base/xorg-x11: fix xorg.conf removal (see bug #278268) (diff)
downloadgentoo-2-729b113c90249ffc0cb028e8a149b92246df7c10.tar.gz
gentoo-2-729b113c90249ffc0cb028e8a149b92246df7c10.tar.bz2
gentoo-2-729b113c90249ffc0cb028e8a149b92246df7c10.zip
Version bump.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/gentoo-syntax/ChangeLog7
-rw-r--r--app-emacs/gentoo-syntax/gentoo-syntax-1.13.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-emacs/gentoo-syntax/ChangeLog b/app-emacs/gentoo-syntax/ChangeLog
index 472054e4e095..d9b7876842b2 100644
--- a/app-emacs/gentoo-syntax/ChangeLog
+++ b/app-emacs/gentoo-syntax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/gentoo-syntax
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/ChangeLog,v 1.49 2009/09/18 16:21:47 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/ChangeLog,v 1.50 2009/09/22 07:09:03 ulm Exp $
+
+*gentoo-syntax-1.13 (22 Sep 2009)
+
+ 22 Sep 2009; Ulrich Mueller <ulm@gentoo.org> +gentoo-syntax-1.13.ebuild:
+ Version bump.
18 Sep 2009; Ulrich Mueller <ulm@gentoo.org>
files/50gentoo-syntax-gentoo.el:
diff --git a/app-emacs/gentoo-syntax/gentoo-syntax-1.13.ebuild b/app-emacs/gentoo-syntax/gentoo-syntax-1.13.ebuild
new file mode 100644
index 000000000000..c31dff043306
--- /dev/null
+++ b/app-emacs/gentoo-syntax/gentoo-syntax-1.13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/gentoo-syntax-1.13.ebuild,v 1.1 2009/09/22 07:09:03 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DOCS="ChangeLog"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ makeinfo gentoo-syntax.texi || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc || die
+ sed -e "s:@PORTDIR@:${PORTDIR}:" \
+ "${FILESDIR}/${SITEFILE}" >"${T}/${SITEFILE}" || die
+ elisp-site-file-install "${T}/${SITEFILE}" || die
+ doinfo gentoo-syntax.info || die
+ dodoc ${DOCS} || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "Some optional features may require installation of additional"
+ elog "packages, like app-portage/gentoolkit-dev for echangelog."
+}