summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-02-24 20:00:26 +0000
committerUlrich Müller <ulm@gentoo.org>2010-02-24 20:00:26 +0000
commit102138a84d3a37e3c62fd14e335dbc607e256386 (patch)
treee173dcba98783484beec732c63e8f6b3662e139f /app-emacs
parentold (diff)
downloadgentoo-2-102138a84d3a37e3c62fd14e335dbc607e256386.tar.gz
gentoo-2-102138a84d3a37e3c62fd14e335dbc607e256386.tar.bz2
gentoo-2-102138a84d3a37e3c62fd14e335dbc607e256386.zip
Version bump.
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/auctex/ChangeLog7
-rw-r--r--app-emacs/auctex/auctex-11.86.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/app-emacs/auctex/ChangeLog b/app-emacs/auctex/ChangeLog
index e1b1542fdea3..dc6f98189289 100644
--- a/app-emacs/auctex/ChangeLog
+++ b/app-emacs/auctex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/auctex
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.97 2010/01/30 18:03:35 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.98 2010/02/24 20:00:26 ulm Exp $
+
+*auctex-11.86 (24 Feb 2010)
+
+ 24 Feb 2010; Ulrich Mueller <ulm@gentoo.org> +auctex-11.86.ebuild:
+ Version bump.
*auctex-11.85-r1 (30 Jan 2010)
diff --git a/app-emacs/auctex/auctex-11.86.ebuild b/app-emacs/auctex/auctex-11.86.ebuild
new file mode 100644
index 000000000000..1448705a3bcf
--- /dev/null
+++ b/app-emacs/auctex/auctex-11.86.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.86.ebuild,v 1.1 2010/02/24 20:00:26 ulm Exp $
+
+EAPI=3
+
+inherit elisp eutils latex-package
+
+DESCRIPTION="Extended support for writing, formatting and using (La)TeX, Texinfo and BibTeX files"
+HOMEPAGE="http://www.gnu.org/software/auctex/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="preview-latex"
+
+DEPEND="virtual/latex-base
+ preview-latex? ( !dev-tex/preview-latex
+ app-text/dvipng
+ app-text/ghostscript-gpl )"
+RDEPEND="${DEPEND}"
+
+TEXMF="/usr/share/texmf-site"
+
+src_configure() {
+ # Remove broken Info file (will be recreated by the build system)
+ rm doc/auctex.info*
+
+ EMACS_NAME=emacs EMACS_FLAVOUR=emacs econf --disable-build-dir-test \
+ --with-auto-dir="${EPREFIX}/var/lib/auctex" \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagelispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagedatadir="${EPREFIX}${SITEETC}/${PN}" \
+ --with-texmf-dir="${EPREFIX}${TEXMF}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable preview-latex preview) || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ cd doc; emake tex-ref.pdf || die "creation of tex-ref.pdf failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" || die
+ if use preview-latex; then
+ elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el" || die
+ fi
+ keepdir /var/lib/auctex
+ dodoc ChangeLog CHANGES README RELEASE TODO FAQ INSTALL*
+}
+
+pkg_postinst() {
+ # rebuild TeX-inputfiles-database
+ use preview-latex && latex-package_pkg_postinst
+ elisp-site-regen
+}
+
+pkg_postrm(){
+ use preview-latex && latex-package_pkg_postrm
+ elisp-site-regen
+}