summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-05-03 08:55:58 +0000
committerMamoru Komachi <usata@gentoo.org>2005-05-03 08:55:58 +0000
commit5161567a30f3a0d4abdbf58797c0e8842ba69e94 (patch)
treec3d4d5c8e52443cb44319b85e5b4d859403740c8 /app-emacs/python-mode
parentAdded to ~ppc (diff)
downloadgentoo-2-5161567a30f3a0d4abdbf58797c0e8842ba69e94.tar.gz
gentoo-2-5161567a30f3a0d4abdbf58797c0e8842ba69e94.tar.bz2
gentoo-2-5161567a30f3a0d4abdbf58797c0e8842ba69e94.zip
Do not hardcode python path. Thanks to dan <reddan@warpmail.net>; bug #88770.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-emacs/python-mode')
-rw-r--r--app-emacs/python-mode/ChangeLog6
-rw-r--r--app-emacs/python-mode/files/setup.py3
-rw-r--r--app-emacs/python-mode/python-mode-4.63-r1.ebuild11
3 files changed, 15 insertions, 5 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
index 40a2359eb247..49e7fa76f978 100644
--- a/app-emacs/python-mode/ChangeLog
+++ b/app-emacs/python-mode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/python-mode
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.14 2005/04/30 19:09:57 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.15 2005/05/03 08:55:58 usata Exp $
+
+ 03 May 2005; Mamoru KOMACHI <usata@gentoo.org> +files/setup.py,
+ python-mode-4.63-r1.ebuild:
+ Do not hardcode python path. Thanks to dan <reddan@warpmail.net>; bug #88770.
30 Apr 2005; Michael Hanselmann <hansmi@gentoo.org>
python-mode-4.63-r1.ebuild:
diff --git a/app-emacs/python-mode/files/setup.py b/app-emacs/python-mode/files/setup.py
new file mode 100644
index 000000000000..a08d125e3a25
--- /dev/null
+++ b/app-emacs/python-mode/files/setup.py
@@ -0,0 +1,3 @@
+from distutils.core import setup
+setup(name="pycomplete", py_modules=["pycomplete"])
+
diff --git a/app-emacs/python-mode/python-mode-4.63-r1.ebuild b/app-emacs/python-mode/python-mode-4.63-r1.ebuild
index 05ac16132091..2161510dc84e 100644
--- a/app-emacs/python-mode/python-mode-4.63-r1.ebuild
+++ b/app-emacs/python-mode/python-mode-4.63-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-4.63-r1.ebuild,v 1.6 2005/04/30 19:09:57 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-4.63-r1.ebuild,v 1.7 2005/05/03 08:55:58 usata Exp $
inherit distutils elisp
@@ -21,14 +21,17 @@ DEPEND="app-emacs/pymacs"
SITEFILE="55python-mode-gentoo.el"
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cp ${FILESDIR}/setup.py ${S}
+}
+
src_compile() {
elisp-comp *.el || die
}
src_install() {
+ distutils_src_install
elisp-install ${PN} *.el *.elc
- distutils_python_version
- insinto /usr/lib/python${PYVER}/site-packages
- doins pycomplete.py
elisp-site-file-install ${FILESDIR}/${SITEFILE}
}