summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-02-13 19:50:33 +0000
committerUlrich Müller <ulm@gentoo.org>2014-02-13 19:50:33 +0000
commit0c3be4f181fa7281523b31665123435b784d3edd (patch)
treef03a337fe21ea1c2e7bb13e966d5afe94084438a /app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-1.2.1.ebuild
parentRemove KDE Telepathy 0.7.0. (diff)
downloadgentoo-2-0c3be4f181fa7281523b31665123435b784d3edd.tar.gz
gentoo-2-0c3be4f181fa7281523b31665123435b784d3edd.tar.bz2
gentoo-2-0c3be4f181fa7281523b31665123435b784d3edd.zip
Version bump. Remove old.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-1.2.1.ebuild')
-rw-r--r--app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-1.2.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-1.2.1.ebuild b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-1.2.1.ebuild
new file mode 100644
index 000000000000..aafba02dfe4f
--- /dev/null
+++ b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-1.2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-1.2.1.ebuild,v 1.1 2014/02/13 19:50:33 ulm Exp $
+
+EAPI=5
+
+#BACKPORTS=
+NEED_EMACS=23
+
+inherit elisp eutils
+
+MY_P="libvirt-${PV/_rc/-rc}"
+
+DESCRIPTION="Extension for nxml-mode with libvirt schemas"
+HOMEPAGE="http://www.libvirt.org/"
+SRC_URI="http://libvirt.org/sources/${MY_P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${MY_P}-backports-${BACKPORTS}.tar.bz2}"
+
+# This is the license of the package, but the schema files are
+# provided without license, maybe it's bad.
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Yes this requires Java, but I'd rather not repackage this, if you
+# know something better in C, I'll be glad to use that.
+DEPEND="app-text/trang"
+RDEPEND=""
+
+SITEFILE="60${PN}-gentoo.el"
+S="${WORKDIR}/${MY_P%-rc*}"
+
+src_prepare() {
+ if [[ -d "${WORKDIR}/patches" ]]; then
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ EPATCH_SOURCE="${WORKDIR}/patches" \
+ epatch
+ fi
+}
+
+src_compile() {
+ emake -C docs/schemas -f "${FILESDIR}/Makefile-trang"
+}
+
+src_test() {
+ # No we don't need tests here... trang will take care of checking
+ # the well-formedness of the schema files for us
+ :
+}
+
+src_install() {
+ insinto ${SITEETC}/${PN}
+ doins "${FILESDIR}/schemas.xml" docs/schemas/*.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}