summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/ilisp
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/ilisp')
-rw-r--r--app-emacs/ilisp/ChangeLog11
-rw-r--r--app-emacs/ilisp/files/50ilisp-gentoo.el109
-rw-r--r--app-emacs/ilisp/files/digest-ilisp-5.12.01
-rw-r--r--app-emacs/ilisp/ilisp-5.12.0.ebuild42
4 files changed, 163 insertions, 0 deletions
diff --git a/app-emacs/ilisp/ChangeLog b/app-emacs/ilisp/ChangeLog
new file mode 100644
index 000000000000..7f39df4dd4e8
--- /dev/null
+++ b/app-emacs/ilisp/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/ilisp
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ilisp/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*ilisp-5.12.0 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ ilisp-5.12.0.ebuild, files/50ilisp-gentoo.el,
+ files/digest-ilisp-5.12.0 :
+
+ Initial import.
diff --git a/app-emacs/ilisp/files/50ilisp-gentoo.el b/app-emacs/ilisp/files/50ilisp-gentoo.el
new file mode 100644
index 000000000000..4b47926662fa
--- /dev/null
+++ b/app-emacs/ilisp/files/50ilisp-gentoo.el
@@ -0,0 +1,109 @@
+
+;;; ilisp site-lisp configuration (most of this was shamelessly yanked
+;;; from the ilisp.emacs file distributed with ilisp)
+
+(setq load-path (cons "@SITELISP@" load-path))
+(setq load-path (cons "@SITELISP@/extra" load-path))
+
+(autoload 'common-lisp "ilisp" "Inferior generic Common Lisp." t)
+; (autoload 'allegro "ilisp" "Inferior Allegro Common Lisp." t)
+; (autoload 'cormanlisp "ilisp" "Inferior Corman Common Lisp." t)
+; (autoload 'lucid "ilisp" "Inferior Lucid Common Lisp." t)
+; (autoload 'lispworks "ilisp" "Inferior Harlequin Common Lisp (LispWorks)." t)
+; (autoload 'harlequin "ilisp" "Inferior Harlequin Common Lisp (LispWorks)." t)
+; (autoload 'pulcinella "ilisp" "Inferior Harlequin Common Lisp (LispWorks)." t)
+(autoload 'cmulisp "ilisp" "Inferior CMU Common Lisp." t)
+(autoload 'clisp-hs "ilisp" "Inferior Haible/Stoll CLISP Common Lisp." t)
+; (autoload 'kcl "ilisp" "Inferior Kyoto Common Lisp." t)
+; (autoload 'akcl "ilisp" "Inferior Austin Kyoto Common Lisp." t)
+; (autoload 'ibcl "ilisp" "Ibuki Common Lisp." t)
+(autoload 'gcl "ilisp" "Inferior GNU Common Lisp." t)
+; (autoload 'ecl "ilisp" "Inferior EcoLisp." t)
+; (autoload 'xlisp "ilisp" "Inferior XLisp." t)
+; (autoload 'xlispstat "ilisp" "Inferior XLisp-Stat." t)
+(autoload 'scheme "ilisp" "Inferior generic Scheme." t)
+; (autoload 'oaklisp "ilisp" "Inferior Oaklisp Scheme." t)
+; (autoload 'scm "ilisp" "Inferior SCM Scheme." t)
+; (autoload 'chez "ilisp" "Inferior Chez Scheme." t)
+; (autoload 'stk "ilisp" "Inferior STk Scheme." t)
+; (autoload 'snow "ilisp" "Inferior STk Scheme without Tk." t)
+(autoload 'guile "ilisp" "Inferior GUILE Scheme." t)
+
+; (setq allegro-program "/usr/local/acl5/lisp")
+; (setq lucid-program "/usr/misc/.lucid/bin/lisp")
+(setq clisp-hs-program "/usr/bin/clisp -I")
+; (setq *cormanlisp-dir* "C:\\CORMAN~1\\CORMAN~1.5\\")
+; (setq cormanlisp-program
+; (concat *cormanlisp-dir* "clconsole.exe"
+; " -image " *cormanlisp-dir* "CormanLisp.img"))
+; (setq lispworks-program
+; "/somewhere/in/the/directory/tree/lispworks")
+(setq cmulisp-program "/opt/cmucl/bin/lisp")
+;; If you are interested in maintaining CMUCL or compiling it
+;; from source then set this to where the source files are.
+; (setq cmulisp-local-source-directory
+; "/usr/robotics/shared/cmu-cl/17e/")
+; (setq akcl-program "kcl")
+; (setq gcl-program "gcl")
+; (setq ecl-program "ecl")
+; (setq xlisp-program "xlisp")
+; (setq xlispstat-program "xlispstat")
+; (setq scm-program "scm -i")
+; (setq chez-program "petite")
+; (setq stk-program "stk -interactive")
+; (setq snow-program "snow -interactive")
+(setq guile-program "/usr/bin/guile")
+
+(set-default 'auto-mode-alist
+ (append '(("\\.lisp$" . lisp-mode)
+ ("\\.lsp$" . lisp-mode)
+ ("\\.cl$" . lisp-mode))
+ auto-mode-alist))
+(add-hook 'lisp-mode-hook '(lambda () (require 'ilisp)))
+
+(set-default 'auto-mode-alist
+ (append '(("\\.scm$" . scheme-mode)
+ ("\\.ss$" . scheme-mode)
+ ("\\.stk$" . scheme-mode)
+ ("\\.stklos$" . scheme-mode))
+ auto-mode-alist))
+(add-hook 'scheme-mode-hook '(lambda () (require 'ilisp)))
+
+;;; Configuration of Erik Naggum's HyperSpec access package.
+;; If you have a local copy of the HyperSpec, set its path here.
+; (setq common-lisp-hyperspec-root
+; "file:/home/joe/HyperSpec/")
+; (setq common-lisp-hyperspec-symbol-table
+; "/home/joe/HyperSpec/Data/Map_Sym.Txt")
+;; Here's how to get the newest version of the CLHS:
+;; <http://groups.google.com/groups?selm=sfwvgftux7g.fsf%40shell01.TheWorld.com>
+
+;;; Configuration of Utz-Uwe Haus' CLtL2 access package.
+;; If you have a local copy of CLtL2, set its path here.
+; (setq cltl2-root-url
+; "file:/home/joe/cltl2/")
+
+;;; Sample load hook
+(add-hook 'ilisp-load-hook
+ '(lambda ()
+ ;; Change default key prefix to C-c
+;; (setq ilisp-*prefix* "\C-c")
+
+ ;; Set a keybinding for the COMMON-LISP-HYPERSPEC command
+;; (defkey-ilisp "" 'common-lisp-hyperspec)
+
+ ;; Make sure that you don't keep popping up the 'inferior
+ ;; Lisp' buffer window when this is already visible in
+ ;; another frame. Actually this variable has more impact
+ ;; than that. Watch out.
+ ; (setq pop-up-frames t)
+
+ (message "Running ilisp-load-hook")
+ ;; Define LispMachine-like key bindings, too.
+ ; (ilisp-lispm-bindings) Sample initialization hook.
+
+ ;; Set the inferior Lisp directory to the directory of
+ ;; the buffer that spawned it on the first prompt.
+ (add-hook 'ilisp-init-hook
+ '(lambda ()
+ (default-directory-lisp ilisp-last-buffer)))))
diff --git a/app-emacs/ilisp/files/digest-ilisp-5.12.0 b/app-emacs/ilisp/files/digest-ilisp-5.12.0
new file mode 100644
index 000000000000..4d3bce010edf
--- /dev/null
+++ b/app-emacs/ilisp/files/digest-ilisp-5.12.0
@@ -0,0 +1 @@
+MD5 24af2a60c24aed577234c01434ff0873 ilisp-5.12.0.tar.gz 246570
diff --git a/app-emacs/ilisp/ilisp-5.12.0.ebuild b/app-emacs/ilisp/ilisp-5.12.0.ebuild
new file mode 100644
index 000000000000..d054344ed690
--- /dev/null
+++ b/app-emacs/ilisp/ilisp-5.12.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ilisp/ilisp-5.12.0.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="A comprehensive (X)Emacs interface for an inferior Common Lisp, or other Lisp based languages."
+HOMEPAGE="http://sourceforge.net/projects/ilisp/"
+SRC_URI="mirror://sourceforge/ilisp/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ make EMACS=emacs SHELL=/bin/sh || die
+ cd extra
+ for i in *.el
+ do
+ emacs -batch -eval "(byte-compile-file \"$i\")"
+ done
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-install ${PN}/extra extra/*.el extra/*.elc
+ elisp-site-file-install ${FILESDIR}/50ilisp-gentoo.el
+ dodoc ACKNOWLEDGMENTS COPYING GETTING-ILISP HISTORY INSTALLATION README Welcome
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}