summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-04-25 21:38:11 +0000
committerUlrich Müller <ulm@gentoo.org>2009-04-25 21:38:11 +0000
commit50b76b2cfb2701f3bf6937388745432e2e7325c9 (patch)
tree933659f6e668521c16d85f99f6fd9359a85f72fe /app-emacs/company-mode
parentFixing badly broken prerm to be postrm. Fixes #250576 (diff)
downloadgentoo-2-50b76b2cfb2701f3bf6937388745432e2e7325c9.tar.gz
gentoo-2-50b76b2cfb2701f3bf6937388745432e2e7325c9.tar.bz2
gentoo-2-50b76b2cfb2701f3bf6937388745432e2e7325c9.zip
Version bump.
(Portage version: 2.2_rc31/cvs/Linux i686)
Diffstat (limited to 'app-emacs/company-mode')
-rw-r--r--app-emacs/company-mode/ChangeLog9
-rw-r--r--app-emacs/company-mode/company-mode-0.4.2.ebuild35
-rw-r--r--app-emacs/company-mode/files/company-mode-0.4.2-disable-semantic.patch15
3 files changed, 58 insertions, 1 deletions
diff --git a/app-emacs/company-mode/ChangeLog b/app-emacs/company-mode/ChangeLog
index cfc136620fde..4aa88083313b 100644
--- a/app-emacs/company-mode/ChangeLog
+++ b/app-emacs/company-mode/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/company-mode
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/company-mode/ChangeLog,v 1.5 2009/04/16 23:03:16 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/company-mode/ChangeLog,v 1.6 2009/04/25 21:38:10 ulm Exp $
+
+*company-mode-0.4.2 (25 Apr 2009)
+
+ 25 Apr 2009; Ulrich Mueller <ulm@gentoo.org>
+ +files/company-mode-0.4.2-disable-semantic.patch,
+ +company-mode-0.4.2.ebuild:
+ Version bump.
16 Apr 2009; Ulrich Mueller <ulm@gentoo.org> company-mode-0.3.1.ebuild:
Fix dependency on nxml-mode.
diff --git a/app-emacs/company-mode/company-mode-0.4.2.ebuild b/app-emacs/company-mode/company-mode-0.4.2.ebuild
new file mode 100644
index 000000000000..8adedd52042f
--- /dev/null
+++ b/app-emacs/company-mode/company-mode-0.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/company-mode/company-mode-0.4.2.ebuild,v 1.1 2009/04/25 21:38:10 ulm Exp $
+
+EAPI=2
+NEED_EMACS=22
+
+inherit elisp eutils
+
+DESCRIPTION="In-buffer completion front-end"
+HOMEPAGE="http://nschum.de/src/emacs/company-mode/"
+SRC_URI="http://nschum.de/src/emacs/${PN}/company-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic"
+
+# Note: company-mode supports many backends, and we refrain from including
+# them all in RDEPEND. Only depend on things that are needed at build time.
+DEPEND="semantic? ( app-emacs/cedet )
+ || ( app-emacs/nxml-mode >=virtual/emacs-23 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ # Disable semantic backend, unless selected by its USE flag
+ if ! use semantic; then
+ elog "Disabling semantic backend, as requested by USE=-semantic"
+ rm "company-semantic.el" || die
+ epatch "${FILESDIR}/${P}-disable-semantic.patch"
+ fi
+}
diff --git a/app-emacs/company-mode/files/company-mode-0.4.2-disable-semantic.patch b/app-emacs/company-mode/files/company-mode-0.4.2-disable-semantic.patch
new file mode 100644
index 000000000000..fc2dd365339f
--- /dev/null
+++ b/app-emacs/company-mode/files/company-mode-0.4.2-disable-semantic.patch
@@ -0,0 +1,15 @@
+--- company.el~ 2009-04-25 09:15:30.000000000 +0200
++++ company.el 2009-04-25 23:33:30.000000000 +0200
+@@ -277,5 +277,4 @@
+ (company-nxml . "nxml")
+ (company-oddmuse . "Oddmuse")
+- (company-semantic . "CEDET Semantic")
+ (company-tempo . "Tempo templates")
+ (company-xcode . "Xcode")))
+@@ -291,5 +290,5 @@
+
+ (defcustom company-backends '(company-elisp company-nxml company-css
+- company-eclim company-semantic company-xcode
++ company-eclim company-xcode
+ (company-gtags company-etags company-dabbrev-code
+ company-keywords)