summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-07-13 12:13:10 +0000
committerUlrich Müller <ulm@gentoo.org>2012-07-13 12:13:10 +0000
commitf530f2cd6463ba0d9c074116dc7364c257c96670 (patch)
tree1363c957804fdc5d132d4e48f946b181d75a55e3 /app-editors
parentRequire bsh[bsf] for building. Fixes bug #426280 by Helmut Jarausch. Also rai... (diff)
downloadgentoo-2-f530f2cd6463ba0d9c074116dc7364c257c96670.tar.gz
gentoo-2-f530f2cd6463ba0d9c074116dc7364c257c96670.tar.bz2
gentoo-2-f530f2cd6463ba0d9c074116dc7364c257c96670.zip
Version bump, fixes bug 425104.
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/zile/ChangeLog7
-rw-r--r--app-editors/zile/zile-2.3.24-r1.ebuild4
-rw-r--r--app-editors/zile/zile-2.4.8.ebuild38
3 files changed, 46 insertions, 3 deletions
diff --git a/app-editors/zile/ChangeLog b/app-editors/zile/ChangeLog
index e21ebc8483bf..41adddf6aa1b 100644
--- a/app-editors/zile/ChangeLog
+++ b/app-editors/zile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/zile
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.179 2012/05/29 19:17:06 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/ChangeLog,v 1.180 2012/07/13 12:13:10 ulm Exp $
+
+*zile-2.4.8 (13 Jul 2012)
+
+ 13 Jul 2012; Ulrich Müller <ulm@gentoo.org> +zile-2.4.8.ebuild:
+ Version bump, fixes bug 425104.
29 May 2012; Brent Baude <ranger@gentoo.org> zile-2.4.7.ebuild:
Marking zile-2.4.7 ppc for bug 417343
diff --git a/app-editors/zile/zile-2.3.24-r1.ebuild b/app-editors/zile/zile-2.3.24-r1.ebuild
index c292938c8899..a1dbb66d4020 100644
--- a/app-editors/zile/zile-2.3.24-r1.ebuild
+++ b/app-editors/zile/zile-2.3.24-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.3.24-r1.ebuild,v 1.6 2012/04/01 15:34:15 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.3.24-r1.ebuild,v 1.7 2012/07/13 12:13:10 ulm Exp $
EAPI=4
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/zile/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="alpha amd64 ppc sparc x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+KEYWORDS="alpha amd64 ppc sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE="test valgrind"
RDEPEND="sys-libs/ncurses"
diff --git a/app-editors/zile/zile-2.4.8.ebuild b/app-editors/zile/zile-2.4.8.ebuild
new file mode 100644
index 000000000000..f45e58a3d53e
--- /dev/null
+++ b/app-editors/zile/zile-2.4.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.4.8.ebuild,v 1.1 2012/07/13 12:13:10 ulm Exp $
+
+EAPI=4
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="http://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="acl test"
+
+RDEPEND="dev-libs/boehm-gc
+ sys-libs/ncurses
+ acl? ( virtual/acl )"
+
+DEPEND="${RDEPEND}
+ test? ( dev-lang/perl )"
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-silent-rules \
+ $(use_enable acl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # AUTHORS, FAQ, and NEWS are installed by the build system
+ dodoc README THANKS
+
+ # Zile should never install charset.alias (even on non-glibc arches)
+ rm -f "${ED}"/usr/lib/charset.alias
+}