summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2002-10-17 10:05:38 +0000
committerHanno Böck <hanno@gentoo.org>2002-10-17 10:05:38 +0000
commitef86ba6660c2d495c0fa28390b2b2097d742d1ba (patch)
tree2857b0e6667fbd3e390bbb2cfea46b4693b46120 /app-editors
parentmask for further gtk+2-snapshots of bluefish (diff)
downloadgentoo-2-ef86ba6660c2d495c0fa28390b2b2097d742d1ba.tar.gz
gentoo-2-ef86ba6660c2d495c0fa28390b2b2097d742d1ba.tar.bz2
gentoo-2-ef86ba6660c2d495c0fa28390b2b2097d742d1ba.zip
updated gtk+2-port of bluefish
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/bluefish/bluefish-2002.09.26.ebuild59
-rw-r--r--app-editors/bluefish/files/digest-bluefish-2002.09.261
2 files changed, 60 insertions, 0 deletions
diff --git a/app-editors/bluefish/bluefish-2002.09.26.ebuild b/app-editors/bluefish/bluefish-2002.09.26.ebuild
new file mode 100644
index 000000000000..9cbf66b0ea50
--- /dev/null
+++ b/app-editors/bluefish/bluefish-2002.09.26.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-2002.09.26.ebuild,v 1.1 2002/10/17 10:05:38 hanno Exp $
+
+IUSE="nls perl"
+
+MY_PV=`echo ${PV} | sed -e 's/\./-/g'`
+S=${WORKDIR}/${PN}-gtk2
+DESCRIPTION="Bluefish is a GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/snapshots/${PN}-gtk2port-${MY_PV}.tgz"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+SLOT="0"
+
+DEPEND=">=x11-libs/gtk+-2.0.5
+ >=media-libs/freetype-2.0.9
+ >=media-libs/gdk-pixbuf-0.18
+ perl? ( sys-devel/perl )
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ local myconf
+ use perl && myconf="${myconf} --with-perl"
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --with-autocomplet \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ makefiles=`find . -name Makefile`
+ for f in $makefiles; do
+ mv $f $f.orig
+ sed -e 's#$(prefix)#$(DESTDIR)$(prefix)#' \
+ -e 's#${prefix}#$(DESTDIR)${prefix}#' \
+ -e 's#/usr/share/pixmaps#$(DESTDIR)$(prefix)/share/pixmaps#' \
+ $f.orig > $f
+ done
+
+ make \
+ DESTDIR=${D} \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING INSTALL NEWS README TODO
+ mv manual ${D}usr/share/doc/${PF}
+}
diff --git a/app-editors/bluefish/files/digest-bluefish-2002.09.26 b/app-editors/bluefish/files/digest-bluefish-2002.09.26
new file mode 100644
index 000000000000..7780db455cda
--- /dev/null
+++ b/app-editors/bluefish/files/digest-bluefish-2002.09.26
@@ -0,0 +1 @@
+MD5 965327b0d22375de02bb162b1c20c81f bluefish-gtk2port-2002-09-26.tgz 390390