summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-07 19:43:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-07 19:43:33 +0000
commited5d66490d0e98dff76d4224a956059dfa672837 (patch)
treede6657e6218339b2ef10b09f1fdfdf3e91d976d4 /app-editors
parentTransition to eapi 2 use deps (diff)
downloadgentoo-2-ed5d66490d0e98dff76d4224a956059dfa672837.tar.gz
gentoo-2-ed5d66490d0e98dff76d4224a956059dfa672837.tar.bz2
gentoo-2-ed5d66490d0e98dff76d4224a956059dfa672837.zip
Bump to 23.2.0, with small modifications by Daniel Pielmeier.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/tea/ChangeLog7
-rw-r--r--app-editors/tea/tea-23.2.0.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-editors/tea/ChangeLog b/app-editors/tea/ChangeLog
index 93d221440c14..b4590f0b4275 100644
--- a/app-editors/tea/ChangeLog
+++ b/app-editors/tea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/tea
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.43 2009/03/07 15:39:20 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.44 2009/03/07 19:43:33 patrick Exp $
+
+*tea-23.2.0 (07 Mar 2009)
+
+ 07 Mar 2009; Patrick Lauer <patrick@gentoo.org> +tea-23.2.0.ebuild:
+ Bump to 23.2.0, with small modifications by Daniel Pielmeier.
*tea-22.0.1 (07 Mar 2009)
diff --git a/app-editors/tea/tea-23.2.0.ebuild b/app-editors/tea/tea-23.2.0.ebuild
new file mode 100644
index 000000000000..20c367b9dfea
--- /dev/null
+++ b/app-editors/tea/tea-23.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-23.2.0.ebuild,v 1.1 2009/03/07 19:43:33 patrick Exp $
+
+EAPI="1"
+inherit eutils qt4
+
+DESCRIPTION="Small, lightweight Qt text editor"
+HOMEPAGE="http://tea-editor.sourceforge.net"
+SRC_URI="mirror://sourceforge/tea-editor/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
+IUSE="spell"
+
+DEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-svg:4
+ x11-libs/qt-script:4"
+RDEPEND="${DEPEND}
+ spell? ( app-text/aspell )"
+
+src_compile() {
+ eqmake4 src.pro
+ emake DESTDIR="${D}" || die "emake failed"
+}
+
+src_install() {
+ dobin bin/tea || die "Couldn't install tea"
+ dodoc AUTHORS ChangeLog NEWS NEWS-RU TODO
+ doicon icons/tea_icon_v2.png
+
+ make_desktop_entry tea Tea tea_icon_v2.png Development
+}
+
+pkg_postinst() {
+ if use spell ; then
+ elog "To get full spellchecking functuality, ensure that you install"
+ elog "the relevant language pack(s)"
+ fi
+}