summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-14 04:48:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-14 04:48:53 +0000
commitde41837b5aa360b73e0966d447c413e90b19fe19 (patch)
tree393b4670ceef20e47d97b1c4359c68e2910241d2 /app-editors
parentBump (diff)
downloadgentoo-2-de41837b5aa360b73e0966d447c413e90b19fe19.tar.gz
gentoo-2-de41837b5aa360b73e0966d447c413e90b19fe19.tar.bz2
gentoo-2-de41837b5aa360b73e0966d447c413e90b19fe19.zip
Bump
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/hteditor/ChangeLog9
-rw-r--r--app-editors/hteditor/hteditor-2.0.19.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/app-editors/hteditor/ChangeLog b/app-editors/hteditor/ChangeLog
index 662d2b07e3d2..1fd64bd43e4a 100644
--- a/app-editors/hteditor/ChangeLog
+++ b/app-editors/hteditor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/hteditor
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/ChangeLog,v 1.47 2011/07/20 13:47:44 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/ChangeLog,v 1.48 2012/03/14 04:48:53 patrick Exp $
+
+*hteditor-2.0.19 (14 Mar 2012)
+
+ 14 Mar 2012; Patrick Lauer <patrick@gentoo.org> +hteditor-2.0.19.ebuild:
+ Bump
20 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #34534
diff --git a/app-editors/hteditor/hteditor-2.0.19.ebuild b/app-editors/hteditor/hteditor-2.0.19.ebuild
new file mode 100644
index 000000000000..a39c2972243d
--- /dev/null
+++ b/app-editors/hteditor/hteditor-2.0.19.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-2.0.19.ebuild,v 1.1 2012/03/14 04:48:53 patrick Exp $
+
+EAPI=3
+
+MY_P=${P/editor}
+
+DESCRIPTION="A file viewer, editor and analyzer for text, binary, and executable files"
+HOMEPAGE="http://hte.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hte/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="X"
+
+RDEPEND="sys-libs/ncurses
+ X? ( x11-libs/libX11 )
+ >=dev-libs/lzo-2"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i \
+ -e '/FLAGS_ALL/s:-ggdb -g3 -O0::' \
+ configure || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable X x11-textmode) \
+ --disable-release
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog KNOWNBUGS README TODO
+ dohtml doc/*.html
+ doinfo doc/*.info
+}