summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-01-28 01:47:53 +0000
committerTim Harder <radhermit@gentoo.org>2015-01-28 01:47:53 +0000
commita553056bfe57f5f3780e393e3d7eb14534fa6669 (patch)
tree382ae7d435fbcb390af763279ee82c56b074ebbc /app-editors
parentVersion bump. (diff)
downloadgentoo-2-a553056bfe57f5f3780e393e3d7eb14534fa6669.tar.gz
gentoo-2-a553056bfe57f5f3780e393e3d7eb14534fa6669.tar.bz2
gentoo-2-a553056bfe57f5f3780e393e3d7eb14534fa6669.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xvile/ChangeLog9
-rw-r--r--app-editors/xvile/xvile-9.8o.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/app-editors/xvile/ChangeLog b/app-editors/xvile/ChangeLog
index e0b985446c7c..0755831cde9b 100644
--- a/app-editors/xvile/ChangeLog
+++ b/app-editors/xvile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/xvile
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/ChangeLog,v 1.41 2014/08/26 15:17:48 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/ChangeLog,v 1.42 2015/01/28 01:47:53 radhermit Exp $
+
+*xvile-9.8o (28 Jan 2015)
+
+ 28 Jan 2015; Tim Harder <radhermit@gentoo.org> +xvile-9.8o.ebuild:
+ Version bump.
*xvile-9.8n (26 Aug 2014)
diff --git a/app-editors/xvile/xvile-9.8o.ebuild b/app-editors/xvile/xvile-9.8o.ebuild
new file mode 100644
index 000000000000..c0d262d31630
--- /dev/null
+++ b/app-editors/xvile/xvile-9.8o.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/xvile-9.8o.ebuild,v 1.1 2015/01/28 01:47:53 radhermit Exp $
+
+EAPI="5"
+
+MY_P="${PN/x/}-${PV}"
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://invisible-island.net/vile/"
+SRC_URI="ftp://invisible-island.net/vile/current/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="perl"
+
+RDEPEND="perl? ( dev-lang/perl )
+ =app-editors/vile-${PV}
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libICE-1.0.0
+ >=x11-libs/libSM-1.0.0
+ >=x11-libs/libXaw-1.0.1
+ >=x11-libs/libXpm-3.5.4.2
+ >=x11-proto/xproto-7.0.4"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ --with-x \
+ $(use_with perl)
+}
+
+src_install() {
+ dobin xvile
+ dodoc CHANGES* README doc/*.doc
+ dohtml doc/*.html
+}