summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-03-07 00:07:04 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-03-07 00:07:04 +0000
commit89d59a6051bc95c737a1c172beaca2172c8d397b (patch)
tree9b544e14743aa262db8f0fc0f96b17fd286cae9b /app-editors
parentFix slot-deps on gtk+ and other libs (diff)
downloadgentoo-2-89d59a6051bc95c737a1c172beaca2172c8d397b.tar.gz
gentoo-2-89d59a6051bc95c737a1c172beaca2172c8d397b.tar.bz2
gentoo-2-89d59a6051bc95c737a1c172beaca2172c8d397b.zip
Fix slot-deps on gtk+ and other libs
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit/ChangeLog6
-rw-r--r--app-editors/gedit/gedit-2.30.3.ebuild21
-rw-r--r--app-editors/gedit/gedit-2.30.4.ebuild6
3 files changed, 19 insertions, 14 deletions
diff --git a/app-editors/gedit/ChangeLog b/app-editors/gedit/ChangeLog
index 74042be9a9cb..e3db91848517 100644
--- a/app-editors/gedit/ChangeLog
+++ b/app-editors/gedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/gedit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.324 2011/01/30 17:30:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.325 2011/03/07 00:07:04 nirbheek Exp $
+
+ 07 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> gedit-2.30.3.ebuild,
+ gedit-2.30.4.ebuild:
+ Fix slot-deps on gtk+ and other libs
30 Jan 2011; Raúl Porcel <armin76@gentoo.org> gedit-2.30.4.ebuild:
alpha/arm/ia64/sh/sparc stable wrt #348987
diff --git a/app-editors/gedit/gedit-2.30.3.ebuild b/app-editors/gedit/gedit-2.30.3.ebuild
index 136632213566..4be30f78bd3f 100644
--- a/app-editors/gedit/gedit-2.30.3.ebuild
+++ b/app-editors/gedit/gedit-2.30.3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.30.3.ebuild,v 1.10 2010/10/17 15:27:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.30.3.ebuild,v 1.11 2011/03/07 00:07:04 nirbheek Exp $
+EAPI="1"
GCONF_DEBUG="no"
PYTHON_DEPEND="python? 2:2.5"
@@ -15,20 +16,20 @@ SLOT="0"
KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="doc python spell"
-RDEPEND=">=gnome-base/gconf-2
+RDEPEND=">=gnome-base/gconf-2:2
>=x11-libs/libSM-1.0
- >=dev-libs/libxml2-2.5.0
- >=dev-libs/glib-2.23.1
- >=x11-libs/gtk+-2.19.0
- >=x11-libs/gtksourceview-2.9.7
+ >=dev-libs/libxml2-2.5.0:2
+ >=dev-libs/glib-2.23.1:2
+ >=x11-libs/gtk+-2.19.0:2
+ >=x11-libs/gtksourceview-2.9.7:2.0
spell? (
>=app-text/enchant-1.2
>=app-text/iso-codes-0.35
)
python? (
- >=dev-python/pygobject-2.15.4
- >=dev-python/pygtk-2.12
- >=dev-python/pygtksourceview-2.9.2
+ >=dev-python/pygobject-2.15.4:2
+ >=dev-python/pygtk-2.12:2
+ >=dev-python/pygtksourceview-2.9.2:2
)"
DEPEND="${RDEPEND}
diff --git a/app-editors/gedit/gedit-2.30.4.ebuild b/app-editors/gedit/gedit-2.30.4.ebuild
index 092c74e1e6e0..587c0c825760 100644
--- a/app-editors/gedit/gedit-2.30.4.ebuild
+++ b/app-editors/gedit/gedit-2.30.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.30.4.ebuild,v 1.7 2011/01/30 17:30:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.30.4.ebuild,v 1.8 2011/03/07 00:07:04 nirbheek Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -16,9 +16,9 @@ SLOT="0"
KEYWORDS="alpha amd64 arm ia64 ~mips ~ppc ~ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="doc python spell"
-RDEPEND=">=gnome-base/gconf-2
+RDEPEND=">=gnome-base/gconf-2:2
>=x11-libs/libSM-1.0
- >=dev-libs/libxml2-2.5.0
+ >=dev-libs/libxml2-2.5.0:2
>=dev-libs/glib-2.23.1:2
>=x11-libs/gtk+-2.19.0:2
>=x11-libs/gtksourceview-2.9.7:2.0