summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-07-15 07:54:46 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-07-15 07:54:46 +0000
commit8929e792b637b6412621b8292af6ac8303c99817 (patch)
tree9120f953a165fb31eaab3ee87ca33c7064390df7 /app-editors
parentSRC_URI is supposed to be static now. (diff)
downloadgentoo-2-8929e792b637b6412621b8292af6ac8303c99817.tar.gz
gentoo-2-8929e792b637b6412621b8292af6ac8303c99817.tar.bz2
gentoo-2-8929e792b637b6412621b8292af6ac8303c99817.zip
mule fix, keywords update etc.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xemacs/ChangeLog10
-rw-r--r--app-editors/xemacs/files/digest-xemacs-21.4.8-r24
-rw-r--r--app-editors/xemacs/xemacs-21.4.8-r2.ebuild147
3 files changed, 160 insertions, 1 deletions
diff --git a/app-editors/xemacs/ChangeLog b/app-editors/xemacs/ChangeLog
index 88179304a840..9aaaa1b1d6ad 100644
--- a/app-editors/xemacs/ChangeLog
+++ b/app-editors/xemacs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/xemacs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.11 2002/06/26 17:40:29 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.12 2002/07/15 07:54:45 mkennedy Exp $
+
+*xemacs-21.4.8-r2 (14 Jul 2002)
+
+ 14 Jul 2002; Matthew Kennedy <mkennedy@gentoo.org>
+ xemacs-21.4.8-r2.ebuild :
+
+ Made SRC_URI static, added KEYWORDS, fixed empty mule flag, updated
+ efs, xemacs-base and mule-base subpackage versions.
*xemacs-21.4.8-r1 (26 June 2002)
diff --git a/app-editors/xemacs/files/digest-xemacs-21.4.8-r2 b/app-editors/xemacs/files/digest-xemacs-21.4.8-r2
new file mode 100644
index 000000000000..b1825922a0e7
--- /dev/null
+++ b/app-editors/xemacs/files/digest-xemacs-21.4.8-r2
@@ -0,0 +1,4 @@
+MD5 8d111231c5ad7d2434f0a80de6de238d xemacs-21.4.8.tar.gz 10539644
+MD5 8c2c6c00cfbdc5f8d64ad54ddfb731df efs-1.29-pkg.tar.gz 371905
+MD5 b0e29382cc9bc6c93cb068fa924ecb14 xemacs-base-1.63-pkg.tar.gz 463861
+MD5 b0b6e1b39d8aa97c2e596b84b478702b mule-base-1.40-pkg.tar.gz 443823
diff --git a/app-editors/xemacs/xemacs-21.4.8-r2.ebuild b/app-editors/xemacs/xemacs-21.4.8-r2.ebuild
new file mode 100644
index 000000000000..2b27bd0e281b
--- /dev/null
+++ b/app-editors/xemacs/xemacs-21.4.8-r2.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.8-r2.ebuild,v 1.1 2002/07/15 07:54:46 mkennedy Exp $
+
+# this is just TEMPORARY until we can get to the core of the problem
+SANDBOX_DISABLED="1"
+
+LICENSE="GPL-2"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="XEmacs is a highly customizable open source text editor and application development system. This is the \"gamma\" release. Support for ncurses, and optional support for X via the lucid toolkit."
+EFS=1.29
+BASE=1.63
+MULE=1.40
+
+SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${P}.tar.gz
+ http://ftp.xemacs.org/packages/efs-${EFS}-pkg.tar.gz
+ http://ftp.xemacs.org/packages/xemacs-base-${BASE}-pkg.tar.gz
+ http://ftp.xemacs.org/packages/mule-base-${MULE}-pkg.tar.gz"
+
+HOMEPAGE="http://www.xemacs.org"
+
+SLOT=""
+KEYWORDS="x86 ppc"
+
+RDEPEND="virtual/glibc
+ !virtual/xemacs
+
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/zlib-1.1.4
+ >=dev-libs/openssl-0.9.6
+ >=media-libs/audiofile-0.2.3
+
+ gpm? ( >=sys-libs/gpm-1.19.6 )
+ postgres? ( >=dev-db/postgresql-7.2 )
+
+ nas? ( media-libs/nas )
+ esd? ( media-sound/esound )
+
+ X? ( virtual/x11 >=x11-libs/openmotif-2.1.30 )
+ xface? ( media-libs/compface )
+ tiff? ( media-libs/tiff )
+ png? ( =media-libs/libpng-1.2* )
+ jpeg? ( media-libs/jpeg )"
+
+DEPEND="${RDEPEND}
+ >=sys-libs/ncurses-5.2"
+
+PROVIDE="virtual/xemacs"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${P}.tar.gz
+ cd ${S}
+ patch -p0 <${FILESDIR}/emodules.info-21.4.8-gentoo.patch
+
+ if [ ${ARCH} = "ppc" ] ; then
+ patch -p0 < ${FILESDIR}/${P}-ppc.diff
+ fi
+
+}
+
+src_compile() {
+ local myconf=""
+
+ if use X;
+ then
+ myconf="${myconf}
+ --with-x
+ --with-xpm
+ --with-dragndrop
+ --with-gif=no"
+
+ use tiff && myconf="${myconf} --with-tiff" ||
+ myconf="${myconf} --without-tiff"
+ use png && mconf="${myconf} --with-png" ||
+ myconf="${myconf} --without-png"
+ use jpeg && myconf="${myconf} --with-jpeg" ||
+ myconf="${myconf} --without-jpeg"
+ use xface && myconf="${myconf} --with-xface" ||
+ myconf="${myconf} --without-xface"
+
+ myconf="${myconf} --with-dialogs=lucid"
+ myconf="${myconf} --with-widgets=lucid"
+ myconf="${myconf} --with-scrollbars=lucid"
+ myconf="${myconf} --with-menubars=lucid"
+ else
+ myconf="${myconf}
+ --without-x
+ --without-xpm
+ --without-dragndrop
+ --with-gif=no"
+ fi
+
+ use gpm && myconf="${myconf} --with-gpm" ||
+ myconf="${myconf} --without-gpm"
+ use postgres && myconf="${myconf} --with-postgresql" ||
+ myconf="${myconf} --without-postgresql"
+ use mule && myconf="${myconf} --with-mule" ||
+ myconf="${myconf} --without-mule"
+
+ local soundconf="native"
+
+ use nas && soundconf="${soundconf},nas"
+ use esd && soundconf="${soundconf},esd"
+
+ myconf="${myconf} --with-sound=${soundconf}"
+
+ ./configure ${myconf} \
+ --prefix=/usr \
+ --with-database=gnudbm \
+ --with-pop \
+ --with-ncurses \
+ --with-site-lisp=yes \
+ --package-path=/usr/lib/xemacs/xemacs-packages/ \
+ --with-msw=no \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix="${D}/usr" \
+ mandir="${D}/usr/share/man/man1" \
+ infodir="${D}/usr/share/info" \
+ install gzip-el || die
+
+ # install base packages
+ dodir /usr/lib/xemacs/xemacs-packages/
+ cd ${D}/usr/lib/xemacs/xemacs-packages/
+ unpack efs-${EFS}-pkg.tar.gz
+ unpack xemacs-base-${BASE}-pkg.tar.gz
+ # (optionally) install mule base package
+ if use mule;
+ then
+ dodir /usr/lib/xemacs/mule-packages
+ cd ${D}/usr/lib/xemacs/mule-packages/
+ unpack mule-base-${MULE}-pkg.tar.gz
+ fi
+
+ # remove extraneous files
+ cd ${D}/usr/share/info
+ rm -f dir info.info texinfo* termcap*
+ cd ${S}
+ dodoc BUGS CHANGES-* COPYING ChangeLog GETTING* INSTALL PROBLEMS README*
+ dodoc ${FILESDIR}/README.Gentoo
+}