summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-01-15 02:12:24 +0000
committerJonathan Callen <abcd@gentoo.org>2010-01-15 02:12:24 +0000
commit5228fd81109cdb507c3d831faf610fea7f467ff5 (patch)
tree09cd04f4158068da5a4c7012cdaf1bb15fb61141 /app-editors
parentAdd prefix keywords (diff)
downloadgentoo-2-5228fd81109cdb507c3d831faf610fea7f467ff5.tar.gz
gentoo-2-5228fd81109cdb507c3d831faf610fea7f467ff5.tar.bz2
gentoo-2-5228fd81109cdb507c3d831faf610fea7f467ff5.zip
Add prefix keywords, patch
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/teco/ChangeLog8
-rw-r--r--app-editors/teco/files/teco-gcc4.patch11
-rw-r--r--app-editors/teco/teco-1.00-r3.ebuild11
3 files changed, 23 insertions, 7 deletions
diff --git a/app-editors/teco/ChangeLog b/app-editors/teco/ChangeLog
index 5872fa981817..5a6409c335c3 100644
--- a/app-editors/teco/ChangeLog
+++ b/app-editors/teco/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/teco
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/ChangeLog,v 1.20 2009/09/11 11:20:43 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/ChangeLog,v 1.21 2010/01/15 02:12:22 abcd Exp $
+
+ 15 Jan 2010; Jonathan Callen <abcd@gentoo.org> +files/teco-gcc4.patch,
+ teco-1.00-r3.ebuild:
+ Add prefix keywords, patch
11 Sep 2009; Diego E. Pettenò <flameeyes@gentoo.org> teco-1.00-r3.ebuild:
Fix DEPEND/RDEPEND assignment.
diff --git a/app-editors/teco/files/teco-gcc4.patch b/app-editors/teco/files/teco-gcc4.patch
new file mode 100644
index 000000000000..fe4d8d3759b4
--- /dev/null
+++ b/app-editors/teco/files/teco-gcc4.patch
@@ -0,0 +1,11 @@
+--- te_subs.c.orig 2007-03-18 19:58:40 +0100
++++ te_subs.c 2007-03-18 19:58:57 +0100
+@@ -231,7 +231,7 @@
+ char c;
+ {
+ if (isdigit(c)) return(c - '0' + 1);
+- else if isalpha(c) return(mapch_l[c] - 'a' + 11);
++ else if (isalpha(c)) return(mapch_l[c] - 'a' + 11);
+ else if (fors)
+ {
+ if (c == '_') return (SERBUF);
diff --git a/app-editors/teco/teco-1.00-r3.ebuild b/app-editors/teco/teco-1.00-r3.ebuild
index a31feb952b7b..5bb70c7e8e46 100644
--- a/app-editors/teco/teco-1.00-r3.ebuild
+++ b/app-editors/teco/teco-1.00-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/teco-1.00-r3.ebuild,v 1.8 2009/09/11 11:20:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/teco-1.00-r3.ebuild,v 1.9 2010/01/15 02:12:22 abcd Exp $
inherit toolchain-funcs flag-o-matic
@@ -14,7 +14,7 @@ SRC_URI="http://www.ibiblio.org/pub/linux/apps/editors/tty/teco.tar.gz
LICENSE="freedist"
SLOT="0"
-KEYWORDS="alpha ~amd64 ~ppc x86"
+KEYWORDS="alpha ~amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="doc"
RDEPEND="sys-libs/ncurses"
@@ -24,9 +24,10 @@ S=${WORKDIR}
src_unpack() {
unpack ${A}
- sed -i -e 's:-ltermcap:-lncurses:' ${S}/Makefile
+ sed -i -e 's:-ltermcap:-lncurses:' Makefile
# bug 103257
- epatch ${FILESDIR}/teco-double-free.diff
+ epatch "${FILESDIR}"/${PN}-double-free.diff
+ epatch "${FILESDIR}"/${PN}-gcc4.patch
}
src_compile() {