summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-05-15 21:28:37 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-05-15 21:28:37 +0000
commit3ab0b77a6a47bd352dd1e25c47b7529d6758ac7c (patch)
treef2e9148f92ffb1609a7ecfb304f6b4c34b9fb984 /app-editors
parentRevision bump for new genpatches. (diff)
downloadgentoo-2-3ab0b77a6a47bd352dd1e25c47b7529d6758ac7c.tar.gz
gentoo-2-3ab0b77a6a47bd352dd1e25c47b7529d6758ac7c.tar.bz2
gentoo-2-3ab0b77a6a47bd352dd1e25c47b7529d6758ac7c.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scite/ChangeLog10
-rw-r--r--app-editors/scite/files/scite-1.78-install.patch20
-rw-r--r--app-editors/scite/files/scite-1.78-no-lua.patch15
-rw-r--r--app-editors/scite/scite-1.78.ebuild75
4 files changed, 118 insertions, 2 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index 17b133df6565..c0e439eb1af8 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/scite
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.78 2009/02/02 23:42:06 nelchael Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.79 2009/05/15 21:28:37 nelchael Exp $
+
+*scite-1.78 (15 May 2009)
+
+ 15 May 2009; Krzysiek Pawlik <nelchael@gentoo.org> +scite-1.78.ebuild,
+ +files/scite-1.78-install.patch, +files/scite-1.78-no-lua.patch:
+ Version bump.
02 Feb 2009; Krzysiek Pawlik <nelchael@gentoo.org> ChangeLog:
Fix ChangeLog entries.
diff --git a/app-editors/scite/files/scite-1.78-install.patch b/app-editors/scite/files/scite-1.78-install.patch
new file mode 100644
index 000000000000..52f51e65b676
--- /dev/null
+++ b/app-editors/scite/files/scite-1.78-install.patch
@@ -0,0 +1,20 @@
+--- scite/gtk/makefile.orig 2006-10-09 06:26:55 -0300
++++ scite/gtk/makefile 2006-10-09 06:36:09 -0300
+@@ -123,11 +123,14 @@
+
+ ifdef gnomeprefix
+ ifdef GTK2
+- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
++ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
++ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
+ else
+- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
++ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
++ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
+ endif
+- $(INSTALL) -m 644 -D Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
++ $(INSTALL) -m 755 -d $(DESTDIR)$(pixmapdir)/
++ $(INSTALL) -m 644 Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
+ endif
+
+ uninstall:
diff --git a/app-editors/scite/files/scite-1.78-no-lua.patch b/app-editors/scite/files/scite-1.78-no-lua.patch
new file mode 100644
index 000000000000..2511cef0faf9
--- /dev/null
+++ b/app-editors/scite/files/scite-1.78-no-lua.patch
@@ -0,0 +1,15 @@
+--- scite/src/SciTEProps.cxx 2008-04-05 17:23:22.000000000 +0200
++++ scite/src/SciTEProps.cxx 2008-04-05 17:23:41.000000000 +0200
+@@ -1461,10 +1461,12 @@
+
+ // return the int value of the command name passed in.
+ int SciTEBase::GetMenuCommandAsInt(SString commandName) {
++#ifndef NO_LUA
+ int i = IFaceTable::FindConstant(commandName.c_str());
+ if (i != -1) {
+ return IFaceTable::constants[i].value;
+ }
++#endif
+ // Otherwise we might have entered a number as command to access a "SCI_" command
+ return commandName.value();
+ }
diff --git a/app-editors/scite/scite-1.78.ebuild b/app-editors/scite/scite-1.78.ebuild
new file mode 100644
index 000000000000..73186794e468
--- /dev/null
+++ b/app-editors/scite/scite-1.78.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.78.ebuild,v 1.1 2009/05/15 21:28:37 nelchael Exp $
+
+inherit toolchain-funcs eutils
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://scintilla.sourceforge.net/SciTE.html"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="Scintilla"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="lua"
+
+RDEPEND=">=x11-libs/gtk+-2
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}/gtk"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/scintilla/gtk"
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ || die "error patching makefile"
+
+ cd "${S}"
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ -e 's#-g root#-g 0#' \
+ || die "error patching makefile"
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}/${P}-install.patch"
+ epatch "${FILESDIR}/${P}-no-lua.patch"
+}
+
+src_compile() {
+ make -C ../../scintilla/gtk || die "prep make failed"
+ if use lua; then
+ emake || die "make failed"
+ else
+ emake NO_LUA=1 || die "make failed"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/{pixmaps,applications}
+
+ make prefix="${D}/usr" install || die
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv "${D}/usr/bin/SciTE" "${D}/usr/bin/scite"
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ # replace .desktop file with our own working version
+ insinto /usr/share/applications
+ rm -f "${D}/usr/share/applications/SciTE.desktop"
+ doins "${FILESDIR}/scite.desktop"
+
+ doman ../doc/scite.1
+ dodoc ../README
+}