summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2004-04-19 06:53:14 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2004-04-19 06:53:14 +0000
commit1765e22752802a5e1602ceaeac9154b6dcc617ae (patch)
treefcbeb0f803c99fc1eb203792939711b9a9f53b49 /app-editors
parentcleanup (Manifest recommit) (diff)
downloadgentoo-2-1765e22752802a5e1602ceaeac9154b6dcc617ae.tar.gz
gentoo-2-1765e22752802a5e1602ceaeac9154b6dcc617ae.tar.bz2
gentoo-2-1765e22752802a5e1602ceaeac9154b6dcc617ae.zip
Avoid problems with now-deprecated APIs. Closes bug #45514.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit/ChangeLog9
-rw-r--r--app-editors/gedit/gedit-2.4.1.ebuild16
2 files changed, 20 insertions, 5 deletions
diff --git a/app-editors/gedit/ChangeLog b/app-editors/gedit/ChangeLog
index f9640163dcbe..3707355012d7 100644
--- a/app-editors/gedit/ChangeLog
+++ b/app-editors/gedit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gedit
-# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.58 2004/04/17 09:38:41 lv Exp $
+# Copyright 1999-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.59 2004/04/19 06:53:14 leonardop Exp $
+
+ 19 Apr 2004; L. Boshell <leonardop@gentoo.org> gedit-2.4.1.ebuild:
+ Remove *_DISABLE_DEPRECATED macros, so it compiles with recent
+ Gtk+/Gnome libraries. Closes bug #45514. Fix eel dependency, as it won't
+ work with eel-2.6.0.
17 Apr 2004; Travis Tilley <lv@gentoo.org> gedit-2.4.1.ebuild:
stable on amd64
diff --git a/app-editors/gedit/gedit-2.4.1.ebuild b/app-editors/gedit/gedit-2.4.1.ebuild
index cb087b1b8163..29378a0d5bb3 100644
--- a/app-editors/gedit/gedit-2.4.1.ebuild
+++ b/app-editors/gedit/gedit-2.4.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.4.1.ebuild,v 1.11 2004/04/17 09:38:41 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.4.1.ebuild,v 1.12 2004/04/19 06:53:14 leonardop Exp $
-inherit gnome2 eutils
+inherit eutils gnome2
DESCRIPTION="A text editor for the Gnome2 desktop"
HOMEPAGE="http://www.gnome.org/"
@@ -14,7 +14,7 @@ IUSE="spell"
RDEPEND=">=gnome-base/libglade-2
>=dev-libs/popt-1.5
- >=gnome-base/eel-2.4
+ =gnome-base/eel-2.4*
>=gnome-base/gconf-2
>=gnome-base/libgnomeui-2.4
>=gnome-base/libbonobo-2.3
@@ -32,4 +32,14 @@ src_unpack() {
unpack ${A}
cd ${S}
use amd64 && epatch ${FILESDIR}/gedit-2.4.0-64bit-fix.patch
+
+ # Remove *_DISABLE_DEPRECATED macros so it compiles with recent
+ # Gtk+/Gnome libraries. See bug #45514.
+ for file in $(find . -name Makefile.in)
+ do
+ sed -i \
+ -e 's:-DGTK_DISABLE_DEPRECATED::g' \
+ -e 's:-DGNOME_DISABLE_DEPRECATED::g' \
+ $file
+ done
}