summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-10-26 19:35:09 +0000
committerHanno Böck <hanno@gentoo.org>2008-10-26 19:35:09 +0000
commit09641084bf7db77904081cb4b3e2a0f651530668 (patch)
tree82c9cd31f75b634fae1aa5aa88b7158578b37a7e /app-editors
parentx86 stable, bug #242792 (diff)
downloadgentoo-2-09641084bf7db77904081cb4b3e2a0f651530668.tar.gz
gentoo-2-09641084bf7db77904081cb4b3e2a0f651530668.tar.bz2
gentoo-2-09641084bf7db77904081cb4b3e2a0f651530668.zip
bluefish bump
(Portage version: 2.2_rc12/cvs/Linux 2.6.28-rc1-git2 x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/bluefish/ChangeLog7
-rw-r--r--app-editors/bluefish/bluefish-1.1.6.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/app-editors/bluefish/ChangeLog b/app-editors/bluefish/ChangeLog
index da26d55761a4..f9955c35a576 100644
--- a/app-editors/bluefish/ChangeLog
+++ b/app-editors/bluefish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/bluefish
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.60 2008/04/04 12:48:51 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.61 2008/10/26 19:35:09 hanno Exp $
+
+*bluefish-1.1.6 (26 Oct 2008)
+
+ 26 Oct 2008; Hanno Boeck <hanno@gentoo.org> +bluefish-1.1.6.ebuild:
+ Version bump, ebuild by Rolandas Valteris in #242512.
04 Apr 2008; Brent Baude <ranger@gentoo.org> bluefish-1.0.7.ebuild:
stable ppc64, bug 214905
diff --git a/app-editors/bluefish/bluefish-1.1.6.ebuild b/app-editors/bluefish/bluefish-1.1.6.ebuild
new file mode 100644
index 000000000000..6b8e14c4ddf8
--- /dev/null
+++ b/app-editors/bluefish/bluefish-1.1.6.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-1.1.6.ebuild,v 1.1 2008/10/26 19:35:09 hanno Exp $
+
+inherit eutils fdo-mime
+
+IUSE="nls spell gnome python"
+
+MY_P="${PN}-unstable-${PV}"
+
+DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://www.bennewitz.com/bluefish/devel/source/${MY_P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2
+ dev-libs/libpcre
+ spell? ( app-text/aspell )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-libs/glib-2
+ x11-libs/pango
+ gnome-base/gnome-vfs
+ dev-libs/libxml2
+ nls? ( sys-devel/gettext )
+ gnome? ( gnome-base/libgnomeui )
+ python? ( dev-lang/python )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e 's/-s -m 755/-m 755/g' src/Makefile.in
+}
+
+src_compile() {
+ econf --disable-update-databases \
+ --disable-xml-catalog-update \
+ $(use_enable nls) \
+ $(use_enable python) \
+ $(use_enable gnome libgnomeui) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ einfo "Adding XML catalog entries..."
+ /usr/bin/xmlcatalog --noout \
+ --add 'public' 'Bluefish/DTD/Bflang' 'bflang.dtd' \
+ --add 'system' 'http://bluefish.openoffice.nl/DTD/bflang.dtd' 'bflang.dtd' \
+ --add 'rewriteURI' 'http://bluefish.openoffice.nl/DTD' '/usr/share/xml/bluefish-unstable' \
+ /etc/xml/catalog \
+ || ewarn "Failed to add XML catalog entries."
+}
+
+pkg_postrm() {
+ einfo "Removing XML catalog entries..."
+ /usr/bin/xmlcatalog --noout \
+ --del 'Bluefish/DTD/Bflang' \
+ --del 'http://bluefish.openoffice.nl/DTD/bflang.dtd' \
+ --del 'http://bluefish.openoffice.nl/DTD' \
+ /etc/xml/catalog \
+ || ewarn "Failed to remove XML catalog entries."
+}