summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-12-03 19:55:30 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-12-03 19:55:30 +0000
commita4fa28b95858148c5d9341dc1dfc997636021788 (patch)
treea183417bdf3cbb2dfdaccc48870a4bbc12338d9e /app-editors/xmlcopyeditor
parentAdd even more LINGUAs by Alphat-PC (bug #445752). (diff)
downloadgentoo-2-a4fa28b95858148c5d9341dc1dfc997636021788.tar.gz
gentoo-2-a4fa28b95858148c5d9341dc1dfc997636021788.tar.bz2
gentoo-2-a4fa28b95858148c5d9341dc1dfc997636021788.zip
Version bump thanks to David Abbott <dabbott@gentoo.org>. Bug #443818
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'app-editors/xmlcopyeditor')
-rw-r--r--app-editors/xmlcopyeditor/ChangeLog8
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.9.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/app-editors/xmlcopyeditor/ChangeLog b/app-editors/xmlcopyeditor/ChangeLog
index 9fa6858778c4..82afad44c2c0 100644
--- a/app-editors/xmlcopyeditor/ChangeLog
+++ b/app-editors/xmlcopyeditor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/xmlcopyeditor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/ChangeLog,v 1.24 2012/11/27 10:13:16 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/ChangeLog,v 1.25 2012/12/03 19:55:30 hwoarang Exp $
+
+*xmlcopyeditor-1.2.0.9 (03 Dec 2012)
+
+ 03 Dec 2012; Markos Chandras <hwoarang@gentoo.org>
+ +xmlcopyeditor-1.2.0.9.ebuild:
+ Version bump thanks to David Abbott <dabbott@gentoo.org>. Bug #443818
27 Nov 2012; Sergey Popov <pinkbyte@gentoo.org> xmlcopyeditor-1.2.0.6.ebuild:
Fix some parts of .desktop file
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.9.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.9.ebuild
new file mode 100644
index 000000000000..6c6e3ea9d731
--- /dev/null
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.0.9.ebuild,v 1.1 2012/12/03 19:55:30 hwoarang Exp $
+
+EAPI="4"
+
+WX_GTK_VER="2.8"
+
+inherit autotools wxwidgets
+
+DESCRIPTION="XML Copy Editor is a fast, free, validating XML editor"
+HOMEPAGE="http://xml-copy-editor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xml-copy-editor/${P}.tar.gz
+ guidexml? ( mirror://gentoo/GuideXML-templates.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="aqua guidexml"
+
+RDEPEND=">=dev-libs/libxml2-2.7.3-r1
+ dev-libs/libxslt
+ dev-libs/xerces-c[icu]
+ dev-libs/libpcre
+ !aqua? ( x11-libs/wxGTK:2.8[X] )
+ aqua? ( x11-libs/wxGTK:2.8[aqua] )"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+DOCS=( AUTHORS ChangeLog README NEWS )
+
+src_prepare() {
+ # fix desktop file
+ sed -i -e '/Categories/s/Application;//' \
+ -e '/Icon/s/.png//' \
+ "src/${PN}.desktop" || die "sed on src/${PN}.desktop failed"
+ # bug #440744
+ sed -i -e 's/ -Wall -g -fexceptions//g' \
+ -e '/CXXFLAGS/s/CPPFLAGS/CXXFLAGS/' \
+ configure.in || die 'sed on configure.in failed'
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use guidexml; then
+ insinto /usr/share/xmlcopyeditor/templates/
+ for TEMPLATE in "${WORKDIR}"/GuideXML-templates/*.xml; do
+ newins "${TEMPLATE}" "${TEMPLATE##*/}"
+ done
+ fi
+
+}