summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-01-14 18:40:54 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-01-14 18:40:54 +0000
commit6db04753e02040ec9b8db597b38af5aac52adcdd (patch)
treeeacf08487fe2f4be4c5398ef3c1bf09c9e81e630 /app-editors/vim
parentenable on alpha (diff)
downloadgentoo-2-6db04753e02040ec9b8db597b38af5aac52adcdd.tar.gz
gentoo-2-6db04753e02040ec9b8db597b38af5aac52adcdd.tar.bz2
gentoo-2-6db04753e02040ec9b8db597b38af5aac52adcdd.zip
masked. patches 1-289
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/ChangeLog7
-rw-r--r--app-editors/vim/files/digest-vim-6.1-r182
-rw-r--r--app-editors/vim/vim-6.1-r18.ebuild87
3 files changed, 95 insertions, 1 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index 516c70dc389d..842efdfcc301 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.35 2003/01/06 10:41:54 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.36 2003/01/14 18:40:54 rphillips Exp $
+
+*vim-6.1-r18.ebuild (14 Jan 2003)
+
+ 14 Jan 2003; Ryan Phillips <rphillips@gentoo.org> vim-6.1-r18.ebuild :
+ patches 1-289
*vim-6.1-r17.ebuild (06 Dec 2002)
diff --git a/app-editors/vim/files/digest-vim-6.1-r18 b/app-editors/vim/files/digest-vim-6.1-r18
new file mode 100644
index 000000000000..bb1466cc2090
--- /dev/null
+++ b/app-editors/vim/files/digest-vim-6.1-r18
@@ -0,0 +1,2 @@
+MD5 7fd0f915adc7c0dab89772884268b030 vim-6.1.tar.bz2 2890049
+MD5 ce7f14e0f526220c85da6262661658e3 vimpatch-1-289.tar.bz2 216360
diff --git a/app-editors/vim/vim-6.1-r18.ebuild b/app-editors/vim/vim-6.1-r18.ebuild
new file mode 100644
index 000000000000..64ecec533281
--- /dev/null
+++ b/app-editors/vim/vim-6.1-r18.ebuild
@@ -0,0 +1,87 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r18.ebuild,v 1.1 2003/01/14 18:40:54 rphillips Exp $
+
+IUSE="nls perl python ruby tcltk gpm X"
+
+VIMPATCH="vimpatch-1-289.tar.bz2"
+inherit vim
+
+DESCRIPTION="Vi IMproved!"
+KEYWORDS="~x86 ~sparc ~alpha"
+DEPEND="app-editors/vim-core
+ sys-libs/libtermcap-compat
+ dev-util/cscope
+ >=sys-libs/ncurses-5.2-r2
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"
+# tcltk? ( dev-lang/tcl )"
+
+PROVIDE="virtual/editor"
+
+src_compile() {
+ local myconf
+ myconf="--with-features=big --enable-multibyte"
+ use nls && myconf="$myconf --enable-multibyte"
+ use nls || myconf="$myconf --disable-nls"
+ use perl && myconf="$myconf --enable-perlinterp"
+ use python && myconf="$myconf --enable-pythoninterp"
+ use ruby && myconf="$myconf --enable-rubyinterp"
+
+# tclinterp is BROKEN. See note above DEPEND=
+# use tcltk && myconf="$myconf --enable-tclinterp"
+
+# Added back gpm for temporary will remove if necessary, I think that I have
+# fixed most of gpm so it should be fine.
+ use gpm || myconf="$myconf --disable-gpm"
+
+ # the console vim will change the caption of a terminal in X.
+ # the configure script should autodetect X being installed, so
+ # we'll specifically turn it off if X is not in the USE vars.
+ # -rphillips
+ use X && myconf="$myconf --with-x"
+
+ # This should fix a sandbox violation.
+ for file in /dev/pty/s*
+ do
+ addwrite $file
+ done
+
+ #
+ # Build a nogui version, this will install as /usr/bin/vim
+ #
+ ./configure \
+ --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
+ --with-features=huge --enable-cscope $myconf \
+ --enable-gui=no \
+ || die "vim configure failed"
+
+ # move config files to /etc/vim/
+ echo "#define SYS_VIMRC_FILE \"/etc/vim/vimrc\"" \
+ >>${WORKDIR}/vim61/src/feature.h
+ echo "#define SYS_GVIMRC_FILE \"/etc/vim/gvimrc\"" \
+ >>${WORKDIR}/vim61/src/feature.h
+
+ # Parallel make does not work
+ make || die "vim make failed"
+}
+
+src_install() {
+ dobin src/vim
+ ln -s vim ${D}/usr/bin/vimdiff
+ ln -s vim ${D}/usr/bin/rvim
+ ln -s vim ${D}/usr/bin/ex
+ ln -s vim ${D}/usr/bin/view
+ ln -s vim ${D}/usr/bin/rview
+
+ # Default vimrc
+ insinto /etc/vim/
+ doins ${FILESDIR}/vimrc
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "gvim has now a seperate ebuild, 'emerge gvim' will install gvim"
+}