summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-07 15:39:20 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-07 15:39:20 +0000
commit97b468fbbc65da8d4f79e4bd741a7e91275c8447 (patch)
tree3df52cc681754fa848f590533b25349d79063eb1 /app-editors/tea
parentMigrate to EAPI 2. (diff)
downloadgentoo-2-97b468fbbc65da8d4f79e4bd741a7e91275c8447.tar.gz
gentoo-2-97b468fbbc65da8d4f79e4bd741a7e91275c8447.tar.bz2
gentoo-2-97b468fbbc65da8d4f79e4bd741a7e91275c8447.zip
Bump to 22.0.1. Fixes #246918
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/tea')
-rw-r--r--app-editors/tea/ChangeLog9
-rw-r--r--app-editors/tea/tea-22.0.1.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/app-editors/tea/ChangeLog b/app-editors/tea/ChangeLog
index 3d85d2a31dbe..93d221440c14 100644
--- a/app-editors/tea/ChangeLog
+++ b/app-editors/tea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/tea
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.42 2008/11/14 12:26:43 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.43 2009/03/07 15:39:20 patrick Exp $
+
+*tea-22.0.1 (07 Mar 2009)
+
+ 07 Mar 2009; Patrick Lauer <patrick@gentoo.org> +tea-22.0.1.ebuild:
+ Bump to 22.0.1. Fixes #246918. Ebuild fixes by Daniel Pielmeier.
14 Nov 2008; Raúl Porcel <armin76@gentoo.org> -tea-17.4.1.ebuild,
-tea-17.5.0.ebuild, -tea-17.5.1.ebuild, -tea-17.5.4.ebuild,
diff --git a/app-editors/tea/tea-22.0.1.ebuild b/app-editors/tea/tea-22.0.1.ebuild
new file mode 100644
index 000000000000..48e1e7b448a0
--- /dev/null
+++ b/app-editors/tea/tea-22.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-22.0.1.ebuild,v 1.1 2009/03/07 15:39:20 patrick Exp $
+
+EAPI="1"
+inherit qt4
+
+DESCRIPTION="Small, lightweight Qt text editor"
+HOMEPAGE="http://tea-editor.sourceforge.net"
+SRC_URI="mirror://sourceforge/tea-editor/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
+IUSE="spell"
+
+DEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-svg:4
+ x11-libs/qt-script"
+RDEPEND="${DEPEND}
+ spell? ( app-text/aspell )"
+
+#S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ eqmake4 src.pro
+ emake DESTDIR="${D}" || die "emake failed"
+}
+
+src_install() {
+ dobin bin/tea || die "Couldn't install tea"
+ dodoc AUTHORS ChangeLog NEWS NEWS-RU TODO
+ doicon icons/tea_icon_v2.png
+
+ make_desktop_entry tea Tea /usr/share/tea/pixmaps/tea_icon_v2.png Development
+}
+
+pkg_postinst() {
+ if use spell ; then
+ elog "To get full spellchecking functuality, ensure that you install"
+ elog "the relevant language pack(s)"
+ fi
+}