summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-06-01 15:44:29 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-06-01 15:44:29 +0000
commit328a6495b58aa5dcc727d040e7d5147176b5451b (patch)
tree0e20225fd79373b1b6a2fa76d94f67daf607cd6f /app-editors/tea
parentCall chromium_suid_sandbox_check_kernel_config from pkg_setup. (diff)
downloadgentoo-2-328a6495b58aa5dcc727d040e7d5147176b5451b.tar.gz
gentoo-2-328a6495b58aa5dcc727d040e7d5147176b5451b.tar.bz2
gentoo-2-328a6495b58aa5dcc727d040e7d5147176b5451b.zip
Version bump, remove old.
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/tea')
-rw-r--r--app-editors/tea/ChangeLog8
-rw-r--r--app-editors/tea/tea-33.1.0.ebuild (renamed from app-editors/tea/tea-32.0.2.ebuild)30
2 files changed, 18 insertions, 20 deletions
diff --git a/app-editors/tea/ChangeLog b/app-editors/tea/ChangeLog
index bc7e09988ed8..3609725a9287 100644
--- a/app-editors/tea/ChangeLog
+++ b/app-editors/tea/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/tea
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.56 2012/05/02 23:25:39 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.57 2012/06/01 15:44:29 kensington Exp $
+
+*tea-33.1.0 (01 Jun 2012)
+
+ 01 Jun 2012; Michael Palimaka <kensington@gentoo.org> +tea-33.1.0.ebuild,
+ -tea-32.0.2.ebuild:
+ Version bump, remove old.
02 May 2012; Davide Pesavento <pesa@gentoo.org> tea-32.0.2.ebuild:
Migrate to virtual/pkgconfig.
diff --git a/app-editors/tea/tea-32.0.2.ebuild b/app-editors/tea/tea-33.1.0.ebuild
index 8144e40806f3..b6204b6c968f 100644
--- a/app-editors/tea/tea-32.0.2.ebuild
+++ b/app-editors/tea/tea-33.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-32.0.2.ebuild,v 1.2 2012/05/02 23:25:39 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-33.1.0.ebuild,v 1.1 2012/06/01 15:44:29 kensington Exp $
EAPI=4
LANGS="de fr ru"
@@ -16,32 +16,24 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
IUSE="aspell hunspell"
-RDEPEND="sys-libs/zlib
+RDEPEND="
+ sys-libs/zlib
x11-libs/qt-core:4
x11-libs/qt-gui:4
aspell? ( app-text/aspell )
- hunspell? ( app-text/hunspell )"
+ hunspell? ( app-text/hunspell )
+"
DEPEND="${RDEPEND}
- hunspell? ( virtual/pkgconfig )"
+ hunspell? ( virtual/pkgconfig )
+"
DOCS="AUTHORS ChangeLog NEWS TODO"
src_configure() {
- local myopts
-
- if use aspell; then
- myopts="USE_ASPELL=true"
- else
- myopts="USE_ASPELL=false"
- fi
-
- if use hunspell; then
- myopts="${myopts} USE_HUNSPELL=true"
- else
- myopts="${myopts} USE_HUNSPELL=false"
- fi
-
- eqmake4 src.pro PREFIX="/usr/bin" ${myopts}
+ eqmake4 src.pro \
+ PREFIX="${EPREFIX}/usr/bin" \
+ USE_ASPELL=$(use aspell && echo true || echo false) \
+ USE_HUNSPELL=$(use hunspell && echo true || echo false)
}
src_install() {