summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-08-14 08:50:59 +0000
committerUlrich Müller <ulm@gentoo.org>2011-08-14 08:50:59 +0000
commitee34be3b7449618cc9f1da3e370cf3e194ba728b (patch)
treed26a04aa790be8e120ea2a7b4ae8107ff154983a /app-editors/qemacs
parentRemove obsoleted entries from selinux profiles from its package.mask files (diff)
downloadgentoo-2-ee34be3b7449618cc9f1da3e370cf3e194ba728b.tar.gz
gentoo-2-ee34be3b7449618cc9f1da3e370cf3e194ba728b.tar.bz2
gentoo-2-ee34be3b7449618cc9f1da3e370cf3e194ba728b.zip
Don't strip binaries in Makefile. Remove RESTRICT=strip.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/qemacs')
-rw-r--r--app-editors/qemacs/ChangeLog11
-rw-r--r--app-editors/qemacs/files/qemacs-0.4.0_pre20090420-nostrip.patch36
-rw-r--r--app-editors/qemacs/qemacs-0.4.0_pre20090420-r1.ebuild76
3 files changed, 121 insertions, 2 deletions
diff --git a/app-editors/qemacs/ChangeLog b/app-editors/qemacs/ChangeLog
index ab5c14ccba91..2435bb23e8d2 100644
--- a/app-editors/qemacs/ChangeLog
+++ b/app-editors/qemacs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/qemacs
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.50 2009/12/09 16:02:19 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.51 2011/08/14 08:50:59 ulm Exp $
+
+*qemacs-0.4.0_pre20090420-r1 (14 Aug 2011)
+
+ 14 Aug 2011; Ulrich Mueller <ulm@gentoo.org>
+ +qemacs-0.4.0_pre20090420-r1.ebuild,
+ +files/qemacs-0.4.0_pre20090420-nostrip.patch:
+ Don't strip binaries in Makefile. Remove RESTRICT=strip.
09 Dec 2009; Christian Faulhammer <fauli@gentoo.org>
-files/qemacs-0.3.1-manpage-ref-fix.patch,
diff --git a/app-editors/qemacs/files/qemacs-0.4.0_pre20090420-nostrip.patch b/app-editors/qemacs/files/qemacs-0.4.0_pre20090420-nostrip.patch
new file mode 100644
index 000000000000..120b09c2129d
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.4.0_pre20090420-nostrip.patch
@@ -0,0 +1,36 @@
+--- qemacs-orig/Makefile
++++ qemacs/Makefile
+@@ -151,7 +151,6 @@
+ qe$(EXE): qe_g$(EXE) Makefile
+ rm -f $@
+ cp $< $@
+- -$(STRIP) $@
+ @ls -l $@
+ echo `size $@` `wc -c $@` qe $(OPTIONS) \
+ | cut -d ' ' -f 7-10,13,15-40 >> STATS
+@@ -165,7 +164,6 @@
+ tqe$(EXE): tqe_g$(EXE) Makefile
+ rm -f $@
+ cp $< $@
+- -$(STRIP) $@
+ @ls -l $@
+ echo `size $@` `wc -c $@` tqe $(OPTIONS) \
+ | cut -d ' ' -f 7-10,13,15-40 >> STATS
+@@ -329,7 +327,7 @@
+ $(INSTALL) -m 755 -d $(DESTDIR)$(prefix)/bin
+ $(INSTALL) -m 755 -d $(DESTDIR)$(prefix)/man/man1
+ $(INSTALL) -m 755 -d $(DESTDIR)$(prefix)/share/qe
+- $(INSTALL) -m 755 -s qe$(EXE) $(DESTDIR)$(prefix)/bin/qemacs$(EXE)
++ $(INSTALL) -m 755 qe$(EXE) $(DESTDIR)$(prefix)/bin/qemacs$(EXE)
+ ln -sf qemacs $(DESTDIR)$(prefix)/bin/qe$(EXE)
+ ifdef CONFIG_FFMPEG
+ ln -sf qemacs$(EXE) $(DESTDIR)$(prefix)/bin/ffplay$(EXE)
+@@ -337,7 +335,7 @@
+ $(INSTALL) -m 644 kmaps ligatures $(DESTDIR)$(prefix)/share/qe
+ $(INSTALL) -m 644 qe.1 $(DESTDIR)$(prefix)/man/man1
+ ifdef CONFIG_HTML
+- $(INSTALL) -m 755 -s html2png$(EXE) $(DESTDIR)$(prefix)/bin
++ $(INSTALL) -m 755 html2png$(EXE) $(DESTDIR)$(prefix)/bin
+ endif
+
+ uninstall:
diff --git a/app-editors/qemacs/qemacs-0.4.0_pre20090420-r1.ebuild b/app-editors/qemacs/qemacs-0.4.0_pre20090420-r1.ebuild
new file mode 100644
index 000000000000..7614446850a8
--- /dev/null
+++ b/app-editors/qemacs/qemacs-0.4.0_pre20090420-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.4.0_pre20090420-r1.ebuild,v 1.1 2011/08/14 08:50:59 ulm Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="QEmacs is a very small but powerful UNIX editor"
+HOMEPAGE="http://savannah.nongnu.org/projects/qemacs"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X png unicode xv"
+RESTRICT="test"
+
+RDEPEND="
+ X? ( x11-libs/libX11
+ x11-libs/libXext
+ xv? ( x11-libs/libXv ) )
+ png? ( >=media-libs/libpng-1.2 )"
+
+DEPEND="${RDEPEND}
+ app-text/texi2html"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # Removes forced march setting and align-functions on x86, as they
+ # would override user's CFLAGS..
+ epatch "${FILESDIR}/${PN}-0.4.0_pre20080605-Makefile.patch"
+ # Make backup files optional
+ epatch "${FILESDIR}/${PN}-0.4.0_pre20080605-make_backup.patch"
+ # Suppress stripping
+ epatch "${FILESDIR}/${P}-nostrip.patch"
+
+ use unicode && epatch "${FILESDIR}/${PN}-0.3.2_pre20070226-tty_utf8.patch"
+
+ # Change the manpage to reference a /real/ file instead of just an
+ # approximation. Purely cosmetic!
+ sed -i "s,^/usr/share/doc/qe,&-${PVR}," qe.1 || die
+}
+
+src_configure() {
+ # when using any other CFLAGS than -O0, qemacs will segfault on startup,
+ # see bug 92011
+ replace-flags -O? -O0
+ econf --cc="$(tc-getCC)" \
+ $(use_enable X x11) \
+ $(use_enable png) \
+ $(use_enable xv)
+}
+
+src_compile() {
+ # Does not support parallel building.
+ emake -j1
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc Changelog README TODO config.eg
+ dohtml *.html
+
+ # Fix man page location
+ mv "${D}"/usr/{,share/}man || die
+
+ # Install headers so users can build their own plugins.
+ insinto /usr/include/qe
+ doins cfb.h config.h cutils.h display.h fbfrender.h libfbf.h qe.h \
+ qeconfig.h qestyles.h qfribidi.h
+ cd libqhtml
+ insinto /usr/include/qe/libqhtml
+ doins css.h cssid.h htmlent.h
+}