summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-02 18:15:01 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-02 18:15:01 +0000
commite887e405682534148c730d6aae366ae7cdf78144 (patch)
treec93220de295997c114ace8fc7760a681d85373b2 /app-editors/nano
parentInitial commit. Fixes #93504 (diff)
downloadgentoo-2-e887e405682534148c730d6aae366ae7cdf78144.tar.gz
gentoo-2-e887e405682534148c730d6aae366ae7cdf78144.tar.bz2
gentoo-2-e887e405682534148c730d6aae366ae7cdf78144.zip
search & replace fix from upstream
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/files/nano-1.3.8-rep.patch12
-rw-r--r--app-editors/nano/nano-1.3.8.ebuild3
2 files changed, 14 insertions, 1 deletions
diff --git a/app-editors/nano/files/nano-1.3.8-rep.patch b/app-editors/nano/files/nano-1.3.8-rep.patch
new file mode 100644
index 000000000000..8bfd5520419a
--- /dev/null
+++ b/app-editors/nano/files/nano-1.3.8-rep.patch
@@ -0,0 +1,12 @@
+Patch from upstream.
+--- nano-1.3.8/src/search.c
++++ nano-1.3.8/src/search.c
+@@ -907,6 +907,8 @@
+ last_search = mallocstrcpy(last_search, answer);
+ }
+
++ last_replace = mallocstrcpy(last_replace, "");
++
+ i = statusq(FALSE, replace_list_2, last_replace,
+ #ifndef NANO_SMALL
+ &replace_history,
diff --git a/app-editors/nano/nano-1.3.8.ebuild b/app-editors/nano/nano-1.3.8.ebuild
index 488c6e6b43b3..2b4a9ffa71db 100644
--- a/app-editors/nano/nano-1.3.8.ebuild
+++ b/app-editors/nano/nano-1.3.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.8.ebuild,v 1.1 2005/07/02 14:02:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.8.ebuild,v 1.2 2005/07/02 18:15:01 vapier Exp $
inherit eutils
@@ -22,6 +22,7 @@ PROVIDE="virtual/editor"
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-rep.patch
use nomac && epatch "${FILESDIR}"/${PN}-1.3.6-nomac.patch
}