summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-26 13:26:22 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-26 13:26:22 +0000
commita130c520866d2ee3df965255b36d3af53aa03995 (patch)
tree240e2de26ba077c4b5e45880eff340adafd61fe3 /app-editors/hteditor
parentmore error checking (Manifest recommit) (diff)
downloadgentoo-2-a130c520866d2ee3df965255b36d3af53aa03995.tar.gz
gentoo-2-a130c520866d2ee3df965255b36d3af53aa03995.tar.bz2
gentoo-2-a130c520866d2ee3df965255b36d3af53aa03995.zip
use $(tc-getCC)
Diffstat (limited to 'app-editors/hteditor')
-rw-r--r--app-editors/hteditor/files/digest-hteditor-0.7.31
-rw-r--r--app-editors/hteditor/hteditor-0.7.3.ebuild29
-rw-r--r--app-editors/hteditor/hteditor-0.7.4.ebuild6
-rw-r--r--app-editors/hteditor/hteditor-0.8.0_pre1.ebuild15
4 files changed, 12 insertions, 39 deletions
diff --git a/app-editors/hteditor/files/digest-hteditor-0.7.3 b/app-editors/hteditor/files/digest-hteditor-0.7.3
deleted file mode 100644
index f0f707725cf8..000000000000
--- a/app-editors/hteditor/files/digest-hteditor-0.7.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 746daea18735b38e46b3eb9addc97ad5 ht-0.7.3.tar.bz2 663567
diff --git a/app-editors/hteditor/hteditor-0.7.3.ebuild b/app-editors/hteditor/hteditor-0.7.3.ebuild
deleted file mode 100644
index 5efb1dca89cb..000000000000
--- a/app-editors/hteditor/hteditor-0.7.3.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.7.3.ebuild,v 1.6 2004/06/27 22:13:51 vapier Exp $
-
-DESCRIPTION="editor for executable files"
-HOMEPAGE="http://hte.sourceforge.net/"
-SRC_URI="mirror://sourceforge/hte/ht-${PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 -alpha"
-IUSE=""
-
-DEPEND="virtual/libc"
-
-S="${WORKDIR}/ht-${PV}"
-
-src_compile() {
- chmod +x configure
- ./configure --prefix=/usr --sysconfdir=/etc || die
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
- dodoc AUTHORS KNOWNBUGS TODO README
- dohtml doc/ht.html
- doinfo doc/*.info
-}
diff --git a/app-editors/hteditor/hteditor-0.7.4.ebuild b/app-editors/hteditor/hteditor-0.7.4.ebuild
index c05dd1408856..cc2f650ac8f2 100644
--- a/app-editors/hteditor/hteditor-0.7.4.ebuild
+++ b/app-editors/hteditor/hteditor-0.7.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.7.4.ebuild,v 1.7 2004/10/05 12:19:43 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.7.4.ebuild,v 1.8 2004/10/26 13:21:33 vapier Exp $
+
+inherit toolchain-funcs
DESCRIPTION="editor for executable files"
HOMEPAGE="http://hte.sourceforge.net/"
@@ -8,7 +10,7 @@ SRC_URI="mirror://sourceforge/hte/ht-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc -alpha"
+KEYWORDS="ppc x86"
IUSE=""
DEPEND="virtual/libc"
diff --git a/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild b/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild
index 8e83efd9b2b9..fb6f07010b06 100644
--- a/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild
+++ b/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild,v 1.3 2004/06/27 22:13:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.8.0_pre1.ebuild,v 1.4 2004/10/26 13:21:33 vapier Exp $
+
+inherit toolchain-funcs
DESCRIPTION="editor for executable files"
HOMEPAGE="http://hte.sourceforge.net/"
@@ -8,13 +10,12 @@ SRC_URI="mirror://sourceforge/hte/ht-${PV/_/}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc -alpha"
+KEYWORDS="~ppc ~x86"
IUSE=""
RDEPEND="virtual/libc
virtual/x11
sys-libs/ncurses"
-
DEPEND="${RDEPEND}
>=sys-devel/automake-1.4
sys-devel/autoconf
@@ -25,10 +26,10 @@ S="${WORKDIR}/ht-${PV/_/}"
src_compile() {
chmod +x configure
- local myconf="--prefix=/usr --sysconfdir=/etc"
- ./configure ${myconf} || die
- emake "CC=${CC}" CXX=${CXX} "CFLAGS=${CFLAGS}" \
- "CXXFLAGS=${CXXFLAGS}" "LDFLAGS=${LDFLAGS}"|| die
+ ./configure --prefix=/usr --sysconfdir=/etc || die
+ emake \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die
}
src_install() {