summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2014-09-29 14:31:01 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2014-09-29 14:31:01 +0000
commit9db8d0f15c7548ff310c7943afba9317ac99f9a5 (patch)
tree3d405451707aa3170c62be0580fc32023f281074 /app-editors/gedit
parentSecurity bump - bug #522498 (diff)
downloadgentoo-2-9db8d0f15c7548ff310c7943afba9317ac99f9a5.tar.gz
gentoo-2-9db8d0f15c7548ff310c7943afba9317ac99f9a5.tar.bz2
gentoo-2-9db8d0f15c7548ff310c7943afba9317ac99f9a5.zip
Really allow multiple python targets for python plugins and install gi overrides in the right place (bug #524018, thanks to Alexander Tsoy). Drop old.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/ChangeLog10
-rw-r--r--app-editors/gedit/gedit-3.12.2-r1.ebuild (renamed from app-editors/gedit/gedit-3.12.1.ebuild)48
2 files changed, 46 insertions, 12 deletions
diff --git a/app-editors/gedit/ChangeLog b/app-editors/gedit/ChangeLog
index 3801ca3839c4..4431a4293975 100644
--- a/app-editors/gedit/ChangeLog
+++ b/app-editors/gedit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/gedit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.371 2014/07/23 15:13:11 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.372 2014/09/29 14:31:01 tetromino Exp $
+
+*gedit-3.12.2-r1 (29 Sep 2014)
+
+ 29 Sep 2014; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -gedit-3.12.1.ebuild, +gedit-3.12.2-r1.ebuild:
+ Really allow multiple python targets for python plugins and install gi
+ overrides in the right place (bug #524018, thanks to Alexander Tsoy). Drop
+ old.
23 Jul 2014; Agostino Sarubbo <ago@gentoo.org> gedit-3.12.2.ebuild:
Stable for x86, wrt bug #512012
diff --git a/app-editors/gedit/gedit-3.12.1.ebuild b/app-editors/gedit/gedit-3.12.2-r1.ebuild
index 768c7942198c..75578bf83aa9 100644
--- a/app-editors/gedit/gedit-3.12.1.ebuild
+++ b/app-editors/gedit/gedit-3.12.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-3.12.1.ebuild,v 1.1 2014/04/27 15:30:11 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-3.12.2-r1.ebuild,v 1.1 2014/09/29 14:31:01 tetromino Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -10,7 +10,7 @@ PYTHON_COMPAT=( python3_{2,3} )
inherit eutils gnome2 multilib python-r1 virtualx
DESCRIPTION="A text editor for the GNOME desktop"
-HOMEPAGE="http://live.gnome.org/Gedit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
LICENSE="GPL-2+ CC-BY-SA-3.0"
SLOT="0"
@@ -50,6 +50,7 @@ COMMON_DEPEND="
"
RDEPEND="${COMMON_DEPEND}
x11-themes/gnome-icon-theme-symbolic
+ python? ( dev-libs/libpeas[${PYTHON_USEDEP}] )
"
DEPEND="${COMMON_DEPEND}
app-text/docbook-xml-dtd:4.1.2
@@ -72,15 +73,28 @@ src_prepare() {
src_configure() {
DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
- gnome2_src_configure \
- --disable-deprecations \
- --enable-updater \
- --enable-gvfs-metadata \
- $(use_enable introspection) \
- $(use_enable python) \
- $(use_enable spell) \
- $(use_enable zeitgeist) \
- ITSTOOL=$(type -P true)
+
+ gedit_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --disable-deprecations \
+ --enable-updater \
+ --enable-gvfs-metadata \
+ $(use_enable introspection) \
+ $(use_enable spell) \
+ $(use_enable zeitgeist) \
+ ITSTOOL=$(type -P true) \
+ "$@"
+ }
+
+ gedit_py_configure() {
+ mkdir -p "${BUILD_DIR}" || die
+ run_in_build_dir gedit_configure --enable-python
+ }
+
+ # run gedit_py_configure first to avoid out-of-source build for C code
+ use python && python_parallel_foreach_impl gedit_py_configure
+ gedit_configure --disable-python
}
src_test() {
@@ -90,3 +104,15 @@ src_test() {
unset DBUS_SESSION_BUS_ADDRESS
GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
}
+
+src_install() {
+ gedit_py_install() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ # manually set pyoverridesdir due to bug #524018 and AM_PATH_PYTHON limitations
+ emake DESTDIR="${D}" top_builddir="${S}" pyoverridesdir="$(python_get_sitedir)/gi/overrides" install
+ popd > /dev/null
+ }
+
+ gnome2_src_install
+ use python && python_foreach_impl gedit_py_install
+}