summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-09-13 08:44:13 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-09-13 08:44:13 +0000
commitad41f0fefecece9d4b5a2a1f773691d85525caef (patch)
tree2b20e028b1ac48a8a6a2d81c40fd2d96b560903d /app-editors/emacs-vcs
parentHonour Gentoo LDFLAGS, see bug #336979. (diff)
downloadgentoo-2-ad41f0fefecece9d4b5a2a1f773691d85525caef.tar.gz
gentoo-2-ad41f0fefecece9d4b5a2a1f773691d85525caef.tar.bz2
gentoo-2-ad41f0fefecece9d4b5a2a1f773691d85525caef.zip
add support for XML parsing with dev-libs/libxml2, which is more efficient than the built-in Elisp parsers, configurable with USE=libxml2
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'app-editors/emacs-vcs')
-rw-r--r--app-editors/emacs-vcs/ChangeLog7
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild7
-rw-r--r--app-editors/emacs-vcs/metadata.xml1
3 files changed, 11 insertions, 4 deletions
diff --git a/app-editors/emacs-vcs/ChangeLog b/app-editors/emacs-vcs/ChangeLog
index 54384fe9acc3..47dbd806979d 100644
--- a/app-editors/emacs-vcs/ChangeLog
+++ b/app-editors/emacs-vcs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/emacs-vcs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/ChangeLog,v 1.23 2010/09/02 14:53:20 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/ChangeLog,v 1.24 2010/09/13 08:44:13 fauli Exp $
+
+ 13 Sep 2010; Christian Faulhammer <fauli@gentoo.org>
+ emacs-vcs-24.0.9999.ebuild, metadata.xml:
+ add support for XML parsing with dev-libs/libxml2, which is more efficient
+ than the built-in Elisp parsers, configurable with USE=libxml2
02 Sep 2010; Christian Faulhammer <fauli@gentoo.org>
emacs-vcs-24.0.9999.ebuild, metadata.xml:
diff --git a/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
index 072719a3ef24..b450f0c88e49 100644
--- a/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild,v 1.9 2010/09/02 14:53:21 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild,v 1.10 2010/09/13 08:44:13 fauli Exp $
EAPI=2
@@ -28,7 +28,7 @@ HOMEPAGE="http://www.gnu.org/software/emacs/"
LICENSE="GPL-3 FDL-1.3 BSD as-is MIT W3C unicode"
SLOT="24"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="alsa dbus gconf gif gpm gtk gzip-el hesiod imagemagick jpeg kerberos m17n-lib motif png sound source svg tiff toolkit-scroll-bars X Xaw3d xft +xpm"
+IUSE="alsa dbus gconf gif gpm gtk gzip-el hesiod imagemagick jpeg kerberos libxml2 m17n-lib motif png sound source svg tiff toolkit-scroll-bars X Xaw3d xft +xpm"
RESTRICT="strip"
RDEPEND="sys-libs/ncurses
@@ -44,6 +44,7 @@ RDEPEND="sys-libs/ncurses
x11-libs/libXt
x11-misc/xbitmaps
gconf? ( >=gnome-base/gconf-2.26.2 )
+ libxml2? ( >=dev-libs/libxml2-2.2.0 )
gif? ( media-libs/giflib )
jpeg? ( media-libs/jpeg:0 )
png? ( media-libs/libpng )
@@ -148,7 +149,7 @@ src_configure() {
if use X; then
myconf="${myconf} --with-x"
- myconf="${myconf} $(use_with gconf)"
+ myconf="${myconf} $(use_with gconf) $(use_with libxml2 xml2)"
myconf="${myconf} $(use_with toolkit-scroll-bars)"
myconf="${myconf} $(use_with gif) $(use_with jpeg)"
myconf="${myconf} $(use_with png) $(use_with svg rsvg)"
diff --git a/app-editors/emacs-vcs/metadata.xml b/app-editors/emacs-vcs/metadata.xml
index 6cfab160e7a4..4c230bfef91a 100644
--- a/app-editors/emacs-vcs/metadata.xml
+++ b/app-editors/emacs-vcs/metadata.xml
@@ -25,6 +25,7 @@
<flag name='gzip-el'>Compress bundled Emacs Lisp source</flag>
<flag name='hesiod'>Enable support for <pkg>net-dns/hesiod</pkg></flag>
<flag name='imagemagick'>Use <pkg>media-gfx/imagemagick</pkg> for image processing</flag>
+ <flag name='libxml2'>Use <pkg>dev-libs/libxml2</pkg> to parse XML instead of the internal Lisp implementations</flag>
<flag name='sound'>Enable sound</flag>
<flag name='toolkit-scroll-bars'>Use the selected toolkit's scrollbars in
preference to Emacs' own scrollbars</flag>