summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-03-17 23:09:57 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-03-17 23:09:57 +0000
commitd3cc6698df555c6a78f05b1c324176ad1b75e1fd (patch)
treee4ba752c524a9a3aaf7c2ab967e8ac5d8f11148b /app-editors/editra
parentadd upstream's pre-release version of the 195.x.y series. Still needs to be t... (diff)
downloadgentoo-2-d3cc6698df555c6a78f05b1c324176ad1b75e1fd.tar.gz
gentoo-2-d3cc6698df555c6a78f05b1c324176ad1b75e1fd.tar.bz2
gentoo-2-d3cc6698df555c6a78f05b1c324176ad1b75e1fd.zip
Version bump. Use new --no-clean option added to prevent sandbox
violations. (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/editra')
-rw-r--r--app-editors/editra/ChangeLog8
-rw-r--r--app-editors/editra/editra-0.5.51.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/app-editors/editra/ChangeLog b/app-editors/editra/ChangeLog
index 321c327413d4..c6e88a4d43d3 100644
--- a/app-editors/editra/ChangeLog
+++ b/app-editors/editra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/editra
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/editra/ChangeLog,v 1.12 2010/03/07 21:29:36 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/editra/ChangeLog,v 1.13 2010/03/17 23:09:57 dirtyepic Exp $
+
+*editra-0.5.51 (17 Mar 2010)
+
+ 17 Mar 2010; Ryan Hill <dirtyepic@gentoo.org> +editra-0.5.51.ebuild:
+ Version bump. Use new --no-clean option added to prevent sandbox
+ violations.
07 Mar 2010; Jonathan Callen <abcd@gentoo.org> editra-0.5.32.ebuild:
Move PYTHON_DEPEND before inherit(), so that the dep is actually added
diff --git a/app-editors/editra/editra-0.5.51.ebuild b/app-editors/editra/editra-0.5.51.ebuild
new file mode 100644
index 000000000000..b39fa9fd5064
--- /dev/null
+++ b/app-editors/editra/editra-0.5.51.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/editra/editra-0.5.51.ebuild,v 1.1 2010/03/17 23:09:57 dirtyepic Exp $
+
+EAPI=2
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.4"
+
+inherit distutils eutils fdo-mime python
+
+MY_PN=${PN/e/E}
+
+DESCRIPTION="Multi-platform text editor supporting over 50 programming languages."
+HOMEPAGE="http://editra.org http://pypi.python.org/pypi/Editra"
+SRC_URI="http://editra.org/uploads/src/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="spell"
+
+DEPEND=">=dev-python/wxpython-2.8.9.2:2.8
+ >=dev-python/setuptools-0.6"
+# setuptools is RDEPEND because it's used by the runtime for installing plugins
+RDEPEND="${DEPEND}
+ spell? ( dev-python/pyenchant )"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+src_install() {
+ distutils_src_install --no-clean
+ insinto /usr/share/pixmaps
+ doins "${S}"/pixmaps/editra.png
+ make_desktop_entry Editra Editra editra "Development;TextEditor"
+ dodoc FAQ THANKS
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ fdo-mime_desktop_database_update
+}