summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-09-05 18:09:54 +0000
committerUlrich Müller <ulm@gentoo.org>2008-09-05 18:09:54 +0000
commit7a985e22752a4f846b3d9509648df1cba923f8b8 (patch)
tree309a4561d2ca9a6ca89d4663c195d70c093c29dd /app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild
parentstable amd64, bug 236612 (diff)
downloadgentoo-2-7a985e22752a4f846b3d9509648df1cba923f8b8.tar.gz
gentoo-2-7a985e22752a4f846b3d9509648df1cba923f8b8.tar.bz2
gentoo-2-7a985e22752a4f846b3d9509648df1cba923f8b8.zip
Add patch to require cl extensions.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild')
-rw-r--r--app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild
new file mode 100644
index 000000000000..732998668589
--- /dev/null
+++ b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild,v 1.1 2008/09/05 18:09:53 ulm Exp $
+
+inherit elisp-common eutils
+
+DESCRIPTION="Casting SPELs in Lisp - A Comic Book (Emacs Lisp Edition)"
+HOMEPAGE="http://code.google.com/p/casting-spels-emacs/"
+SRC_URI="http://casting-spels-emacs.googlecode.com/files/${PN}-v${PV}.zip"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/emacs"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ edos2unix *.txt html/*.html {lisp,test}/*.el || die "edos2unix failed"
+
+ # needs cl extensions
+ epatch "${FILESDIR}/${P}-require-cl.patch"
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el || die "elisp-install failed"
+ dohtml -r html/. images || die "dohtml failed"
+ dosym html/images /usr/share/doc/${PF}/images
+ dosym ${SITELISP}/${PN} /usr/share/doc/${PF}/lisp
+ dodoc README.txt test/walk-through-commands.el
+}