summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2008-03-23 13:08:33 +0000
committerSven Wegener <swegener@gentoo.org>2008-03-23 13:08:33 +0000
commitc61cbb979e4f59678e028ef33ee005164475d7fb (patch)
tree97cc60e581a52a34bbb79cc1e550f5ba7dd98835 /app-crypt
parentFix multilib issue, ruby bindings now doing site installation, bug #214051, t... (diff)
downloadgentoo-2-c61cbb979e4f59678e028ef33ee005164475d7fb.tar.gz
gentoo-2-c61cbb979e4f59678e028ef33ee005164475d7fb.tar.bz2
gentoo-2-c61cbb979e4f59678e028ef33ee005164475d7fb.zip
Version bump, bug #213383. Drop bindnow-flags, bug #213669. Workaround for API change in >=glib-2.16.1, bug #213382.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/pinentry/ChangeLog10
-rw-r--r--app-crypt/pinentry/files/pinentry-0.7.5-grab.patch15
-rw-r--r--app-crypt/pinentry/files/pinentry-gmem.patch45
-rw-r--r--app-crypt/pinentry/pinentry-0.7.3.ebuild9
-rw-r--r--app-crypt/pinentry/pinentry-0.7.4-r1.ebuild8
-rw-r--r--app-crypt/pinentry/pinentry-0.7.5.ebuild68
6 files changed, 145 insertions, 10 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
index 17373c3aacc7..2d6e2b42eb35 100644
--- a/app-crypt/pinentry/ChangeLog
+++ b/app-crypt/pinentry/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-crypt/pinentry
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.82 2008/02/13 10:59:30 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.83 2008/03/23 13:08:32 swegener Exp $
+
+*pinentry-0.7.5 (23 Mar 2008)
+
+ 23 Mar 2008; Sven Wegener <swegener@gentoo.org>
+ +files/pinentry-0.7.5-grab.patch, +files/pinentry-gmem.patch,
+ pinentry-0.7.3.ebuild, pinentry-0.7.4-r1.ebuild, +pinentry-0.7.5.ebuild:
+ Version bump, bug #213383. Drop bindnow-flags, bug #213669. Workaround for
+ API change in >=glib-2.16.1, bug #213382.
13 Feb 2008; Alon Bar-Lev <alonbl@gentoo.org> -pinentry-0.7.2-r3.ebuild:
Cleanup
diff --git a/app-crypt/pinentry/files/pinentry-0.7.5-grab.patch b/app-crypt/pinentry/files/pinentry-0.7.5-grab.patch
new file mode 100644
index 000000000000..7cd3d96cdc9e
--- /dev/null
+++ b/app-crypt/pinentry/files/pinentry-0.7.5-grab.patch
@@ -0,0 +1,15 @@
+--- pinentry/gtk+-2/pinentry-gtk-2.c
++++ pinentry/gtk+-2/pinentry-gtk-2.c
+@@ -261,10 +261,10 @@ create_window (int confirm_mode)
+ if (!confirm_mode)
+ {
+ g_signal_connect (G_OBJECT (win),
+- pinentry->grab ? "map-event" : "focus-in-event",
++ "focus-in-event",
+ G_CALLBACK (grab_keyboard), NULL);
+ g_signal_connect (G_OBJECT (win),
+- pinentry->grab ? "unmap-event" : "focus-out-event",
++ "focus-out-event",
+ G_CALLBACK (ungrab_keyboard), NULL);
+ }
+ gtk_window_add_accel_group (GTK_WINDOW (win), acc);
diff --git a/app-crypt/pinentry/files/pinentry-gmem.patch b/app-crypt/pinentry/files/pinentry-gmem.patch
new file mode 100644
index 000000000000..78121e6b3dbe
--- /dev/null
+++ b/app-crypt/pinentry/files/pinentry-gmem.patch
@@ -0,0 +1,45 @@
+Workaround for API change in >=glib-2.16.1, bug #213382
+
+This is not the final solution, but the patches posted on the mailing-list
+cause more breakage than they help to solve the problem.
+
+Index: pinentry/gtk+-2/gtksecentry.c
+===================================================================
+--- pinentry/gtk+-2/gtksecentry.c (revision 181)
++++ pinentry/gtk+-2/gtksecentry.c (working copy)
+@@ -270,7 +270,11 @@
+
+
+ gpointer
++#if GLIB_CHECK_VERSION(2, 16, 1)
++g_malloc(gsize size)
++#else
+ g_malloc(gulong size)
++#endif
+ {
+ gpointer p;
+
+@@ -288,7 +292,11 @@
+ }
+
+ gpointer
++#if GLIB_CHECK_VERSION(2, 16, 1)
++g_malloc0(gsize size)
++#else
+ g_malloc0(gulong size)
++#endif
+ {
+ gpointer p;
+
+@@ -308,7 +316,11 @@
+ }
+
+ gpointer
++#if GLIB_CHECK_VERSION(2, 16, 1)
++g_realloc(gpointer mem, gsize size)
++#else
+ g_realloc(gpointer mem, gulong size)
++#endif
+ {
+ gpointer p;
+
diff --git a/app-crypt/pinentry/pinentry-0.7.3.ebuild b/app-crypt/pinentry/pinentry-0.7.3.ebuild
index 3b90b4c0f56a..f11b12e995c4 100644
--- a/app-crypt/pinentry/pinentry-0.7.3.ebuild
+++ b/app-crypt/pinentry/pinentry-0.7.3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.3.ebuild,v 1.9 2007/10/09 14:59:19 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.3.ebuild,v 1.10 2008/03/23 13:08:32 swegener Exp $
#WANT_AUTOCONF="2.5"
#WANT_AUTOMAKE="1.9"
-inherit flag-o-matic qt3 multilib eutils autotools
+inherit qt3 multilib eutils autotools
DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
HOMEPAGE="http://www.gnupg.org/aegypten/"
@@ -29,6 +29,7 @@ src_unpack() {
epatch "${FILESDIR}/0.7.2-libcap.patch"
epatch "${FILESDIR}/0.7.2-info.patch"
epatch "${FILESDIR}/${PN}-0.7.2-grab.patch"
+ epatch "${FILESDIR}/${PN}-gmem.patch"
AT_M4DIR="m4" eautoreconf
}
@@ -41,8 +42,6 @@ src_compile() {
myconf="--enable-pinentry-curses --enable-fallback-curses"
fi
- append-ldflags $(bindnow-flags)
-
# Issues finding qt on multilib systems
export QTLIB="${QTDIR}/$(get_libdir)"
diff --git a/app-crypt/pinentry/pinentry-0.7.4-r1.ebuild b/app-crypt/pinentry/pinentry-0.7.4-r1.ebuild
index 5fda7713a56c..ab530a866e07 100644
--- a/app-crypt/pinentry/pinentry-0.7.4-r1.ebuild
+++ b/app-crypt/pinentry/pinentry-0.7.4-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.4-r1.ebuild,v 1.6 2008/01/21 21:10:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.4-r1.ebuild,v 1.7 2008/03/23 13:08:32 swegener Exp $
-inherit qt3 multilib eutils flag-o-matic
+inherit qt3 multilib eutils
DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
HOMEPAGE="http://www.gnupg.org/aegypten/"
@@ -22,7 +22,9 @@ DEPEND="gtk? ( =x11-libs/gtk+-2* )
src_unpack() {
unpack ${A}
cd "${S}"
+
epatch "${FILESDIR}/${P}-grab.patch"
+ epatch "${FILESDIR}/${PN}-gmem.patch"
}
src_compile() {
@@ -33,8 +35,6 @@ src_compile() {
myconf="--enable-pinentry-curses --enable-fallback-curses"
fi
- append-ldflags $(bindnow-flags)
-
# Issues finding qt on multilib systems
export QTLIB="${QTDIR}/$(get_libdir)"
diff --git a/app-crypt/pinentry/pinentry-0.7.5.ebuild b/app-crypt/pinentry/pinentry-0.7.5.ebuild
new file mode 100644
index 000000000000..f53a3623e053
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-0.7.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.5.ebuild,v 1.1 2008/03/23 13:08:32 swegener Exp $
+
+inherit qt3 multilib eutils
+
+DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="http://www.gnupg.org/aegypten/"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk ncurses qt3 caps"
+
+DEPEND="gtk? ( =x11-libs/gtk+-2* )
+ ncurses? ( sys-libs/ncurses )
+ qt3? ( $(qt_min_version 3.3) )
+ !gtk? ( !qt3? ( !ncurses? ( sys-libs/ncurses ) ) )
+ caps? ( sys-libs/libcap )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-grab.patch"
+ epatch "${FILESDIR}/${PN}-gmem.patch"
+}
+
+src_compile() {
+ local myconf=""
+
+ if ! ( use qt3 || use gtk || use ncurses )
+ then
+ myconf="--enable-pinentry-curses --enable-fallback-curses"
+ fi
+
+ # Issues finding qt on multilib systems
+ export QTLIB="${QTDIR}/$(get_libdir)"
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-maintainer-mode \
+ --disable-pinentry-gtk \
+ $(use_enable gtk pinentry-gtk2) \
+ $(use_enable qt3 pinentry-qt) \
+ $(use_enable ncurses pinentry-curses) \
+ $(use_enable ncurses fallback-curses) \
+ $(use_with caps libcap) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "We no longer install pinentry-curses and pinentry-qt SUID root by default."
+ elog "Linux kernels >=2.6.9 support memory locking for unprivileged processes."
+ elog "The soft resource limit for memory locking specifies the limit an"
+ elog "unprivileged process may lock into memory. You can also use POSIX"
+ elog "capabilities to allow pinentry to lock memory. To do so activate the caps"
+ elog "USE flag and add the CAP_IPC_LOCK capability to the permitted set of"
+ elog "your users."
+}