summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-06-29 22:25:56 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-06-29 22:25:56 +0000
commit5e8c1e89c4c874d06094d8185b55830500cfc2b4 (patch)
tree92afa7dbdf4c23a96c91f526c1fdc820c83daa83 /app-crypt
parentVersion bump, upstream broke the BER decoder, and this broke gnupg-1.9*. (diff)
downloadgentoo-2-5e8c1e89c4c874d06094d8185b55830500cfc2b4.tar.gz
gentoo-2-5e8c1e89c4c874d06094d8185b55830500cfc2b4.tar.bz2
gentoo-2-5e8c1e89c4c874d06094d8185b55830500cfc2b4.zip
Version bump to 1.9.21 for security bug #137622, please note the newer version of libksba that is required!.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/ChangeLog8
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.9.213
-rw-r--r--app-crypt/gnupg/gnupg-1.9.21.ebuild108
3 files changed, 118 insertions, 1 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index b07231347177..56a654fd4c21 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/gnupg
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.206 2006/06/28 19:18:03 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.207 2006/06/29 22:25:56 robbat2 Exp $
+
+*gnupg-1.9.21 (29 Jun 2006)
+
+ 29 Jun 2006; Robin H. Johnson <robbat2@gentoo.org> +gnupg-1.9.21.ebuild:
+ Version bump to 1.9.21 for security bug #137622, please note the newer
+ version of libksba that is required!.
28 Jun 2006; Rene Nussbaumer <killerfox@gentoo.org> gnupg-1.4.4.ebuild:
Stable on hppa. See bug #137622.
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.9.21 b/app-crypt/gnupg/files/digest-gnupg-1.9.21
new file mode 100644
index 000000000000..7f65fdcd534c
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.9.21
@@ -0,0 +1,3 @@
+MD5 94f4e2ded63820efa6903543c2e06017 gnupg-1.9.21.tar.bz2 1901908
+RMD160 f522125f30a29fd2bcacca5894958242946de430 gnupg-1.9.21.tar.bz2 1901908
+SHA256 7dfaa7867427dd44ac3277026dec3602626b657d95952b7a5bdeb9e567b5d34c gnupg-1.9.21.tar.bz2 1901908
diff --git a/app-crypt/gnupg/gnupg-1.9.21.ebuild b/app-crypt/gnupg/gnupg-1.9.21.ebuild
new file mode 100644
index 000000000000..993348bb85b5
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.9.21.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.9.21.ebuild,v 1.1 2006/06/29 22:25:56 robbat2 Exp $
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/alpha/gnupg/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="1.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="X gpg2-experimental ldap nls smartcard selinux"
+#IUSE+=caps
+
+COMMON_DEPEND="
+ dev-lang/perl
+ sys-libs/zlib
+ virtual/libc
+ >=dev-libs/pth-1.3.7
+ smartcard? ( >=dev-libs/opensc-0.8.0 )
+ >=dev-libs/libgcrypt-1.1.94
+ >=dev-libs/libksba-0.9.15
+ >=dev-libs/libgpg-error-1.0
+ ~dev-libs/libassuan-0.6.10
+ ldap? ( net-nds/openldap )"
+# caps? ( sys-libs/libcap )"
+
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="${COMMON_DEPEND}
+ !app-crypt/gpg-agent
+ =app-crypt/gnupg-1.4*
+ X? ( || ( media-gfx/xloadimage media-gfx/xli ) )
+ virtual/mta
+ selinux? ( sec-policy/selinux-gnupg )
+ nls? ( virtual/libintl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if use smartcard && ! built_with_use dev-libs/opensc pcsc-lite ; then
+ sed -i -e 's:OPENSC_LIBS="\$OPENSC_LIBS -lpcsclite -lpthread":OPENSC_LIBS="\$OPENSC_LIBS -lopenct -lpthread":' \
+ acinclude.m4 || die "openct patching failed."
+ ./autogen.sh
+ fi
+ sed -i -e 's/PIC/__PIC__/g' intl/relocatable.c || die "PIC patching failed"
+
+ epatch "${FILESDIR}/${PN}-1.9.20-fbsd.patch"
+ #epatch "${FILESDIR}/${P}-fbsd-gcc41.patch"
+ AT_M4DIR="m4 gl/m4" eautoreconf
+}
+
+src_compile() {
+ local myconf=""
+
+ if use X; then
+ local viewer
+ if has_version 'media-gfx/xloadimage'; then
+ viewer=/usr/bin/xloadimage
+ else
+ viewer=/usr/bin/xli
+ fi
+ myconf="${myconf} --with-photo-viewer=${viewer}"
+ else
+ myconf="${myconf} --disable-photo-viewers"
+ fi
+
+ #use caps || append-ldflags $(bindnow-flags)
+ append-ldflags $(bindnow-flags)
+
+ #$(use_with caps capabilities) \
+ econf \
+ --enable-agent \
+ --enable-symcryptrun \
+ $(use_enable gpg2-experimental gpg) \
+ --enable-gpgsm \
+ $(use_enable smartcard scdaemon) \
+ $(use_enable nls) \
+ $(use_enable ldap) \
+ --disable-capabilities \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ChangeLog NEWS README THANKS TODO VERSION
+
+ #if ! use caps; then
+ use gpg2-experimental && fperms u+s,go-r /usr/bin/gpg2
+ fperms u+s,go-r /usr/bin/gpg-agent
+ #fi
+}
+
+pkg_postinst() {
+ #if ! use caps; then
+ # einfo "gpg is installed suid root to make use of protected memory space"
+ # einfo "This is needed in order to have a secure place to store your"
+ # einfo "passphrases, etc. at runtime but may make some sysadmins nervous."
+ #fi
+ einfo
+ einfo "See http://www.gentoo.org/doc/en/gnupg-user.xml for documentation on gnupg"
+ einfo
+}