summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2006-10-27 01:34:44 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2006-10-27 01:34:44 +0000
commit2f77123ce7e9215af437c979717aab817bdb8b3b (patch)
tree41afb7ffc0974cee919dbf979bd0f45c59611812 /app-crypt
parentFix postinstall instructions, bug #135233. (diff)
downloadgentoo-2-2f77123ce7e9215af437c979717aab817bdb8b3b.tar.gz
gentoo-2-2f77123ce7e9215af437c979717aab817bdb8b3b.tar.bz2
gentoo-2-2f77123ce7e9215af437c979717aab817bdb8b3b.zip
Fixes db detection, thanks to Tomas Sedlak, bug#152846. Cleanup old revisions, organize patchset
(Portage version: 2.1.1)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/xca/ChangeLog9
-rw-r--r--app-crypt/xca/files/xca-0.5.1-build.patch98
-rw-r--r--app-crypt/xca/files/xca-0.5.1-qt.patch12
-rw-r--r--app-crypt/xca/xca-0.5.1-r1.ebuild23
4 files changed, 129 insertions, 13 deletions
diff --git a/app-crypt/xca/ChangeLog b/app-crypt/xca/ChangeLog
index 4b31f0d56948..ee4d4028fc04 100644
--- a/app-crypt/xca/ChangeLog
+++ b/app-crypt/xca/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/xca
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.8 2006/10/06 22:41:18 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.9 2006/10/27 01:34:44 alonbl Exp $
+
+ 27 Oct 2006; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/xca-0.5.1-build.patch, -files/xca-0.5.1-qt.diff,
+ +files/xca-0.5.1-qt.patch, -files/Rules.mak-prefix.patch,
+ -files/configure-db.patch, -xca-0.5.1.ebuild, xca-0.5.1-r1.ebuild:
+ Fixes db detection, thanks to Tomas Sedlak, bug#152846. Cleanup old
+ revisions, organize patchset
*xca-0.5.1-r1 (06 Oct 2006)
diff --git a/app-crypt/xca/files/xca-0.5.1-build.patch b/app-crypt/xca/files/xca-0.5.1-build.patch
new file mode 100644
index 000000000000..9fbafdc04315
--- /dev/null
+++ b/app-crypt/xca/files/xca-0.5.1-build.patch
@@ -0,0 +1,98 @@
+diff -urNp xca-0.5.1.org/configure xca-0.5.1/configure
+--- xca-0.5.1.org/configure 2004-04-23 11:22:57.000000000 +0300
++++ xca-0.5.1/configure 2006-10-26 22:23:56.000000000 +0200
+@@ -66,9 +66,11 @@ add_lib() {
+ search_includes() {
+ for dir in ${DIRS}; do
+ for dbn in "" ${subdirs}; do
+- if test -r ${dir}/include${dbn}/$1; then
+- add_include ${dir}/include${dbn}
+- echo Found: $1 at ${dir}/include${dbn}
++ for inc_path in `ls -dr "${dir}"/include${dbn} 2> /dev/null`; do
++ if test -r "${inc_path}/$1"; then
++ add_include "${inc_path}"
++ echo "Found: $1 at ${inc_path}"
+- return 0
++ return 0
++ fi
++ done
+- fi
+ done
+@@ -81,9 +81,9 @@ search_lib() {
+ for dir in ${DIRS}; do
+ for dbn in $@; do
+ for suffix in so dylib obj; do
+- if test -r ${dir}/lib/lib${dbn}.${suffix}; then
+- add_lib ${dir}/lib ${dbn};
+- echo Found: lib${dbn}.${suffix} at ${dir}/lib
++ if test -r "${dir}/lib/lib${dbn}.${suffix}"; then
++ add_lib "${dir}/lib" "${dbn}";
++ echo "Found: lib${dbn}.${suffix} at ${dir}/lib"
+ return 0
+ fi
+ done
+@@ -94,7 +94,7 @@ search_lib() {
+
+
+ ######################## DB
+-subdirs="/db /db4 /db3"
++subdirs="/db4.?"
+ search_includes db_cxx.h || err "The Berkeley DB header files were not found"
+ search_lib db_cxx db4_cxx db_cxx-4 db3_cxx db_cxx-3 || err "The Berkeley DB library was not found. Try installing db-dev"
+ ## The fun of NPTL... (Thx Enrico Scholz)
+@@ -144,11 +144,11 @@ fi
+
+
+
+-if test -x $QTDIR/bin/moc; then
++if test -x "$QTDIR/bin/moc"; then
+ MOC="$QTDIR/bin/moc"
+ fi
+
+-if test -x $QTDIR/bin/uic; then
++if test -x "$QTDIR/bin/uic"; then
+ UIC="$QTDIR/bin/uic"
+ fi
+
+@@ -160,22 +160,22 @@ echo "CFLAGS :${CFLAGS:=-Wall}"
+
+ for dirs in /bin /usr/bin /usr/local/bin /sw/bin; do
+ for make in gmake make; do
+- if ${dirs}/${make} -v 2>/dev/null | grep GNU; then
+- mak=${dirs}/${make}
++ if "${dirs}/${make}" -v 2>/dev/null | grep GNU; then
++ mak="${dirs}/${make}"
+ fi
+ done
+ done
+
+ echo
+ if test ! -z "${mak}"; then
+- echo A usable "make" executable was found in ${mak}
++ echo "A usable "make" executable was found in ${mak}"
+ else
+- echo No usable "make" executable found.
++ echo "No usable "make" executable found."
+ fi
+ echo
+
+ if test "x${err_occ}" = "xY"; then
+ echo
+- echo An error occured. Please edit 'Local.mak' manually if compiling fails.
++ echo "An error occured. Please edit 'Local.mak' manually if compiling fails."
+ fi
+
+diff -urNp xca-0.5.1.org/Rules.mak xca-0.5.1/Rules.mak
+--- xca-0.5.1.org/Rules.mak 2004-04-15 02:36:54.000000000 +0300
++++ xca-0.5.1/Rules.mak 2006-10-26 22:20:04.000000000 +0200
+@@ -2,8 +2,8 @@ include $(TOPDIR)/Local.mak
+
+ all: target.obj
+
+-ifneq ($(prefix),)
+- CFLAGS+= -DPREFIX=\"$(prefix)\"
++ifneq ($(inst_prefix),)
++ CFLAGS+= -DPREFIX=\"$(inst_prefix)\"
+ endif
+
+ ifneq ($(basedir),)
diff --git a/app-crypt/xca/files/xca-0.5.1-qt.patch b/app-crypt/xca/files/xca-0.5.1-qt.patch
new file mode 100644
index 000000000000..c6d101942ff8
--- /dev/null
+++ b/app-crypt/xca/files/xca-0.5.1-qt.patch
@@ -0,0 +1,12 @@
+diff -ur xca-0.5.1.orig/widgets/clicklabel.cpp xca-0.5.1/widgets/clicklabel.cpp
+--- xca-0.5.1.orig/widgets/clicklabel.cpp 2003-11-26 23:03:18.000000000 +0100
++++ xca-0.5.1/widgets/clicklabel.cpp 2004-12-09 20:18:02.632858864 +0100
+@@ -58,7 +58,7 @@
+ ClickLabel::ClickLabel( QWidget* parent, const char* name, WFlags f )
+ :QLabel( parent, name, f )
+ {
+- QFont font( font() );
++ QFont font;
+ font.setBold(true);
+ setFont( font );
+ setFrameShape( QLabel::Panel );
diff --git a/app-crypt/xca/xca-0.5.1-r1.ebuild b/app-crypt/xca/xca-0.5.1-r1.ebuild
index b6dee57d2143..9ed95fba9d62 100644
--- a/app-crypt/xca/xca-0.5.1-r1.ebuild
+++ b/app-crypt/xca/xca-0.5.1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.5.1-r1.ebuild,v 1.1 2006/10/06 22:41:18 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.5.1-r1.ebuild,v 1.2 2006/10/27 01:34:44 alonbl Exp $
inherit eutils kde toolchain-funcs
-DESCRIPTION="a graphical user interface to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
+DESCRIPTION="A graphical user interface to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
HOMEPAGE="http://www.hohnstaedt.de/xca.html"
SRC_URI="mirror://sourceforge/xca/${P}.tar.gz"
@@ -19,23 +19,22 @@ DEPEND=">=dev-libs/openssl-0.9.8
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gcc4.patch
- epatch ${FILESDIR}/${P}-openssl.patch
- epatch ${FILESDIR}/${P}-qt.diff
- epatch ${FILESDIR}/configure-db.patch
- echo "inst_prefix=/usr" >> Local.mak
- epatch ${FILESDIR}/Rules.mak-prefix.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build.patch"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+ epatch "${FILESDIR}/${P}-openssl.patch"
+ epatch "${FILESDIR}/${P}-qt.patch"
}
src_compile() {
kde_src_compile nothing
- CC=$(tc-getCC) prefix=/usr ./configure || die "configure died"
- inst_prefix=/usr emake || die "emake failed"
+ STRIP="true" CC="$(tc-getCC)" prefix=/usr ./configure || die "configure died"
+ echo "inst_prefix=/usr" >> Local.mak
+ inst_prefix="/usr" emake || die "emake failed"
}
src_install() {
- make destdir=${D} mandir=share/man install
+ make destdir="${D}" mandir="share/man" install
dodoc README CREDITS AUTHORS COPYRIGHT