summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-09-17 13:35:48 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-09-17 13:35:48 +0000
commit279fcd0b09acf444b698c7cde4adc7eb6c2061c4 (patch)
tree9eddd75305513f15a0eee8da3a5c52b498a22174 /app-crypt/tpm-tools/tpm-tools-1.1.0.ebuild
parentInitial commit of boxbackup, based on the work of Mark Spanbroek and Anatoly ... (diff)
downloadgentoo-2-279fcd0b09acf444b698c7cde4adc7eb6c2061c4.tar.gz
gentoo-2-279fcd0b09acf444b698c7cde4adc7eb6c2061c4.tar.bz2
gentoo-2-279fcd0b09acf444b698c7cde4adc7eb6c2061c4.zip
version bump and cleanout - bug #105799
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-crypt/tpm-tools/tpm-tools-1.1.0.ebuild')
-rw-r--r--app-crypt/tpm-tools/tpm-tools-1.1.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/tpm-tools/tpm-tools-1.1.0.ebuild b/app-crypt/tpm-tools/tpm-tools-1.1.0.ebuild
new file mode 100644
index 000000000000..82e36237ecbe
--- /dev/null
+++ b/app-crypt/tpm-tools/tpm-tools-1.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-tools/tpm-tools-1.1.0.ebuild,v 1.1 2005/09/17 13:35:48 dragonheart Exp $
+
+inherit autotools
+
+DESCRIPTION="TrouSerS' support tools for the Trusted Platform Modules"
+HOMEPAGE="http://trousers.sf.net"
+SRC_URI="mirror://sourceforge/trousers/${P}.tar.gz"
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="virtual/libc
+ >=dev-libs/openssl-0.9.7
+ >=app-crypt/trousers-0.1.1"
+# TODO: add optionnal opencryptoki support
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # workaround econf "updating config.sub" sandbox violation
+ ## (bug #96242 for instance):
+ #touch config.sub
+
+ # no translation so far -> no need to gettextize it
+ # (makes compilation a bit simpler...):
+ sed -i '/^gettextize/d' ./bootstrap.sh
+ sed -i '/\<po\>/d' Makefile.am
+ sed -i -e '/AM_GNU_GETTEXT/d' -e '\:po/Makefile.in:d' configure.in
+
+ eautoconf
+}
+
+src_compile() {
+ econf --disable-nls || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README
+}