summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2013-03-12 08:16:40 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2013-03-12 08:16:40 +0000
commit4d6145cf1a67c972d7ed345c24d40e7227b3ed0e (patch)
tree21ca698508812522611af283a2e25f865ba43093 /app-crypt/tinyca
parentsci-visualization/quickplot: Version BUmp (diff)
downloadgentoo-2-4d6145cf1a67c972d7ed345c24d40e7227b3ed0e.tar.gz
gentoo-2-4d6145cf1a67c972d7ed345c24d40e7227b3ed0e.tar.bz2
gentoo-2-4d6145cf1a67c972d7ed345c24d40e7227b3ed0e.zip
Solve openssl-1.0 compatibility, per bug#460270, thanks to Per Pomsel
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'app-crypt/tinyca')
-rw-r--r--app-crypt/tinyca/ChangeLog11
-rw-r--r--app-crypt/tinyca/files/tinyca-2.0.7.5-openssl-1.patch48
-rw-r--r--app-crypt/tinyca/tinyca-2.0.7.5-r1.ebuild68
3 files changed, 124 insertions, 3 deletions
diff --git a/app-crypt/tinyca/ChangeLog b/app-crypt/tinyca/ChangeLog
index b479e7408f79..d4030dc301bb 100644
--- a/app-crypt/tinyca/ChangeLog
+++ b/app-crypt/tinyca/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/tinyca
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/tinyca/ChangeLog,v 1.18 2012/09/18 04:46:37 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tinyca/ChangeLog,v 1.19 2013/03/12 08:16:40 alonbl Exp $
+
+*tinyca-2.0.7.5-r1 (12 Mar 2013)
+
+ 12 Mar 2013; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/tinyca-2.0.7.5-openssl-1.patch, +tinyca-2.0.7.5-r1.ebuild:
+ Solve openssl-1.0 compatibility, per bug#460270, thanks to Per Pomsel
18 Sep 2012; Tim Harder <radhermit@gentoo.org> metadata.xml:
Remove redundant maintainer from metadata.
@@ -29,4 +35,3 @@
-tinyca-2.0.7.0.ebuild, -tinyca-2.0.7.1.ebuild, -tinyca-2.0.7.2.ebuild,
+tinyca-2.0.7.3.ebuild:
version bump
-
diff --git a/app-crypt/tinyca/files/tinyca-2.0.7.5-openssl-1.patch b/app-crypt/tinyca/files/tinyca-2.0.7.5-openssl-1.patch
new file mode 100644
index 000000000000..3691d5b9cc93
--- /dev/null
+++ b/app-crypt/tinyca/files/tinyca-2.0.7.5-openssl-1.patch
@@ -0,0 +1,48 @@
+--- a/lib/OpenSSL.pm.orig 2013-03-05 15:57:46.332286060 +0100
++++ b/lib/OpenSSL.pm 2013-03-05 15:57:53.408466038 +0100
+@@ -605,6 +605,8 @@
+ # dirty fix (incompleted) --curly
+ $i = sprintf( "%x", $1);
+ $tmp->{'SERIAL'} = length($i)%2?"0".uc($i):uc($i);
++ } elsif ($_ =~ /^\s*([da-f]{2}:\w{2}:\w{2}:\w{2}:\w{2}:\w{2}:\w{2}:\w{2})\s*$/i) {
++ $tmp->{'SERIAL'} = $1;
+ } elsif ($_ =~ /Signature Algorithm.*: (\w+)/i) {
+ $tmp->{'SIG_ALGORITHM'} = $1;
+ } elsif ($_ =~ /Issuer: (.+)/i) {
+@@ -823,10 +825,10 @@
+ $cmd = "$self->{'bin'} $opts->{'cmd'}";
+ $cmd .= " -config $opts->{'config'}" if(defined($opts->{'config'}));
+ $cmd .= " -inform $opts->{'inform'}";
+- $cmd .= " -out \"$file\"";
+ if($opts->{'outform'} eq 'TEXT') {
+ $cmd .= " -text -noout";
+ } else {
++ $cmd .= " -out \"$file\"";
+ $cmd .= " -outform $opts->{'outform'}";
+ }
+
+@@ -859,13 +861,17 @@
+ }
+ }
+
+- open(IN, $file) || do {
+- my $t = sprintf(_("Can't open file %s: %s"), $file, $!);
+- GUI::HELPERS::print_warning($t);
+- return;
+- };
+- $tmp .= $_ while(<IN>);
+- close(IN);
++ if ($opts->{'outform'} eq 'TEXT') {
++ $tmp = $ext;
++ } else {
++ open(IN, $file) || do {
++ my $t = sprintf(_("Can't open file %s: %s"), $file, $!);
++ GUI::HELPERS::print_warning($t);
++ return;
++ };
++ $tmp .= $_ while(<IN>);
++ close(IN);
++ }
+
+ unlink($file);
+
diff --git a/app-crypt/tinyca/tinyca-2.0.7.5-r1.ebuild b/app-crypt/tinyca/tinyca-2.0.7.5-r1.ebuild
new file mode 100644
index 000000000000..f86b37d1c166
--- /dev/null
+++ b/app-crypt/tinyca/tinyca-2.0.7.5-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tinyca/tinyca-2.0.7.5-r1.ebuild,v 1.1 2013/03/12 08:16:40 alonbl Exp $
+
+inherit eutils
+
+MY_P="${PN}${PV/./-}"
+DESCRIPTION="Simple Perl/Tk GUI to manage a small certification authority"
+HOMEPAGE="http://tinyca.sm-zone.net/"
+SRC_URI="http://tinyca.sm-zone.net/${MY_P}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+LANGS="en de cs es sv"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND=">=dev-libs/openssl-0.9.7e
+ dev-perl/Locale-gettext
+ >=virtual/perl-MIME-Base64-2.12
+ >=dev-perl/gtk2-perl-1.072"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-2.0.7.3-compositefix.patch"
+ epatch "${FILESDIR}/${P}-openssl-1.patch"
+ sed -i -e 's:./lib:/usr/share/tinyca/lib:g' \
+ -e 's:./templates:/usr/share/tinyca/templates:g' \
+ -e 's:./locale:/usr/share/locale:g' "${S}/tinyca2"
+}
+
+src_compile() {
+ make -C po
+}
+
+locale_install() {
+ dodir /usr/share/locale/$@/LC_MESSAGES/
+ insinto /usr/share/locale/$@/LC_MESSAGES/
+ doins locale/$@/LC_MESSAGES/tinyca2.mo
+}
+
+src_install() {
+ exeinto /usr/bin
+ newexe tinyca2 tinyca
+ insinto /usr/share/tinyca/lib
+ doins lib/*.pm
+ insinto /usr/share/tinyca/lib/GUI
+ doins lib/GUI/*.pm
+ insinto /usr/share/tinyca/templates
+ doins templates/*
+ insinto /usr/share/
+ strip-linguas ${LANGS}
+ local l
+ for l in ${LANGS}; do
+ if [ "$l" != "en" ]; then
+ use linguas_$l && locale_install $l
+ fi
+ done
+}