summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hammer <mueli@gentoo.org>2008-08-19 12:58:05 +0000
committerMichael Hammer <mueli@gentoo.org>2008-08-19 12:58:05 +0000
commitff6d13671850f4ccf4c4504afe52eb29d6953653 (patch)
tree8a4538ae243ac7325851be9a02dadb58312799b4 /app-crypt/mit-krb5
parentAdded horde-webmail-1.1.2. (diff)
downloadgentoo-2-ff6d13671850f4ccf4c4504afe52eb29d6953653.tar.gz
gentoo-2-ff6d13671850f4ccf4c4504afe52eb29d6953653.tar.bz2
gentoo-2-ff6d13671850f4ccf4c4504afe52eb29d6953653.zip
revision bump to 1.6.3-r2 to fix bug #234886 with a hack - should use pkg-config
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-crypt/mit-krb5')
-rw-r--r--app-crypt/mit-krb5/ChangeLog8
-rw-r--r--app-crypt/mit-krb5/mit-krb5-1.6.3-r2.ebuild106
2 files changed, 113 insertions, 1 deletions
diff --git a/app-crypt/mit-krb5/ChangeLog b/app-crypt/mit-krb5/ChangeLog
index 56b23ef5b3fd..e83cdb9a9519 100644
--- a/app-crypt/mit-krb5/ChangeLog
+++ b/app-crypt/mit-krb5/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/mit-krb5
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/ChangeLog,v 1.183 2008/07/31 08:42:24 mueli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/ChangeLog,v 1.184 2008/08/19 12:58:05 mueli Exp $
+
+*mit-krb5-1.6.3-r2 (19 Aug 2008)
+
+ 19 Aug 2008; Michael Hammer <mueli@gentoo.org> +mit-krb5-1.6.3-r2.ebuild:
+ revision bump to 1.6.3-r2 to fix bug #234886 with a hack - should use
+ pkg-config
31 Jul 2008; Michael Hammer <mueli@gentoo.org> metadata.xml:
fixed manifest.xml due to GLEP 56
diff --git a/app-crypt/mit-krb5/mit-krb5-1.6.3-r2.ebuild b/app-crypt/mit-krb5/mit-krb5-1.6.3-r2.ebuild
new file mode 100644
index 000000000000..a45f85718dc0
--- /dev/null
+++ b/app-crypt/mit-krb5/mit-krb5-1.6.3-r2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.6.3-r2.ebuild,v 1.1 2008/08/19 12:58:05 mueli Exp $
+
+inherit eutils flag-o-matic versionator autotools
+
+PATCHV="0.3"
+MY_P=${P/mit-}
+P_DIR=$(get_version_component_range 1-2)
+DESCRIPTION="MIT Kerberos V"
+HOMEPAGE="http://web.mit.edu/kerberos/www/"
+SRC_URI="http://web.mit.edu/kerberos/dist/krb5/${P_DIR}/${MY_P}-signed.tar
+ mirror://gentoo/${P}-patches-${PATCHV}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="krb4 doc"
+
+RDEPEND="!virtual/krb5
+ || ( ( sys-libs/com_err sys-libs/ss ) ( >sys-libs/e2fsprogs-libs-1.40.11 ) )"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+S=${WORKDIR}/${MY_P}/src
+
+PROVIDE="virtual/krb5"
+
+src_unpack() {
+ unpack ${A}
+ unpack ./${MY_P}.tar.gz
+ cd "${S}"
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"
+ einfo "Regenerating configure scripts (be patient)"
+ local subdir
+ for subdir in $(find . -name configure.in \
+ | xargs grep -l 'AC_CONFIG_SUBDIRS' \
+ | sed 's@/configure\.in$@@'); do
+ ebegin "Regenerating configure script in ${subdir}"
+ cd "${S}"/${subdir}
+ eautoconf --force -I "${S}"
+ eend $?
+ done
+}
+
+src_compile() {
+ # needed to work with sys-libs/e2fsprogs-libs <- should be removed!!
+ append-flags "-I/usr/include/et"
+ econf \
+ $(use_with krb4) \
+ --enable-shared \
+ --with-system-et --with-system-ss \
+ --enable-dns-for-realm \
+ --enable-kdc-replay-cache || die
+
+ emake -j1 || die
+
+ if use doc ; then
+ cd ../doc
+ for dir in api implement ; do
+ make -C ${dir} || die
+ done
+ fi
+}
+
+src_test() {
+ einfo "Tests do not run in sandbox ..."
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ EXAMPLEDIR=/usr/share/doc/${PF}/examples \
+ install || die
+
+ keepdir /var/lib/krb5kdc
+
+ cd ..
+ dodoc README
+ dodoc doc/*.ps
+ doinfo doc/*.info*
+ dohtml -r doc/*
+
+ use doc && dodoc doc/{api,implement}/*.ps
+
+ for i in {telnetd,ftpd} ; do
+ mv "${D}"/usr/share/man/man8/${i}.8 "${D}"/usr/share/man/man8/k${i}.8
+ mv "${D}"/usr/sbin/${i} "${D}"/usr/sbin/k${i}
+ done
+
+ for i in {rcp,rlogin,rsh,telnet,ftp} ; do
+ mv "${D}"/usr/share/man/man1/${i}.1 "${D}"/usr/share/man/man1/k${i}.1
+ mv "${D}"/usr/bin/${i} "${D}"/usr/bin/k${i}
+ done
+
+ newinitd "${FILESDIR}"/mit-krb5kadmind.initd mit-krb5kadmind
+ newinitd "${FILESDIR}"/mit-krb5kdc.initd mit-krb5kdc
+
+ insinto /etc
+ newins "${D}/usr/share/doc/${PF}/examples/krb5.conf krb5.conf.example"
+ newins "${D}/usr/share/doc/${PF}/examples/kdc.conf kdc.conf.example"
+}
+
+pkg_postinst() {
+ elog "See /usr/share/doc/${PF}/html/krb5-admin.html for documentation."
+}