summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-05-01 16:54:42 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2015-05-01 16:54:42 +0000
commit0b94430511578f2548ac702f58dca354573ef7b5 (patch)
treea9f3274133cd9608a475acf2e1393587b22fed32 /app-crypt/libsecret
parentVersion bump. (diff)
downloadgentoo-2-0b94430511578f2548ac702f58dca354573ef7b5.tar.gz
gentoo-2-0b94430511578f2548ac702f58dca354573ef7b5.tar.bz2
gentoo-2-0b94430511578f2548ac702f58dca354573ef7b5.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-crypt/libsecret')
-rw-r--r--app-crypt/libsecret/ChangeLog7
-rw-r--r--app-crypt/libsecret/libsecret-0.18.2.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/app-crypt/libsecret/ChangeLog b/app-crypt/libsecret/ChangeLog
index 1cb53343bfe3..ee072576aeef 100644
--- a/app-crypt/libsecret/ChangeLog
+++ b/app-crypt/libsecret/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/libsecret
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/libsecret/ChangeLog,v 1.47 2015/04/08 07:30:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/libsecret/ChangeLog,v 1.48 2015/05/01 16:54:42 eva Exp $
+
+*libsecret-0.18.2 (01 May 2015)
+
+ 01 May 2015; Gilles Dartiguelongue <eva@gentoo.org> +libsecret-0.18.2.ebuild:
+ Version bump.
08 Apr 2015; Michał Górny <mgorny@gentoo.org> libsecret-0.16.ebuild,
libsecret-0.18.ebuild:
diff --git a/app-crypt/libsecret/libsecret-0.18.2.ebuild b/app-crypt/libsecret/libsecret-0.18.2.ebuild
new file mode 100644
index 000000000000..d994b10a43ac
--- /dev/null
+++ b/app-crypt/libsecret/libsecret-0.18.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/libsecret/libsecret-0.18.2.ebuild,v 1.1 2015/05/01 16:54:42 eva Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+VALA_MIN_API_VERSION=0.18
+VALA_USE_DEPEND=vapigen
+
+inherit gnome2 python-any-r1 vala virtualx
+
+DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
+HOMEPAGE="https://live.gnome.org/Libsecret"
+
+LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
+SLOT="0"
+IUSE="+crypt debug +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.38:2
+ crypt? ( >=dev-libs/libgcrypt-1.2.2:0= )
+ introspection? ( >=dev-libs/gobject-introspection-1.29 )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gnome-keyring-3
+"
+# Add ksecrets to RDEPEND when it's added to portage
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? (
+ dev-python/mock
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gjs-1.32
+ dev-python/pygobject:3 )
+ )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ gnome2_src_configure \
+ --enable-manpages \
+ --disable-strict \
+ --disable-coverage \
+ --disable-static \
+ $(use_enable crypt gcrypt) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ Xemake check
+}