summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-01-08 08:25:27 +0000
committerEray Aslan <eras@gentoo.org>2012-01-08 08:25:27 +0000
commit2bb7d1b3673e3727f7d341055fee8ce257687680 (patch)
tree374ad8eed1eacd8b707b514bba0cf5e43eeaaaff /app-crypt/kstart/kstart-4.1.ebuild
parentBump for #393621 (diff)
downloadgentoo-2-2bb7d1b3673e3727f7d341055fee8ce257687680.tar.gz
gentoo-2-2bb7d1b3673e3727f7d341055fee8ce257687680.tar.bz2
gentoo-2-2bb7d1b3673e3727f7d341055fee8ce257687680.zip
version bump
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/kstart/kstart-4.1.ebuild')
-rw-r--r--app-crypt/kstart/kstart-4.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/kstart/kstart-4.1.ebuild b/app-crypt/kstart/kstart-4.1.ebuild
new file mode 100644
index 000000000000..6d49428ff67d
--- /dev/null
+++ b/app-crypt/kstart/kstart-4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kstart/kstart-4.1.ebuild,v 1.1 2012/01/08 08:25:27 eras Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Modified versions of kinit for refreshing kerberos tickets
+automatically"
+HOMEPAGE="http://www.eyrie.org/~eagle/software/kstart"
+SRC_URI="http://archives.eyrie.org/software/kerberos/${P}.tar.gz"
+
+LICENSE="|| ( MIT Stanford ISC )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="afs"
+
+DEPEND="virtual/krb5
+ afs? ( net-fs/openafs )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ econf \
+ --enable-reduced-depends \
+ "$(use_with afs)" \
+ "$(use_enable afs setpag)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman k5start.1 krenew.1
+ dodoc README NEWS TODO examples/*
+}