summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryon Roche <kain@gentoo.org>2002-12-06 06:13:41 +0000
committerBryon Roche <kain@gentoo.org>2002-12-06 06:13:41 +0000
commiteccd5c0123fb4fcca2cfc1937def8038ab0b46b4 (patch)
tree34a2af4d63396ff509cf3efc11d1229c283b6b3b /app-crypt/heimdal
parentkeyword fixes (diff)
downloadgentoo-2-eccd5c0123fb4fcca2cfc1937def8038ab0b46b4.tar.gz
gentoo-2-eccd5c0123fb4fcca2cfc1937def8038ab0b46b4.tar.bz2
gentoo-2-eccd5c0123fb4fcca2cfc1937def8038ab0b46b4.zip
new setup for virtuals/krb5
Diffstat (limited to 'app-crypt/heimdal')
-rw-r--r--app-crypt/heimdal/ChangeLog7
-rw-r--r--app-crypt/heimdal/files/digest-heimdal-0.5.1-r11
-rw-r--r--app-crypt/heimdal/heimdal-0.5.1-r1.ebuild70
-rw-r--r--app-crypt/heimdal/heimdal-0.5.1.ebuild4
4 files changed, 79 insertions, 3 deletions
diff --git a/app-crypt/heimdal/ChangeLog b/app-crypt/heimdal/ChangeLog
index 37c44195cc91..10fed72edcfd 100644
--- a/app-crypt/heimdal/ChangeLog
+++ b/app-crypt/heimdal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/heimdal
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.4 2002/10/26 15:24:01 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.5 2002/12/06 06:13:41 kain Exp $
+
+*heimdal-0.5.1-r1 (05 Dec 2002)
+
+ 05 Dec 2002; Kain X <kain@kain.org> heimdal-0.5.1-r1.ebuild :
+ Initial setup for new virtual/krb5 structure
*heimdal-0.5.1 (26 Oct 2002)
diff --git a/app-crypt/heimdal/files/digest-heimdal-0.5.1-r1 b/app-crypt/heimdal/files/digest-heimdal-0.5.1-r1
new file mode 100644
index 000000000000..1a8baebe1014
--- /dev/null
+++ b/app-crypt/heimdal/files/digest-heimdal-0.5.1-r1
@@ -0,0 +1 @@
+MD5 bef2257673ddb9196702bf60c550ce53 heimdal-0.5.1.tar.gz 2979612
diff --git a/app-crypt/heimdal/heimdal-0.5.1-r1.ebuild b/app-crypt/heimdal/heimdal-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..02477221c35c
--- /dev/null
+++ b/app-crypt/heimdal/heimdal-0.5.1-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.5.1-r1.ebuild,v 1.1 2002/12/06 06:13:41 kain Exp $
+
+DESCRIPTION="Kerberos 5 implementation from KTH"
+SRC_URI="ftp://ftp.pdc.kth.se/pub/${PN}/src/${P}.tar.gz"
+HOMEPAGE="http://www.pdc.kth.se/heimdal/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc ~sparc64 ~ppc"
+IUSE="ssl ldap berkdb ipv6"
+PROVIDES="virtual/krb5"
+
+DEPEND=">=app-crypt/kth-krb-1.2.1
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ berkdb? ( sys-libs/db )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/lib/krb5
+ mv Makefile.in Makefile.in.bak
+ sed "s:LIB_crypt = @LIB_crypt@:LIB_crypt = -lssl @LIB_crypt@:g" Makefile.in.bak >Makefile.in
+}
+
+src_compile() {
+ local myconf
+
+ use ssl && myconf="--with-openssl=/usr" || myconf="--without-openssl"
+
+ use ldap && myconf="${myconf} --with-open-ldap=/usr"
+
+ use ipv6 || myconf="${myconf} --without-ipv6"
+
+ use berkdb || myconf="${myconf} --without-berkely-db"
+
+ econf --with-krb4=/usr/athena \
+ ${myconf}
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ datadir=${D}/usr/share \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodir /etc/env.d
+ cp ${FILESDIR}/01heimdal ${D}/etc/env.d
+
+ dodoc COPYRIGHT ChangeLog README NEWS PROBLEMS TODO
+
+ # Begin client rename and install
+ for i in {telnetd,ftpd}
+ do
+ mv ${D}/usr/share/man/man8/${i}.8.gz ${D}/usr/share/man/man8/k${i}.8.gz
+ mv ${D}/usr/sbin/${i} ${D}/usr/sbin/k${i}
+ done
+ for i in {rcp,rsh,telnet,ftp,rlogin}
+ do
+ mv ${D}/usr/share/man/man1/${i}.1.gz ${D}/usr/share/man/man1/k${i}.1.gz
+ mv ${D}/usr/bin/${i} ${D}/usr/bin/k${i}
+ done
+}
diff --git a/app-crypt/heimdal/heimdal-0.5.1.ebuild b/app-crypt/heimdal/heimdal-0.5.1.ebuild
index b5e3f0d8ef74..444abf614590 100644
--- a/app-crypt/heimdal/heimdal-0.5.1.ebuild
+++ b/app-crypt/heimdal/heimdal-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.5.1.ebuild,v 1.2 2002/11/30 20:29:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.5.1.ebuild,v 1.3 2002/12/06 06:13:41 kain Exp $
DESCRIPTION="Kerberos 5 implementation from KTH"
SRC_URI="ftp://ftp.pdc.kth.se/pub/${PN}/src/${P}.tar.gz"
@@ -41,7 +41,7 @@ src_compile() {
--with-krb4=/usr/athena \
${myconf} || die
- make || die
+ emake || die
}
src_install() {