summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-05-22 15:10:50 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-05-22 15:10:50 +0000
commit684edcf0c767a524374d2d6686ff7e4ceaf34e46 (patch)
treece6388c1791e62ab436a4f96445b9aea90a25406 /app-crypt/heimdal
parentVersion bump; house-cleaning; fixed homepage url (diff)
downloadgentoo-2-684edcf0c767a524374d2d6686ff7e4ceaf34e46.tar.gz
gentoo-2-684edcf0c767a524374d2d6686ff7e4ceaf34e46.tar.bz2
gentoo-2-684edcf0c767a524374d2d6686ff7e4ceaf34e46.zip
this revbump adds the execve patch for exg in bug #118508, the cracklib support in bug #118508 by Henrik Sankala, and the rshd file collision that exg told me about
(Portage version: 2.1_rc1-r4)
Diffstat (limited to 'app-crypt/heimdal')
-rw-r--r--app-crypt/heimdal/ChangeLog10
-rw-r--r--app-crypt/heimdal/files/digest-heimdal-0.7.2-r26
-rw-r--r--app-crypt/heimdal/heimdal-0.7.2-r2.ebuild140
3 files changed, 155 insertions, 1 deletions
diff --git a/app-crypt/heimdal/ChangeLog b/app-crypt/heimdal/ChangeLog
index 1ecb0696ebe7..2e146ec44b81 100644
--- a/app-crypt/heimdal/ChangeLog
+++ b/app-crypt/heimdal/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-crypt/heimdal
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.102 2006/05/22 14:50:19 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.103 2006/05/22 15:10:50 seemant Exp $
+
+*heimdal-0.7.2-r2 (22 May 2006)
+
+ 22 May 2006; Seemant Kulleen <seemant@gentoo.org>
+ +heimdal-0.7.2-r2.ebuild:
+ this revbump adds the execve patch for exg in bug #118508, the cracklib
+ support in bug #118508 by Henrik Sankala, and the rshd file collision that
+ exg told me about
22 May 2006; Seemant Kulleen <seemant@gentoo.org> heimdal-0.7.2.ebuild,
heimdal-0.7.2-r1.ebuild:
diff --git a/app-crypt/heimdal/files/digest-heimdal-0.7.2-r2 b/app-crypt/heimdal/files/digest-heimdal-0.7.2-r2
new file mode 100644
index 000000000000..15ca996cf7a8
--- /dev/null
+++ b/app-crypt/heimdal/files/digest-heimdal-0.7.2-r2
@@ -0,0 +1,6 @@
+MD5 e9f2ec2f7fe16bcab8684ca8f83ef203 heimdal-0.7.2-gentoo-patches-0.1.tar.bz2 5347
+RMD160 9e2c78b1f6a282a03ee91ecf12a974b825b520d2 heimdal-0.7.2-gentoo-patches-0.1.tar.bz2 5347
+SHA256 34be35020924673f2cc252a43fe9a8da07c7a38e625bf1ac98e2a423c20237a3 heimdal-0.7.2-gentoo-patches-0.1.tar.bz2 5347
+MD5 c937580d6f8b11bf7f0e540530e1dc18 heimdal-0.7.2.tar.gz 4525734
+RMD160 0f028a9d5a6a66e8efc0397e4d8c8adc2183b409 heimdal-0.7.2.tar.gz 4525734
+SHA256 28661862ac8cbbd62ddddbda7db760b622b903c88c06f2fbdbf7b97be47eac60 heimdal-0.7.2.tar.gz 4525734
diff --git a/app-crypt/heimdal/heimdal-0.7.2-r2.ebuild b/app-crypt/heimdal/heimdal-0.7.2-r2.ebuild
new file mode 100644
index 000000000000..7f63c8c5911e
--- /dev/null
+++ b/app-crypt/heimdal/heimdal-0.7.2-r2.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.7.2-r2.ebuild,v 1.1 2006/05/22 15:10:50 seemant Exp $
+
+inherit autotools libtool eutils virtualx toolchain-funcs
+
+PATCHVER=0.1
+PATCH_P=${P}-gentoo-patches-${PATCHVER}
+
+DESCRIPTION="Kerberos 5 implementation from KTH"
+HOMEPAGE="http://www.pdc.kth.se/heimdal/"
+SRC_URI="ftp://ftp.pdc.kth.se/pub/heimdal/src/${P}.tar.gz
+ mirror://gentoo/${PATCH_P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ssl berkdb ipv6 krb4 ldap X"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ berkdb? ( sys-libs/db )
+ krb4? ( >=app-crypt/kth-krb-1.2.2-r2 )
+ ldap? ( net-nds/openldap )
+ sys-libs/ss
+ sys-libs/com_err
+ sys-libs/cracklib
+ !virtual/krb5"
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/gcc
+ >=sys-apps/sed-4"
+
+PROVIDE="virtual/krb5"
+
+GENTOODIR=${WORKDIR}/gentoo
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ EPATCH_SUFFIX="patch" epatch ${GENTOODIR}/patches
+
+ AT_M4DIR="cf" eautoreconf
+}
+
+src_compile() {
+ local myconf=""
+
+ use krb4 \
+ && myconf="${myconf} --with-krb4-config=/usr/athena/bin/krb4-config"
+
+ use ldap && myconf="${myconf} --with-openldap=/usr"
+
+ econf \
+ $(use_with ipv6) \
+ $(use_with berkdb berkeley-db) \
+ $(use_with ssl openssl) \
+ $(use_with X x) \
+ $(use_with krb4) \
+ --enable-kcm \
+ --enable-shared \
+ --includedir=/usr/include/heimdal \
+ --libexecdir=/usr/sbin \
+ ${myconf} || die "econf failed"
+
+ emake || die
+
+ # Compile the added password checker:
+ cd ${S}/lib/kadm5
+ tc-export CC
+ ${CC} -shared -fPIC \
+ ${CFLAGS} -I${S}/include \
+ -DDICTPATH=\"/usr/$(get_libdir)/cracklib_dict\" \
+ -o sample_passwd_check.so sample_passwd_check.c -lcrack || \
+ die "Failed to compile password checker"
+}
+
+src_test() {
+ addpredict /proc/fs/openafs/afs_ioctl
+ addpredict /proc/fs/nnpfs/afs_ioctl
+
+ if use X ; then
+ KRB5_CONFIG=${S}/krb5.conf Xmake check || die
+ else
+ KRB5_CONFIG=${S}/krb5.conf make check || die
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dolib ${S}/lib/kadm5/sample_passwd_check.so
+
+ dodoc ChangeLog README NEWS TODO
+
+ # Begin client rename and install
+ for i in {telnetd,ftpd,rshd}
+ do
+ mv ${D}/usr/share/man/man8/{,k}${i}.8
+ mv ${D}/usr/sbin/{,k}${i}
+ done
+
+ for i in {rcp,rsh,telnet,ftp,su,login}
+ do
+ mv ${D}/usr/share/man/man1/{,k}${i}.1
+ mv ${D}/usr/bin/{,k}${i}
+ done
+
+ mv ${D}/usr/share/man/man5/{,k}ftpusers.5
+ mv ${D}/usr/share/man/man5/{,k}login.access.5
+
+ # Create symlinks for the includes
+ dosym heimdal /usr/include/gssapi
+ dosym heimdal/krb5-types.h /usr/include/krb5-types.h
+ dosym heimdal/krb5.h /usr/include/krb5.h
+ dosym heimdal/asn1_err.h /usr/include/asn1_err.h
+ dosym heimdal/krb5_asn1.h /usr/include/krb5_asn1.h
+ dosym heimdal/krb5_err.h /usr/include/krb5_err.h
+ dosym heimdal/heim_err.h /usr/include/heim_err.h
+ dosym heimdal/k524_err.h /usr/include/k524_err.h
+ dosym heimdal/krb5-protos.h /usr/include/krb5-protos.h
+
+ doinitd ${GENTOODIR}/configs/heimdal-kdc
+ doinitd ${GENTOODIR}/configs/heimdal-kadmind
+ doinitd ${GENTOODIR}/configs/heimdal-kpasswdd
+
+ insinto /etc
+ newins ${GENTOODIR}/configs/krb5.conf krb5.conf.example
+
+ sed -i "s:/lib:/$(get_libdir):" ${D}/etc/krb5.conf.example
+
+ if use ldap; then
+ insinto /etc/openldap/schema
+ doins ${GENTOODIR}/configs/krb5-kdc.schema
+ fi
+
+ # default database dir
+ keepdir /var/heimdal
+}