summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2014-07-31 13:39:02 +0000
committerKristian Fiskerstrand <k_f@gentoo.org>2014-07-31 13:39:02 +0000
commitd14df7c737c0deb647c548e8abb04da11516a10b (patch)
treee988c02be1b77e2eb0e6f5ddf06ee5430ec8718e /app-crypt/gpgme
parentInitial bump. Based on Kent's ebuild from perl-experimental (diff)
downloadgentoo-2-d14df7c737c0deb647c548e8abb04da11516a10b.tar.gz
gentoo-2-d14df7c737c0deb647c548e8abb04da11516a10b.tar.bz2
gentoo-2-d14df7c737c0deb647c548e8abb04da11516a10b.zip
Revbump with backported patch for security bug #518646 (CVE-2014-3564)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xFC3B17DE05E136A0!)
Diffstat (limited to 'app-crypt/gpgme')
-rw-r--r--app-crypt/gpgme/ChangeLog8
-rw-r--r--app-crypt/gpgme/files/gpgme-1.3.2-CVE-2014-3564.patch24
-rw-r--r--app-crypt/gpgme/gpgme-1.3.2-r1.ebuild46
3 files changed, 77 insertions, 1 deletions
diff --git a/app-crypt/gpgme/ChangeLog b/app-crypt/gpgme/ChangeLog
index f642d7c26135..41734beea770 100644
--- a/app-crypt/gpgme/ChangeLog
+++ b/app-crypt/gpgme/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/gpgme
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/ChangeLog,v 1.209 2014/07/31 10:00:31 k_f Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/ChangeLog,v 1.210 2014/07/31 13:39:02 k_f Exp $
+
+*gpgme-1.3.2-r1 (31 Jul 2014)
+
+ 31 Jul 2014; Kristian Fiskerstrand <k_f@gentoo.org>
+ +files/gpgme-1.3.2-CVE-2014-3564.patch, +gpgme-1.3.2-r1.ebuild:
+ Revbump with backported patch for security bug #518646 (CVE-2014-3564)
*gpgme-1.5.1 (31 Jul 2014)
*gpgme-1.4.4 (31 Jul 2014)
diff --git a/app-crypt/gpgme/files/gpgme-1.3.2-CVE-2014-3564.patch b/app-crypt/gpgme/files/gpgme-1.3.2-CVE-2014-3564.patch
new file mode 100644
index 000000000000..37e9eb1360a1
--- /dev/null
+++ b/app-crypt/gpgme/files/gpgme-1.3.2-CVE-2014-3564.patch
@@ -0,0 +1,24 @@
+diff -r 71644dea35c8 src/engine-gpgsm.c
+--- a/src/engine-gpgsm.c Thu Jul 31 14:06:58 2014 +0200
++++ b/src/engine-gpgsm.c Thu Jul 31 14:10:25 2014 +0200
+@@ -834,7 +834,7 @@
+ else
+ {
+ *aline = newline;
+- gpgsm->colon.attic.linesize += linelen + 1;
++ gpgsm->colon.attic.linesize = *alinelen + linelen + 1;
+ }
+ }
+ if (!err)
+diff -r 71644dea35c8 src/engine-uiserver.c
+--- a/src/engine-uiserver.c Thu Jul 31 14:06:58 2014 +0200
++++ b/src/engine-uiserver.c Thu Jul 31 14:10:25 2014 +0200
+@@ -699,7 +699,7 @@
+ else
+ {
+ *aline = newline;
+- uiserver->colon.attic.linesize += linelen + 1;
++ uiserver->colon.attic.linesize = *alinelen + linelen + 1;
+ }
+ }
+ if (!err)
diff --git a/app-crypt/gpgme/gpgme-1.3.2-r1.ebuild b/app-crypt/gpgme/gpgme-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..d47326e94b7a
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-1.3.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-1.3.2-r1.ebuild,v 1.1 2014/07/31 13:39:02 k_f Exp $
+
+EAPI="4"
+
+inherit eutils libtool autotools
+
+DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
+HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
+SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="common-lisp static-libs"
+
+DEPEND="app-crypt/gnupg
+ >=dev-libs/libassuan-2.0.2
+ >=dev-libs/libgpg-error-1.4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.1.8-et_EE.patch"
+ epatch "${FILESDIR}/${P}-CVE-2014-3564.patch"
+
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --includedir="${EPREFIX}/usr/include/gpgme" \
+ --with-gpg="${EPREFIX}/usr/bin/gpg" \
+ --with-gpgsm="${EPREFIX}/usr/bin/gpgsm" \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ if ! use common-lisp; then
+ rm -fr "${ED}usr/share/common-lisp"
+ fi
+}