summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-13 11:01:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-13 11:01:55 +0000
commit3ca5cdd1dd6e46971deaa1d334de4a3d9f5aee0c (patch)
tree64d9459a5b169dcabc64c994a1e62daccdb877dc /app-crypt/chntpw
parentFixed build failure against ghc-6.12.2+ (bug #327903) (diff)
downloadgentoo-2-3ca5cdd1dd6e46971deaa1d334de4a3d9f5aee0c.tar.gz
gentoo-2-3ca5cdd1dd6e46971deaa1d334de4a3d9f5aee0c.tar.bz2
gentoo-2-3ca5cdd1dd6e46971deaa1d334de4a3d9f5aee0c.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/chntpw')
-rw-r--r--app-crypt/chntpw/ChangeLog9
-rw-r--r--app-crypt/chntpw/chntpw-080526.ebuild37
-rw-r--r--app-crypt/chntpw/chntpw-100627.ebuild44
3 files changed, 51 insertions, 39 deletions
diff --git a/app-crypt/chntpw/ChangeLog b/app-crypt/chntpw/ChangeLog
index 4036db3624ce..3c00782805cf 100644
--- a/app-crypt/chntpw/ChangeLog
+++ b/app-crypt/chntpw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/chntpw
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/ChangeLog,v 1.16 2009/10/28 04:18:27 robbat2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/ChangeLog,v 1.17 2010/07/13 11:01:55 ssuominen Exp $
+
+*chntpw-100627 (13 Jul 2010)
+
+ 13 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> +chntpw-100627.ebuild:
+ Version bump.
28 Oct 2009; Robin H. Johnson <robbat2@gentoo.org> chntpw-080526.ebuild:
Keyword for ~amd64.
diff --git a/app-crypt/chntpw/chntpw-080526.ebuild b/app-crypt/chntpw/chntpw-080526.ebuild
deleted file mode 100644
index 60faa1151f7e..000000000000
--- a/app-crypt/chntpw/chntpw-080526.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/chntpw-080526.ebuild,v 1.4 2009/10/28 04:18:27 robbat2 Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="Offline Windows NT Password & Registry Editor"
-HOMEPAGE="http://home.eunet.no/~pnordahl/ntpasswd/"
-SRC_URI="http://home.eunet.no/~pnordahl/ntpasswd/${PN}-source-${PV}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="static"
-
-RDEPEND="dev-libs/openssl"
-DEPEND="app-arch/unzip"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i -e "/^CC/s/gcc/$(tc-getCC)/" \
- Makefile || die "sed failed"
-}
-
-src_compile() {
- #Makefile is hardcoded, override the defaults with the user's settings.
- emake LIBS="-lcrypto" CFLAGS="${CFLAGS}" || die "emake failed"
-}
-
-src_install() {
- dobin chntpw
- use static && dobin chntpw.static
- dobin cpnt
- dodoc HISTORY.txt README.txt regedit.txt WinReg.txt
-}
diff --git a/app-crypt/chntpw/chntpw-100627.ebuild b/app-crypt/chntpw/chntpw-100627.ebuild
new file mode 100644
index 000000000000..2c0d9a27588b
--- /dev/null
+++ b/app-crypt/chntpw/chntpw-100627.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/chntpw-100627.ebuild,v 1.1 2010/07/13 11:01:55 ssuominen Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Offline Windows NT Password & Registry Editor"
+HOMEPAGE="http://pogostick.net/~pnh/ntpasswd/"
+SRC_URI="http://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ sed -i \
+ -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' \
+ Makefile || die
+
+ emake clean || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -DUSEOPENSSL -Wall" \
+ LIBS="-lcrypto" || die
+}
+
+src_install() {
+ dobin chntpw cpnt reged || die
+
+ if use static; then
+ dobin {chntpw,reged}.static || die
+ fi
+
+ dodoc {HISTORY,README,regedit,WinReg}.txt || die
+}