summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-06-18 21:39:45 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-06-18 21:39:45 +0000
commit061a72f0da2ba185c09205e26e5c91e1a0831fd3 (patch)
tree73c15816da0f513dd06cce7ac078f4c18d417a6d /app-crypt/bcrypt/bcrypt-1.1.ebuild
parentInitial import. (diff)
downloadgentoo-2-061a72f0da2ba185c09205e26e5c91e1a0831fd3.tar.gz
gentoo-2-061a72f0da2ba185c09205e26e5c91e1a0831fd3.tar.bz2
gentoo-2-061a72f0da2ba185c09205e26e5c91e1a0831fd3.zip
Initial import.
Diffstat (limited to 'app-crypt/bcrypt/bcrypt-1.1.ebuild')
-rw-r--r--app-crypt/bcrypt/bcrypt-1.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-crypt/bcrypt/bcrypt-1.1.ebuild b/app-crypt/bcrypt/bcrypt-1.1.ebuild
new file mode 100644
index 000000000000..9f98e49ba038
--- /dev/null
+++ b/app-crypt/bcrypt/bcrypt-1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcrypt/bcrypt-1.1.ebuild,v 1.1 2003/06/18 21:39:41 absinthe Exp $
+
+DESCRIPTION="A file encryption utility using Paul Kocher's implementation of the blowfish algorithm"
+HOMEPAGE="http://bcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86 ppc sparc alpha"
+IUSE=""
+DEPEND="sys-libs/zlib"
+
+src_compile() {
+ sed -e "s:CFLAGS = -O2 -Wall:CFLAGS = -Wall ${CFLAGS}:" Makefile > Makefile.new
+ mv Makefile.new Makefile
+ make || die
+}
+
+src_install() {
+ dobin bcrypt
+ dodoc LICENSE README
+ doman bcrypt.1
+}