summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2010-08-13 17:53:52 +0000
committerDaniel Pielmeier <billie@gentoo.org>2010-08-13 17:53:52 +0000
commit6d1fec3d5b443f4d418af4aae937281d232f2b56 (patch)
tree6de72dca25df8c9bc623fd4797984bf2bc7b0c75 /app-cdr/backlite/backlite-1.0.1.ebuild
parentVersion bump, drop old. (diff)
downloadgentoo-2-6d1fec3d5b443f4d418af4aae937281d232f2b56.tar.gz
gentoo-2-6d1fec3d5b443f4d418af4aae937281d232f2b56.tar.bz2
gentoo-2-6d1fec3d5b443f4d418af4aae937281d232f2b56.zip
Version bump. Remove old.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'app-cdr/backlite/backlite-1.0.1.ebuild')
-rw-r--r--app-cdr/backlite/backlite-1.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-cdr/backlite/backlite-1.0.1.ebuild b/app-cdr/backlite/backlite-1.0.1.ebuild
new file mode 100644
index 000000000000..0ccd9627075e
--- /dev/null
+++ b/app-cdr/backlite/backlite-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/backlite/backlite-1.0.1.ebuild,v 1.1 2010/08/13 17:53:52 billie Exp $
+
+EAPI=2
+
+inherit qt4-r2
+
+DESCRIPTION="backlite is a pure QT4 version of k9copy"
+HOMEPAGE="http://k9copy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/k9copy/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mplayer"
+
+# According to the author of backlite/k9copy libdvdread and libdvdnav are
+# bundled internal because newer versions produce bad DVD copies.
+# This will be fixed later.
+# DEPEND="media-libs/libdvdread"
+
+DEPEND=">=media-libs/libmpeg2-0.5.1
+ media-video/ffmpeg
+ x11-libs/qt-gui:4[dbus]
+ || ( x11-libs/qt-phonon:4 media-sound/phonon )"
+
+RDEPEND="${DEPEND}
+ media-video/dvdauthor
+ mplayer? ( media-video/mplayer )"
+
+src_configure() {
+ eqmake4 backlite.pro PREFIX="${D}"/usr
+}
+
+src_install() {
+ emake install || die "emake install failed"
+}